Bug Hunting Session
Bug 65994 - Dutch spell checking does not work, other languages work doubtfull
Summary: Dutch spell checking does not work, other languages work doubtfull
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other Windows (All)
: medium major
Assignee: Thomas van der Meulen
URL:
Whiteboard: target:4.2.0 target:4.1.0.2 target:4.0.5
Keywords: regression
: 66210 66253 66264 66443 66757 66856 67475 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-06-21 05:56 UTC by Winfried Donkers
Modified: 2013-07-29 16:23 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
old file, don't download (719.45 KB, application/x-zip-compressed)
2013-06-21 14:56 UTC, Thomas van der Meulen
Details
old file, don't download (719.28 KB, application/zip)
2013-06-21 16:05 UTC, Thomas van der Meulen
Details
fix voor Nederlandse spelling corrector 2.0 (693.07 KB, application/zip)
2013-07-29 16:21 UTC, Thomas van der Meulen
Details
fix for dutch spell corrector 2.0 (en) (692.16 KB, application/zip)
2013-07-29 16:22 UTC, Thomas van der Meulen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Donkers 2013-06-21 05:56:07 UTC
Since version 4.0.4 the Dutch spelling correction no longer works.
This applies to Windows XP/7 and Linux (openSUSE and Ubuntu).
It applies to upgraded installations (from 3.6, 4.0.2 and 4.0.3) and to clean installations.

behaviour:
-open a new document
-type a Dutch word (fiets)
-it is marked with a red wavy line below it
-on pressing the right mouse key with the cursor on the word, no suggestions for correct spelling appear
-when the word has been selected, and the menu option extra-language-selection is chosen, Frisian (once Catalan!) was shown apart from Dutch and no other languages (not even English). Frisian (or Catalan) was not 'installed' as used language, but chosing it (Catalan too!) makes the red wavy line disappear. Adding a new language sometimes works (e.g. English GB) correctly, but on other occasions it does not (e.g. Catalan, Chuvash).

I checked on master (4.2.0.0.alpha+), and there the behaviuour is not identical, but also incorrect. two words: fiets (Dutch) and Farad (incorrect German) are both shown as correct in Dutch, German, Catalan, Chuvash and are both shown as incorrect in English-US.
Comment 1 Winfried Donkers 2013-06-21 06:08:07 UTC
Additional note:
Some words do get suggestions for correct spelling (with language set to Dutch) and words personally added to the list are checked correctly.

The word 'These' (not a Dutch word) gets the suggestion 'The' (not Dutch either); the word 'The' is shown as if spelled correctly.
Comment 2 Cor Nouws 2013-06-21 09:06:02 UTC
temporary fix: 
- copy folder dict-nl from e.g. 4.0.3
- See

 <install>/libreoffice4.0/share/extensions/dict-nl

cuased by bug 63033 ?
Comment 3 Thomas van der Meulen 2013-06-21 11:59:38 UTC
This bug doesn't accure on mac osx 10.8.3. 
@Joren could you please test this bug on your mac machine to make sure?
Comment 4 Thomas van der Meulen 2013-06-21 12:56:31 UTC
Found out what the problem was and trying to fix this as fast as posible.
Comment 5 Thomas van der Meulen 2013-06-21 14:04:55 UTC
A temporary fix can be found here: https://pje335.wordpress.com
Comment 6 Thomas van der Meulen 2013-06-21 14:56:21 UTC
Created attachment 81172 [details]
old file, don't download
Comment 7 Cor Nouws 2013-06-21 15:06:16 UTC
(In reply to comment #6)
> Created attachment 81172 [details] fix voor Nederlandse spelling corrector

Thanks Thomas!

All:        it's simply the file "nl-NL.dic" that needs to be replaced.
Location:   <installatie>\LibreOffice 4.0\share\extensions\dict-nl 
File + info are in the attached zip
Comment 8 Thomas van der Meulen 2013-06-21 16:05:43 UTC
Created attachment 81175 [details]
old file, don't download
Comment 9 Thomas van der Meulen 2013-06-23 09:33:11 UTC
Patch is under review, waiting for some one to approve. 
see: https://gerrit.libreoffice.org/#/c/4451/
Comment 10 bugquestcontri 2013-06-24 02:51:44 UTC
May I a draw attention also to https://bugs.freedesktop.org/show_bug.cgi?id=66051

I provided there test material.
Comment 11 Thomas van der Meulen 2013-06-26 16:46:29 UTC
*** Bug 66210 has been marked as a duplicate of this bug. ***
Comment 12 Thomas van der Meulen 2013-06-27 12:45:05 UTC
*** Bug 66253 has been marked as a duplicate of this bug. ***
Comment 13 Thomas van der Meulen 2013-06-27 16:14:20 UTC
*** Bug 66264 has been marked as a duplicate of this bug. ***
Comment 14 Commit Notification 2013-06-27 16:26:39 UTC
pje335_NL committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=92a907ab17814a8e08ab787745fefb85ed00d3f3

Fix for broken dutch spell checker fdo#65994 and fdo#63033



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Thomas van der Meulen 2013-06-27 18:16:21 UTC
Oke the fix is pushed to master, if anybody know how to push it to 4.0 brance please let me know :-)
Comment 16 Commit Notification 2013-06-27 18:56:23 UTC
pje335_NL committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=ec1372f7e0f78ff84b90a9d61aa4e3e389008f99&h=libreoffice-4-1

Fix for broken dutch spell checker fdo#65994 and fdo#63033


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2013-06-27 18:56:43 UTC
pje335_NL committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/dictionaries/commit/?id=819d3e52131cfca7a3bb72e1e91fece30ceef41a&h=libreoffice-4-0

Fix for broken dutch spell checker fdo#65994 and fdo#63033


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Jorendc 2013-07-01 08:22:58 UTC
Looks fixed using Mac OSX 10.8.4 with LibreOffice Version: 4.2.0.0.alpha0+
Build ID: 9ab800829b8a0e44824dc11276b54b1870bc5b2b

I'll try to test later this evening on a Windows 8 to confirm it works also on other platforms.

Thanks Thomas!
Comment 19 Jorendc 2013-07-01 08:40:32 UTC
*** Bug 66443 has been marked as a duplicate of this bug. ***
Comment 20 Thomas van der Meulen 2013-07-04 14:17:58 UTC
User reports that the fix doesn't work in Windows 8... could someone please confirm this? thank you
Comment 21 Jorendc 2013-07-05 07:24:48 UTC
@thomas: reopened a bit too soon I guess :). As I mentioned in my email on the Dutch mailinglist I said the problem is rather my OS (W8) then LibreOffice :).

Confirmed it is fixed on the Dutch Mailinglist -> resolved fixed
Comment 22 Peter 2013-07-05 14:17:23 UTC
(In reply to comment #21)
> @thomas: reopened a bit too soon I guess :). As I mentioned in my email on
> the Dutch mailinglist I said the problem is rather my OS (W8) then
> LibreOffice :).
> 
> Confirmed it is fixed on the Dutch Mailinglist -> resolved fixed

Isn't that a bit to easy as a reply? It's a Win8 problem? What do we do then? search for another office suite? I like LibreOffice so I want to use it in Win 8.
Comment 23 Jorendc 2013-07-05 17:03:28 UTC
(In reply to comment #22) 
> Isn't that a bit to easy as a reply? It's a Win8 problem? What do we do
> then? search for another office suite? I like LibreOffice so I want to use
> it in Win 8.

True, but if it's indeed broken on Windows 8 (really don't know, could be just a setting somewhere) my test related to _this_ bug isn't relevant. For now no spellings correction work at all (Dutch, nor English, French, ...) I'll do next days some more tests and create a bug report for it if necessary.

Others did confirm this is fixed, so RESOLVED FIXED is still valid for this bug.

Kind regards,
Joren
Comment 24 Cor Nouws 2013-07-10 08:52:04 UTC
*** Bug 66757 has been marked as a duplicate of this bug. ***
Comment 25 Cor Nouws 2013-07-10 08:53:31 UTC
(In reply to comment #24)
> *** Bug 66757 has been marked as a duplicate of this bug. ***

But the reporter there, mentions it is broken in 4.1.0.2 on Win 7.. 
Waiting for his comments here..
Comment 26 Maarten 2013-07-10 20:12:11 UTC
Hi Cor,
The problem is still there. I run several machines on Windows 7, all fully
updated (e.g. running java 7 update 25) and all show same problem. All text
which is put in  a dcoument is marked as 'false' (or not known in library).
It means all text is underlined in red.
I installed as an extension the latest 'Opentaal' dictoinary.. in the
extension menu there was a message that i already had installed this
version. I installed anyway, but problem is still there.
However, it seems that extension Language tool is working fine now.
Bye,
Maarten




2013/7/10 <bugzilla-daemon@freedesktop.org>

>   *Comment # 25 <https://bugs.freedesktop.org/show_bug.cgi?id=65994#c25>on bug
> 65994 <https://bugs.freedesktop.org/show_bug.cgi?id=65994> from Cor Nouws<cno@nouenoff.nl>
> *
>
> (In reply to comment #24 <https://bugs.freedesktop.org/show_bug.cgi?id=65994#c24>)
> > *** Bug 66757 <https://bugs.freedesktop.org/show_bug.cgi?id=66757> has been marked as a duplicate of this bug. ***
>
>
> But the reporter there, mentions it is broken in 4.1.0.2 on Win 7..
> Waiting for his comments here..
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>
>
Comment 27 Jorendc 2013-07-10 20:47:43 UTC
Hi Andras,

I'm sorry I'm bugging you this much lately, but we have a strange problem here. Dutch spelling corrector is working using Mac OSX (10.8.4), Linux (Mint 15 x64), but doesn't on Windows.

Any thoughts?

Thanks in advance,
Joren
Comment 28 Cor Nouws 2013-07-12 14:40:30 UTC
*** Bug 66856 has been marked as a duplicate of this bug. ***
Comment 29 Thomas van der Meulen 2013-07-20 05:43:42 UTC
I have sent a "patch" to gerrit to downgrade the spellchecker back to version 2.00 because I had the old files saved just in case.
( https://gerrit.libreoffice.org/#/c/4987/ )

I also cannot follow on with OS it is working and on with not. 
so could you all please help me out with filling this spread sheet

https://docs.google.com/spreadsheet/ccc?key=0AhAABMSoIAfmdENpZGw5em0wZ0NHdWNZR3F3SFNJZVE&usp=sharing

Merci!
Comment 30 Thomas van der Meulen 2013-07-20 09:03:14 UTC
Oke, canceled the downgrade because maby it is a bit to soon to do that, but I am confused with witch OS the problem still happens so could you please fill out the spreadsheet 

Merci!
Comment 31 Joop Lanting 2013-07-20 10:23:33 UTC
Thomas, let een beetje op je Engels:

een 'witch' is een HEKS.

Straks snapt niemand meer waar het over gaat ....
;JOOP!
Comment 32 Thomas van der Meulen 2013-07-20 11:23:15 UTC
---------------------------- update of comment 30 --------------------------------
Oke, canceled the downgrade because maybe it is a bit to soon to do that, but I am confused with which OS the problem still happens. 
If you all who had/still have problems could help me filling out the spreadsheet I would appreciate that and it would be easier for me to understand were this bug still occurs.
Comment 33 Peter 2013-07-20 15:15:02 UTC
Even with the latest release (4.1) it still doens't work on a Windows 8 machine. It still underlines every word in Dutch and Dutch BE
Comment 34 Thomas van der Meulen 2013-07-20 15:45:33 UTC
oke, still find it strange that it isn't working under Windows 8 so I have sent the patch for the downgrade again to Gerrit.
Comment 35 Thomas van der Meulen 2013-07-22 18:09:08 UTC
oke, it is downgraded back to 2.00 (same as was before I messed up)
Comment 36 Cor Nouws 2013-07-29 13:45:56 UTC
*** Bug 67475 has been marked as a duplicate of this bug. ***
Comment 37 Thomas van der Meulen 2013-07-29 16:21:11 UTC
Created attachment 83214 [details]
fix voor Nederlandse spelling corrector 2.0
Comment 38 Thomas van der Meulen 2013-07-29 16:22:35 UTC
Created attachment 83215 [details]
fix for dutch spell corrector 2.0 (en)