Bug Hunting Session
Bug 66012 - Extension: outdated extension version listed on extension page of MRI - UNO Object Inspection Tool
Summary: Extension: outdated extension version listed on extension page of MRI - UNO O...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-21 14:57 UTC by Przemek
Modified: 2017-08-16 08:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Przemek 2013-06-21 14:57:43 UTC
Problem description: 
<http://extensions.libreoffice.org/extension-center/mri-uno-object-inspection-tool/releases/1.1.4/mri-1-1-4.oxt> is some junk HTML content misleadingly named with an ".oxt" extension.

Stephan described this problem in another bug: https://bugzilla.redhat.com/show_bug.cgi?id=966796.

Steps to reproduce:
1. Download extension 
3. Try to install extension.

Current behavior:
Installs blank extension that does nothing.

Expected behavior:
The extension shall be successfuly installed. (As with previous version 1.1.2).
              
Operating System: All
Version: 4.0.4.2 release
Comment 1 Julien Nabet 2013-06-22 21:49:13 UTC
Pzemek: http://extensions.services.openoffice.org/fr/node/201/releases shows there's an 1.2.0 version but indeed, http://extensions.libreoffice.org/extension-center/mri-uno-object-inspection-tool shows only 1.1.2

Andreas: thought you might be interested in this tracker, if I'm wrong, sorry for the noise.
Comment 2 Przemek 2013-06-23 12:55:47 UTC
Thanks Julien.
Przemek 

(In reply to comment #1)
> Pzemek: http://extensions.services.openoffice.org/fr/node/201/releases shows
> there's an 1.2.0 version but indeed,
> http://extensions.libreoffice.org/extension-center/mri-uno-object-inspection-
> tool shows only 1.1.2
> 
> Andreas: thought you might be interested in this tracker, if I'm wrong,
> sorry for the noise.
Comment 3 retired 2013-06-24 09:34:56 UTC
version 1.2 of the extension installs fine, thus

* adjusting title
* setting to NEW.

The working version of the extension in question (1.2.0) can be found here: http://extensions.services.openoffice.org/fr/node/201/releases

LO Extension page lists 1.1.4 as latest release: http://extensions.libreoffice.org/extension-center/mri-uno-object-inspection-tool

I can't log-in on the extension page. Also it's totally unclear how to mark extensions as broken on the extension page. This leads to the general issue that the extension management currently in total is rather flakey. Hope we can come up with a good way of dealing with this and showing very clearly to the user, which extensions do and which don't work or are in need of an update. But that would be another bug in itself I guess.
Comment 4 QA Administrators 2015-03-16 23:28:24 UTC Comment hidden (obsolete, spam)
Comment 5 tommy27 2016-04-16 07:22:51 UTC Comment hidden (obsolete, spam)
Comment 6 QA Administrators 2017-05-22 13:22:16 UTC Comment hidden (obsolete, spam)
Comment 7 Jean-Baptiste Faure 2017-08-16 08:49:43 UTC
This extension has been released on 2013-07-17, then after this bug has been reported. Both versions 1.1.2 and 1.1.4 are not empty and are real archives. They do not install on LO 5.4 (error message), but it is expected because they are said compatible with LO 3.3, 3.4 and 3.5; nothing about LO 4.x and 5.x.

Seeing that an upload has been done on the extensions website after the bug report, I guess this bug is fixed. The extension works or not on current LO versions is another story.

Best regards. JBF