Bug 66017 - FILEOPEN: DOCX chart is missing labels and pdf export cuts off text
Summary: FILEOPEN: DOCX chart is missing labels and pdf export cuts off text
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.0.4.1 rc
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:emf, filter:pdf
Depends on:
Blocks: OOXML-Chart PDF-Export EMF-WMF Chart-Labels
  Show dependency treegraph
 
Reported: 2013-06-21 17:34 UTC by jflowers
Modified: 2017-09-21 21:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
source document (25.84 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-06-21 17:34 UTC, jflowers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jflowers 2013-06-21 17:34:58 UTC
Created attachment 81179 [details]
source document

I have a web service that relies on libreoffice to convert different file types to pdfs. It works great for most documents, but this particular document (attached) does not get parsed into a PDF correctly.

In fact if I simply open this document in libreoffice on my desktop machine, it is unable to properly show the document.

Apologizes in advance if this is a known issue.
Comment 1 Thomas van der Meulen 2013-06-21 17:58:45 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 on Mac osx 10.8.4. 

It looks like the picture if cut off, since it doesn't open it good it also doesn't export it good to pdf.
Comment 2 QA Administrators 2015-04-19 03:21:37 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2015-06-16 16:38:03 UTC
Compared with Word viewer, the chart is missing all labels and legends.

PDF export cuts a part of the text in the upper box.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 80ec99db4325a439a8a3f1d420d0a80f8bf9c439
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-16_00:00:20
Locale: fi-FI (fi_FI)
Comment 4 QA Administrators 2016-09-20 10:02:14 UTC Comment hidden (obsolete)
Comment 5 Telesto 2016-12-10 15:29:30 UTC
Repro with:
Version: 5.4.0.0.alpha0+
Build ID: b894104a0b02a9b074c76feb925389d7bee6a493
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-10_01:00:52
Locale: nl-NL (nl_NL); Calc: CL

File is containing an EMF
Comment 6 V Stuart Foote 2017-04-14 05:10:25 UTC
Not sure about the OP's headless conversion, but handling the embedded EMF suffers from issue of bug 104252 -- it is perfect with CPU only, , but clipping occurs with GPU Hardware acceleration enabled.
Comment 7 Xisco Faulí 2017-09-21 21:42:12 UTC
Label problem no longer reproduced in

Version: 6.0.0.0.alpha0+
Build ID: 86f256596c8566e80993e1cf6035bc3534b6f816
CPU threads: 4; OS: Linux 4.10; UI render: GL; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Closing as RESOLVED WORKSFORME

[Improvement found by office-interoperability-tools]