Bug Hunting Session
Bug 66054 - Amharic rendered as gibberish in fontwork
Summary: Amharic rendered as gibberish in fontwork
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 66098 (view as bug list)
Depends on:
Blocks: FontWork-WordArt
  Show dependency treegraph
 
Reported: 2013-06-22 18:15 UTC by Samson
Modified: 2019-01-13 07:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Font work (317.85 KB, image/png)
2018-01-02 23:50 UTC, Samson
Details
Font work (282.92 KB, image/png)
2018-01-02 23:56 UTC, Samson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samson 2013-06-22 18:15:37 UTC
Problem description: font work doesn't work. 

Steps to reproduce:font work 
1. ....Opend font work and typed what I want.
2. ....I typed in Amharic it rights good but when i press enter it doesn't show what I typed.
3. ....It shows different characters  

Current behavior:It is the same 

Expected behavior:It should have shown what I typed like libreOffice 3.6

If you want i can send a picture.
Thanks for putting the Amharic help file. but inside is empty.

Thanks
Samson 

              
Operating System: Linux (Other)
Version: 4.1.0.1 rc
Comment 1 Julien Nabet 2013-06-22 20:41:32 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.

Samson: Could you try to retrieva a backtrace? (see 
https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_on_Linux)
About Amharic help file, could you please fill a new bug? It's simpler to follow bugs when there's 1 per bugtracker.
Comment 2 Regina Henschel 2013-06-22 21:32:32 UTC
Please attach a Writer document with normal Amharic text and with fontwork in Amharic.
Comment 3 Khaled Hosny 2013-06-24 18:13:45 UTC
*** Bug 66098 has been marked as a duplicate of this bug. ***
Comment 4 Khaled Hosny 2013-06-25 12:24:04 UTC
Bug 66098 has a sample file, and I think I can reproduce the issue. When I open the file the Amharic fontwork shows just some random characters, if I replace it with, say, Arabic text it gets rendered fine. Looks like a case of broken font fallback to me (the layout is done with a fallback font but the final drawing uses the base font).
Comment 5 QA Administrators 2015-03-16 23:25:38 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2015-03-31 08:19:12 UTC
I see squares in the Amharic fontwork in attachment 81355 [details].

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 8c3cf9dd48e40604867d3a28bddaccd65142df17
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-03-27_15:15:18
Locale: fi_FI
Comment 7 tommy27 2016-04-16 07:23:39 UTC Comment hidden (obsolete)
Comment 8 Samson 2016-04-27 14:49:59 UTC
Hello!

This bug started when Libre Offfice started the version 4.0. before that it was working good. But when the version 4.0 started and after that till 5.1.2.1 the problem is still here. But if you go to version 3.4 or older it used to work good.If you put this fonts in Open Office in any version it work perfect. I will just write some words so you can try it in fonts work.

ሊብሬ ቢሮ = libre Office
ሰላም አለም = Hello world 
ሰላም ይዋሉ = have a nice day

copy this fonts and see it libre Office and Open Office and see the difference

Thanks
Samson
Comment 9 Buovjaga 2016-04-27 16:08:30 UTC
Samson: what about version 3.5 and 3.6? Did it work ok in them? You can test with the old versions: https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 10 Samson 2016-04-27 17:45:42 UTC
Hello! 

Yes it was working perfectly. when you start Libre Office version 4.0 and above that is when the problem starts. I tried every libre office to the last one 5.1.2.1 it is not working. If you have the older version libre Office less than 4.0 it works fine any thing above 4.0 it is not working. Did you try it so you can see the problem for yourself. 

Thanks 
Samson
Comment 11 Samson 2017-05-05 14:14:26 UTC
Hi Yousuf Philips

Nothing changed. I am on libre 5.2. the problem still exists but if I try the same thing in any open Office it works perfect. check it in any Open Office.

Thanks 

Samson
Comment 12 Samson 2018-01-02 23:50:38 UTC
Created attachment 138830 [details]
Font work
Comment 13 Samson 2018-01-02 23:56:12 UTC
Created attachment 138831 [details]
Font work

This is the letters I used = የ ፊደል ስራዎች copy and paste it in Open Office it works perfwct but when you paste it in Libre Office it will break it should be like Open office. It is been 5 years since I file this bug.

Thanks 
Samson
Comment 14 Buovjaga 2018-06-30 12:31:11 UTC
Weird: with version 3.5.0 on Windows, I see the text rendered fine, but on Ubuntu 14.04 the oldest build in 43all bibisect repo (3.5.0), I see it wrong.
Same result when done from scratch.

Thus I cannot bibisect.

The top text in the example file uses FreeSerif (exists on the Ubuntu install) while the lower uses Tahoma (not on Ubuntu).
Comment 15 Samson 2019-01-12 21:47:01 UTC
2013-06-22 -  2019-1-12

Thanks for your hard work. The problem now is solved with the new
LibreOffice 6.2.02

I will attach screenshot
Comment 16 Buovjaga 2019-01-13 07:38:27 UTC
(In reply to Samson from comment #15)
> 2013-06-22 -  2019-1-12
> 
> Thanks for your hard work. The problem now is solved with the new
> LibreOffice 6.2.02
> 
> I will attach screenshot

It is true, I no longer see squares in attachment 81355 [details]

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: c2d59ec2832c8b51568e73e9314ab9c82f1f5b7b
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 8 January 2019