Download it now!
Bug 66120 - FILEOPEN: MS 97 .doc Fails to import properly. Chart distorted (4/5)
Summary: FILEOPEN: MS 97 .doc Fails to import properly. Chart distorted (4/5)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-24 10:12 UTC by Luke
Modified: 2013-07-01 22:33 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison of Doc in Word vs Writer (1.15 MB, image/png)
2013-06-24 10:12 UTC, Luke
Details
MS .doc file fails to import correctly (552.50 KB, application/msword)
2013-06-24 10:13 UTC, Luke
Details
Document, opened in Libreoffice 4.1rc on Ubuntu 13.04x64 (319.09 KB, image/png)
2013-06-24 16:41 UTC, Eugene
Details
screenshot of broken view (334.51 KB, image/png)
2013-06-25 10:29 UTC, retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2013-06-24 10:12:03 UTC
Created attachment 81324 [details]
Comparison of Doc in Word vs Writer

This bug was tested LibreOffice v4.1 RC1 running in windows 7 and XP. It appears that LibreOffice loses formatting when importing MS Word 2003 .doc files. I have attached an example.

Steps to reproduce the bug:
1. Open attached Demo-Hayden-Management.doc document in writer 
2. Open attached Demo-Hayden-Management.doc document in Word2003/Office 365
3. Compare the documents. 

Note item #4 in the image comparison. The chart is distorted after import into LO.
Comment 1 Luke 2013-06-24 10:13:16 UTC
Created attachment 81325 [details]
MS .doc file fails to import correctly
Comment 2 Jorendc 2013-06-24 11:46:39 UTC
I can NOT confirm this behavior using Mac OSX 10.8.3 with LibreOffice 4.1.0.1 RC. Chart is displayed OK.

@Steve: you mind reproducing :)?

Kind regards,
Joren
Comment 3 Eugene 2013-06-24 16:38:43 UTC
I can't reproduce this bug (chart distortion) in Libreoffice 4.1 RC1 running on Ubuntu 13.04 x64. Though, document formatting is incorrect.
Comment 4 Eugene 2013-06-24 16:41:44 UTC
Created attachment 81350 [details]
Document, opened in Libreoffice 4.1rc on Ubuntu 13.04x64
Comment 5 retired 2013-06-25 10:28:41 UTC
Not sure what to make of this. For me the whole file is very flaky. Chart #4 is also distorted. When scrolling up and down sometimes the view clears up and show the items correctly but when scrolling down I keep seeing very strange behavior.

Setting to NEW.
Comment 6 retired 2013-06-25 10:29:47 UTC
Created attachment 81403 [details]
screenshot of broken view
Comment 7 Luke 2013-07-01 22:33:16 UTC
I tested with master~2013-07-01_09.19.22_LibreOfficeDev_4.2.0.0.alpha0_Win_x86 under winXP, and this bug has been fixed. Nice work team!