Bug Hunting Session
Bug 66123 - VIEWING: right single quote (’) becomes straight quote (') when hyphenating a word already containing an hyphen
Summary: VIEWING: right single quote (’) becomes straight quote (') when hyphenating a...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: x86 (IA32) Linux (All)
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-24 11:37 UTC by Julien de Vulpillières
Modified: 2015-04-27 08:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Examples of strange single quote and hyphenation behaviour (34.87 KB, application/pdf)
2013-06-24 11:37 UTC, Julien de Vulpillières
Details
Language Settings > Writing Aids > French (152.13 KB, image/png)
2013-07-07 15:52 UTC, Julien de Vulpillières
Details
Language Settings > Writing Aids (114.98 KB, image/png)
2013-07-07 15:53 UTC, Julien de Vulpillières
Details
Examples of strange single quote and hyphenation behaviour (34.87 KB, application/pdf)
2013-07-07 15:56 UTC, Julien de Vulpillières
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien de Vulpillières 2013-06-24 11:37:08 UTC
Created attachment 81329 [details]
Examples of strange single quote and hyphenation behaviour

When a word containing both a right single quote (’) and hyphen(s) (for ex.: c’est-à-dire, d’elle-même, l’ici-bas...) must be hyphenated because it comes at the end of a line, the right single quote (’) becomes straight quote ('). (cf. ex. 1 and 2 - with d’elle-même - in attached document).

This bug affects only the viewing: when I "copy-paste" the text in another office program, the right single quote appears as it should be.

NB:
1. I noticed it for the first time with LibreOffice 4.0
2. It occurs only when the (new) hyphenation takes place just where the existing hyphen already was. (cf. ex. 3: d’évidemment)
3. I am quite puzzled by hyphenation and single quotes because hyphenation seems to occur arbitrary with that type of words (cf. ex. 4, 5 and 6: d’évidemment-ci).
Comment 1 Zoltan Laszlo 2013-07-05 16:10:47 UTC
Does it appear with French hyphenation or standard hyphenation? I could not reproduce it with the language set to either English (UK) or Hungarian (I do not have French proofing installed).
Comment 2 Zoltan Laszlo 2013-07-05 16:11:31 UTC
(In reply to comment #1)
> Does it appear with French hyphenation or standard hyphenation? I could not
> reproduce it with the language set to either English (UK) or Hungarian (I do
> not have French proofing installed).

I tried in LibreOffice 4.1.0.1 on Win7 Home Premium x64.
Comment 3 Julien de Vulpillières 2013-07-07 15:47:12 UTC
(In reply to comment #1)
> Does it appear with French hyphenation or standard hyphenation? I could not
> reproduce it with the language set to either English (UK) or Hungarian (I do
> not have French proofing installed).

As far as I understand, it appear using Libhyphen Hyphenator French (see attachement). This is how I set it in L
Comment 4 Julien de Vulpillières 2013-07-07 15:49:33 UTC
(In reply to comment #3)
> (In reply to comment #1)
> > Does it appear with French hyphenation or standard hyphenation? I could not
> > reproduce it with the language set to either English (UK) or Hungarian (I do
> > not have French proofing installed).

As far as I understand, it appear using Libhyphen Hyphenator French (see attached file). This is how I set it in Language Settings > Writing Aids.
What would "standard hyphenation" be?
Comment 5 Julien de Vulpillières 2013-07-07 15:52:17 UTC
Created attachment 82143 [details]
Language Settings > Writing Aids > French
Comment 6 Julien de Vulpillières 2013-07-07 15:53:08 UTC
Created attachment 82144 [details]
Language Settings > Writing Aids
Comment 7 Julien de Vulpillières 2013-07-07 15:56:32 UTC
Created attachment 82145 [details]
Examples of strange single quote and hyphenation behaviour
Comment 8 QA Administrators 2014-06-01 21:29:46 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 9 QA Administrators 2014-07-08 17:17:35 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO
Comment 10 Matthew Francis 2015-04-26 04:39:32 UTC
I couldn't reproduce this with LO 4.0.4.2 or 4.4.2.2.

Could you possibly provide the original document for the PDF which is already attached?


Setting Status -> NEEDINFO. Please set back to UNCONFIRMED when the requested information has been provided.
Comment 11 Julien de Vulpillières 2015-04-27 08:52:32 UTC
I couldn't reproduce bug in LO 4.4.2.2 so I assume it was only temporary, and just a viewing problem.
Bug status changed to INVALID.