Bug 66263 - "Edit - Changes - Protect Records" can't be activated
Summary: "Edit - Changes - Protect Records" can't be activated
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.2.0 target:4.1.0.2 target:4....
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-27 15:34 UTC by Thomas Hackert
Modified: 2018-05-06 18:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hackert 2013-06-27 15:34:29 UTC
Hello @ll,
I hope, I have chosen the right settings for this bug. If not, feel free to change adequate ... ;)

Steps to reproduce:
1. Create a new Calc document
2. Enable "Edit - Changes - Record"
3. Enable "Edit - Changes - Protect Records..."

Now I would expect a dialog, which will ask for a password, but this does not happen ... (

4. Look below "Edit - Changes" again. "Protect Records..." is still not enabled.
5. Click it again.
6. Look again at "Edit - Changes"

"Protect Records is still not enabled ... :(

Expected behaviour:
1. LO should ask for a password after step 3.
2. LO should enable "Protect Records..." and use it.

Current behaviour:
LO does not enable the menu item.

If it is not intended to be used in Calc, it should be either greyed-out or better not shown at all.

Discovered it with
LO: Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2) and Version: 4.1.0.1 Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155
OS: Debian Testing AMD64

Sorry for the inconvenience
Thomas.
Thomas.
Comment 1 Olivier Hallot 2013-06-27 15:41:46 UTC
I can confirm it.

Linux, Kubuntu 13.4, LibreOffice 4.0 4 from TDF, 

Under Calc, the password dialog does not show. More, the checkbox in the menu is not visible (for comparison, Protect changes in writer has a checkebox).
Comment 2 Julien Nabet 2013-06-29 19:29:44 UTC
On pc Debian x86-64 with LO 4.0.3 Debian package, I reproduce this too.
I also tested with master sources updated today and I had the same result.

Caolán: I know it's about Calc but I thought you might be interested in this tracker since you're working hard on UI conversions. Of course, if you prefer
Comment 3 Commit Notification 2013-07-01 10:54:41 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=257ba103fb9ffae87189eb5d435969961fe4e98c

Resolves: fdo#66263 calc's protect records doesn't do anything, sid collision



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2013-07-01 11:09:34 UTC
fixed on master, review for 4-1 and 4-1 in gerrit
Comment 5 Commit Notification 2013-07-01 13:07:36 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d4d5c97b4eb0b0d28aac635482bca547d60b7cdc&h=libreoffice-4-1

Resolves: fdo#66263 calc's protect records doesn't do anything, sid collision


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2013-07-02 07:29:06 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f3f510653424987591577693fe986e4d6f4b5080&h=libreoffice-4-0

Resolves: fdo#66263 calc's protect records doesn't do anything, sid collision


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2018-05-06 18:29:26 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=709e9bbf89bcf762dee358c77abc7bac825b60e9

uitest Calc tracked changes + tdf#66263

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.