Download it now!
Bug 66335 - unnecessary space for buttons in scrollbars
Summary: unnecessary space for buttons in scrollbars
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Ivan Timofeev (retired)
URL:
Whiteboard: target:4.2.0 target:4.1.1 target:4.0.5
Keywords:
: 35799 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-06-28 17:19 UTC by Ivan Timofeev (retired)
Modified: 2014-11-03 04:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (20.82 KB, image/png)
2013-06-28 17:19 UTC, Ivan Timofeev (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Timofeev (retired) 2013-06-28 17:19:20 UTC
Created attachment 81652 [details]
screenshot

Scrollbars have unnecessary space for buttons, but my theme doesn't provide any buttons, it only provides a thumb. See the attached screenshot.

I am working on this.
Comment 1 Commit Notification 2013-06-28 18:42:35 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=48e1d9c7afe5c2a39d9a08d7a38f7c8ff39d8c84

fdo#66335: gtk: Revert hacks for RTL scrollbars



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Commit Notification 2013-07-03 23:20:20 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6d16423a82847c82f6915f03cdd0179c42d23929&h=libreoffice-4-1

fdo#66335: fix fdo#44582 and fdo#63254 differently


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2013-07-08 09:15:00 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=54d8b3ae7ff97c798ea515b8196c1b2b9ccdf056&h=libreoffice-4-0

fdo#66335: fix fdo#44582 and fdo#63254 differently


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Adolfo Jayme 2014-11-03 04:59:25 UTC
*** Bug 35799 has been marked as a duplicate of this bug. ***