Bug Hunting Session
Bug 66410 - UI: Auto scroll with middle mouse button not working.
Summary: UI: Auto scroll with middle mouse button not working.
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 105418 115265 119274 (view as bug list)
Depends on:
Blocks: Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2013-06-30 18:42 UTC by Lukasz
Modified: 2018-12-11 16:53 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukasz 2013-06-30 18:42:26 UTC
The scrolling with middle mouse button is not working when set to this behavior in view options. Nothing happens after clicking and dragging middle mouse button on the drawing area. If the issue was solved it would be a lot easier and faster to create drawings.
Comment 1 Jorendc 2013-07-04 21:47:09 UTC
Rather an enhancement then a bug. I see the use case (don't use it myself, but it's a valid request).

Kind regards,
Joren
Comment 2 MarjaE 2016-03-19 01:16:20 UTC
Is working for me... except not working because unusably fast, worsening migraine, and giving no control.
Comment 3 Heiko Tietze 2016-06-30 09:03:59 UTC
Tools > Options > View > Middle mouse button = Automatic scrolling

When a shape is being selected the middle mouse duplicates it to the current position (otherwise, if nothing is selected, the clipboard is pasted). I don't see any scrolling. And as a Linux user I wouldn't expect. But since there is the option I'd say it's a bug.

Setting to normal.
Comment 4 QA Administrators 2017-09-01 11:15:46 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2018-02-15 20:24:07 UTC
*** Bug 105418 has been marked as a duplicate of this bug. ***
Comment 6 Buovjaga 2018-02-15 20:24:30 UTC
*** Bug 115265 has been marked as a duplicate of this bug. ***
Comment 7 Buovjaga 2018-02-15 20:26:46 UTC
To reflect the two reports I just duped to this, it would make sense while fixing this non-working feature to ensure that in Draw it works like panning: in both x and y axes.
Comment 8 Buovjaga 2018-09-03 18:53:10 UTC
*** Bug 119274 has been marked as a duplicate of this bug. ***