Bug 66470 - FILEOPEN: easier access to scale drawings
Summary: FILEOPEN: easier access to scale drawings
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Draw-UX
  Show dependency treegraph
 
Reported: 2013-07-01 20:31 UTC by John Spencer
Modified: 2021-03-18 09:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of statusbar (8.13 KB, image/png)
2021-03-05 18:23 UTC, Regina Henschel
Details
Screenshot 2 of status bar (2.25 KB, image/png)
2021-03-05 18:24 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Spencer 2013-07-01 20:31:18 UTC
This is not so much a bug as an design omission.

Whilst the Libre Office Drawing fulfills the basic needs for creating simple drawings and sketches, it fails to have a drawing scale feature.  The same is true of Libre CAD.

The very first time I tried to draw a small detail I was frustrated because my object was only 2 x 3 inches in section and 4 inches long.  In order to have a reasonable size representation I had to mentally create a 2:1 scale as I went along.

There needs to be a drawing scale feature at the file level to provide this very basic need.

John Spencer
Comment 1 Jorendc 2013-07-02 09:25:32 UTC
What about Tools > Options > LibreOffice Draw > General > Drawing scale :)?

But I think a faster access is desirable (like in the bottom status/toolbar).
Therefore lets change this bug to an enhancement request?

Kind regards,
Joren
Comment 2 John Spencer 2013-07-02 16:17:32 UTC
On 2013-07-02 2:25 AM, bugzilla-daemon@freedesktop.org wrote:
> Jorendc <mailto:joren.libreoffice@telenet.be> changed bug 66470 
> <https://bugs.freedesktop.org/show_bug.cgi?id=66470>
> What 	Removed 	Added
> Hardware 	x86-64 (AMD64) 	All
> OS 	Windows (All) 	All
> Status 	UNCONFIRMED 	NEW
> Severity 	normal 	enhancement
> QA Contact 		joren.libreoffice@telenet.be
> See Also 		https://bugs.freedesktop.org/show_bug.cgi?id=65765, 
> https://bugs.freedesktop.org/show_bug.cgi?id=59068
> Summary 	FILEOPEN 	FILEOPEN: easier access to scale drawings
> Component 	Drawing 	UI
> Ever confirmed 		1
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=66470#c1> 
> on bug 66470 <https://bugs.freedesktop.org/show_bug.cgi?id=66470> from 
> Jorendc <mailto:joren.libreoffice@telenet.be> *
> What about Tools > Options > LibreOffice Draw > General > Drawing scale :)?
>
> But I think a faster access is desirable (like in the bottom status/toolbar).
> Therefore lets change this bug to an enhancement request?
>
> Kind regards,
> Joren
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Thanks for your response.  My apologies for raising a non issue. 
However, I do concur that the route to the solution is obscure and I am 
not sure I would ever have found it.  I am more used to Visio, am 
looking for a replacement and find Libre Draw/CAD similarly functional.  
There, the scale function is reached very quickly via the Page Set Up in 
the File menu.  I do agree that an enhancement is appropriate, since the 
drawing scale is usually the first parameter that is determined after 
the drawing page is created.

Best regards

John
Comment 3 Thomas Lendo 2019-06-08 14:01:30 UTC
Adding needsUXEval to discuss how this can be resolved or if anyhow.
Comment 4 Heiko Tietze 2021-03-04 08:47:27 UTC
We discussed this in the design meeting and having feedback in the statusbar with quick access to the options is welcome. 

Will look into it myself.
Comment 5 Regina Henschel 2021-03-04 14:35:23 UTC
The status bar is already very full in Draw. Therefore I would not add an additional tool there.

Scaling is in settings.xml, items ScaleDenominator and ScaleNumerator. So it is stored in file, but no ODF feature.

In the long term, I would like to have a dedicated dialog for document specific settings, reachable without Tools > Options.

But for now I can think of adding a part in the page properties dialog in Draw. Currently Draw can use only exact one page style and scaling is usually chosen at the same time when setting page size, the place there would be obvious.

Alternatively a submenu-list in menu Page, which lists all the predefined scale ratios.
Comment 6 Regina Henschel 2021-03-05 18:23:50 UTC
Created attachment 170257 [details]
Screenshot of statusbar

The field ".uno;ModificationStatus" is much too wide. The field ".uno:Size" is too small. See screenshots.
Comment 7 Regina Henschel 2021-03-05 18:24:40 UTC
Created attachment 170258 [details]
Screenshot 2 of status bar
Comment 8 Commit Notification 2021-03-18 09:14:41 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/951b243f10a7c184e635ce1d84f69683d8e7abde

Resolves tdf#66470 - Scaling value in statusbar

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.