Download it now!
Bug 66499 - Generating PDF slows down LO (Win only)
Summary: Generating PDF slows down LO (Win only)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: perf, preBibisect, regression
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2013-07-02 10:38 UTC by slingshot
Modified: 2017-12-09 17:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The original .doc file, three different PDF exports 1 working from 3.5 generated on my linux box (since it had old version installed) 2 broken files generated with the newer 4+ versions of LibreOffice (369.55 KB, application/zip)
2013-07-02 10:38 UTC, slingshot
Details
Win7 generated PDF with Libreoffice 4.4.3.2 (151.25 KB, application/pdf)
2015-06-08 18:44 UTC, slingshot
Details
PDF generated with 4.3.5.2 (151.07 KB, application/pdf)
2015-06-08 18:46 UTC, slingshot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description slingshot 2013-07-02 10:38:42 UTC
Created attachment 81866 [details]
The original .doc file, three different PDF exports 1 working from 3.5 generated on my linux box (since it had old version installed) 2 broken files generated with the newer 4+ versions of LibreOffice

Problem description: 

Steps to reproduce:
1. Open attached file
2. Click the "Export directly as PDF"
3. See the program becom unresponsive.

Current behavior:

Notice how slow and unresponsive the UI becomes both when opening and PDFing the file.
Also the PDF file is broken with black fields.

Expected behavior:

Responsive UI and usable PDF
              
Operating System: Windows 7
Version: 4.1.0.1 rc
Last worked in: 3.5.7.2 release
Comment 1 retired 2013-07-03 10:57:51 UTC
WORKSFORME on OS X 10.8.4 LO 4.1.0.1.

WIN only as it seems.
Comment 2 Pedro 2013-07-04 00:00:27 UTC
Bug confirmed under Windows XP SP3 x86 en_US

I didn't try the PDF part on all the versions but simply loading the file is absurdly slow (it's a 2 page document with a table...)

It is indeed a regression. It loads at a normal speed using LO 3.5.7.2 but not when using 3.6.6.2, 4.0.4.2 or 4.1.0.1

However PDF creation was also slow in 3.5.7.2
Comment 3 retired 2014-12-08 10:26:42 UTC
Over a year later: XP is endoflife. everybody still using it should update to a newer OS.

NEEDINFO: does this problem still persist with 4.4beta builds?
https://www.libreoffice.org/download/pre-releases/
Comment 4 QA Administrators 2015-06-08 14:28:41 UTC Comment hidden (obsolete)
Comment 5 slingshot 2015-06-08 18:44:42 UTC
Created attachment 116382 [details]
Win7 generated PDF with Libreoffice 4.4.3.2
Comment 6 slingshot 2015-06-08 18:45:05 UTC
Version: 4.3.5.2
Operativsystemnamn:              Microsoft® Windows Server® 2008 Standard
Operativsystemsversion:          6.0.6002 Service Pack 2 Build 6002


14 seconds to load the document.
54 seconds to create PDF.
PDF export better but still missing almost all the data in the table, looks like attached file. (winserver)

Version: 4.4.3.2
Operativsystemnamn:               Microsoft Windows 7 Professional
Operativsystemsversion:           6.1.7601 Service Pack 1 Build 7601

16 seconds to load document.
49 seconds to create PDF.
PDF PDF export better but still missing almost all the data in the table, looks like attached file. (win7)
Comment 7 slingshot 2015-06-08 18:46:09 UTC
Created attachment 116383 [details]
PDF generated with 4.3.5.2
Comment 8 slingshot 2015-06-25 18:46:56 UTC
Changed from REOPENED to UNCONFIRMED
Comment 9 Buovjaga 2015-07-01 10:44:11 UTC
PDF creation takes 1min 18s.
Most of the data missing from table.

Win 7 Pro 64-bit, Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Locale: fi_FI
Comment 10 tommy27 2015-07-08 19:56:17 UTC
same findings as in previous comment with LibO 5.1.0.0.alpha1+ (x64) under Win8.1 x64

Build ID: 0251e61640b94094918406b33ee7b05564409feb
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-06_23:45:07
Locale: en-US (it_IT)
Comment 11 Buovjaga 2016-02-09 09:53:59 UTC
Same slowness still.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 76ec54e8c9f3580450bca85236a4f5af0c328588
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-02-09_00:10:35
Locale: fi-FI (fi_FI)
Comment 12 Xisco Faulí 2016-09-13 11:25:01 UTC
Adding keyword 'preBisect' as this regression was introduced before branch 4.4 and therefore it can't be bibisected as there's no bibisect repository for this branch.
Comment 13 Telesto 2017-12-07 19:01:59 UTC
No repro with
Version: 6.1.0.0.alpha0+
Build ID: cc1db6f2b0ebe05ae807628778835b62df00eca2
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-02_23:45:34
Locale: nl-NL (nl_NL); Calc: CL
Comment 14 Buovjaga 2017-12-09 17:38:37 UTC
Yep, no slowness and PDF looks fine.

Version: 6.1.0.0.alpha0+ (x64)
Build ID: 0bb0299b29960c3a27427eba5d5fc34e5e913a8b
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-09_00:15:04
Locale: fi-FI (fi_FI); Calc: group threaded