Bug Hunting Session
Bug 66541 - FILEOPEN: DOCX import does not show line numbers correctly
Summary: FILEOPEN: DOCX import does not show line numbers correctly
Status: RESOLVED DUPLICATE of bug 121663
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2013-07-03 07:45 UTC by Adam CloudOn
Modified: 2019-09-17 10:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX containing line numbers (15.82 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-07-03 07:45 UTC, Adam CloudOn
Details
continuous line numbers, works as expected (24.87 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-07-03 08:00 UTC, Jorendc
Details
DOCX compared (90.90 KB, image/jpeg)
2019-09-17 10:45 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2013-07-03 07:45:19 UTC
Created attachment 81940 [details]
DOCX containing line numbers

Problem description: 
When loading a DOCX with 'line numbers' turned on - the lines appear different than in Word.

Steps to reproduce:
1. Load the attached DOCX in LO
2. The line numbers appear differently than in Word

Current behavior:
The line numbers appear different than in Word.
(The number '3' appears on the 3rd line)

Expected behavior:
The line numbers should appear like in Word
(The number '3' should appear on the 2nd line)

Note: the actual logic of line numbering in Word looks a bit strange. This might actually be a bug of Word !
(play with the 'start from' value in Word).


Operating System: All
Version: 4.2.0.0.alpha0+ Master
Comment 1 Jorendc 2013-07-03 07:59:41 UTC
Mmh, a bit harder to confirm. I also can confirm this bug, but as you said it looks also a bit weird to me.

I tried to create another test document using Mac OSX 10.8.4 and Word for Mac 2011 with a continuous line numbering. Works as expected then.
Comment 2 Jorendc 2013-07-03 08:00:07 UTC
Created attachment 81944 [details]
continuous line numbers, works as expected
Comment 3 Adam CloudOn 2013-07-03 08:06:55 UTC
The problem seems to me specifically with the 'start value' setting.
This looks to be a bit strange in Word.
Comment 4 Jorendc 2013-07-04 21:44:39 UTC
NEW in that case :)

Kind regards,
Joren
Comment 5 QA Administrators 2015-04-01 14:40:15 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2015-04-20 18:04:43 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 7 Xisco Faulí 2016-04-20 10:14:11 UTC
This issue is still reproducible in

Version: 5.2.0.0.alpha0+
Build ID: d6bf3bcd8b51012d55a2ec962800a8549e2b85e1
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-04-15_06:45:16
Locale: es-ES (es_ES)
Comment 8 QA Administrators 2017-12-10 16:38:59 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2019-09-03 15:44:54 UTC

*** This bug has been marked as a duplicate of bug 121663 ***
Comment 10 Timur 2019-09-17 10:45:35 UTC
Created attachment 154219 [details]
DOCX compared

There were 2 issues, both are OK now and as in MSO.