Download it now!
Bug 66828 - FILE SAVE/OPEN: corner radius set in rectangle disappears
Summary: FILE SAVE/OPEN: corner radius set in rectangle disappears
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-11 16:41 UTC by Manfred
Modified: 2015-04-24 17:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manfred 2013-07-11 16:41:51 UTC
Problem description: 

Steps to reproduce:
1. if I give a rectangle with a radius of 0.5 cm, then save it, then close and then reopen the file and the radius is 0cm.
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: Windows 7
Version: 4.0.4.2 release
Comment 1 Cor Nouws 2013-07-11 19:00:11 UTC
Hi Manfred,
thanks for the report.

I can confirm the behaviour.
Important for the test: insert a rectangle without rounding.

Do you know if this worked in previous versions?
regards,
Cor
Comment 2 Manfred 2013-07-11 21:28:31 UTC
Hi Cor,
I have LibreOffice to 3.6.4 tested is the same error there.
regards
Manfred


Am 11.07.2013 21:00, schrieb bugzilla-daemon@freedesktop.org:
> Cor Nouws <mailto:cno@nouenoff.nl> changed bug 66828 
> <https://bugs.freedesktop.org/show_bug.cgi?id=66828>
> What 	Removed 	Added
> OS 	Windows (All) 	Linux (All)
> Status 	UNCONFIRMED 	NEW
> CC 		cno@nouenoff.nl
> Ever confirmed 		1
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=66828#c1> 
> on bug 66828 <https://bugs.freedesktop.org/show_bug.cgi?id=66828> from 
> Cor Nouws <mailto:cno@nouenoff.nl> *
> Hi Manfred,
> thanks for the report.
>
> I can confirm the behaviour.
> Important for the test: insert a rectangle without rounding.
>
> Do you know if this worked in previous versions?
> regards,
> Cor
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 Cor Nouws 2013-07-12 19:24:13 UTC
thanks!
After some test: set version to 3.4.0 (may be beta...?)

Interesting: in 3.3.0, the radius control cannot be used on a (non rounded) rectangle.
And particularly odd: on a rounded rectangle, that control cannot be used anywhere...
(Maybe I get the use wrong??)
Comment 4 QA Administrators 2015-04-01 14:42:43 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 5 Buovjaga 2015-04-24 17:32:55 UTC
Basic shapes, Rectangle, Rounded.
The roundness can be controlled with the yellow dot. Roundness setting is retained on save & reload.
Set to WFM.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI