Download it now!
Bug 67007 - UI: Name Box does not show a name in sheet scope when selecting a range
Summary: UI: Name Box does not show a name in sheet scope when selecting a range
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: All All
: lowest trivial
Assignee: Eike Rathke
URL:
Whiteboard: target:7.1.0 target:7.0.3
Keywords: implementationError, needUITest
Depends on:
Blocks: Cell-Name
  Show dependency treegraph
 
Reported: 2013-07-17 17:59 UTC by marius.spix
Modified: 2020-10-05 10:52 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Scope Local do not appear Active Cell Reference (Name Box) (201 bytes, text/plain)
2018-03-27 02:51 UTC, russell
Details
Named cells with Scope Local do not appear Active Cell Reference (Name Box) (201 bytes, text/plain)
2018-03-27 03:16 UTC, russell
Details
Names with Local Scope do not appear Active Cell Reference (Name Box) (28.77 KB, image/jpeg)
2018-03-27 03:25 UTC, russell
Details
testsheet_with_two_named_ranges_test (8.10 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-10-04 16:40 UTC, b.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marius.spix 2013-07-17 17:59:24 UTC
Problem description: 

Steps to reproduce:
1. Create a new spreadsheet document with at least one sheet.
2. Open the "Manage Names" dialog
3. Assign a name to a range (or a single cell, which does not matter) and set the scope of the name to any sheet (but not to "Document (Global)")
4. Select the above assigned range in the corresponding sheet

Current behavior:
The name box displays the selected range (e. g. "A1" or "A1:C6")

Expected behavior:
The name box should display the assigned name (e. g. "myField" or "myMatrix") This currently only works for names in the global scope. MS Excel 2007 shows the name in the local scope.
Operating System: Linux (Other)
Version: 3.6.6.2 release
Comment 1 Joel Madero 2013-09-24 22:04:18 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 4.1.1.2 
Platform: Ubuntu 13.04
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Trivial - no impact at all but should probably say name not range
Lowest

Keywords - 

Whiteboard Status - proposedeasyhack

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Robinson Tryon (qubit) 2013-10-23 18:43:33 UTC Comment hidden (obsolete)
Comment 3 Joel Madero 2014-02-27 23:03:38 UTC Comment hidden (obsolete)
Comment 4 Robinson Tryon (qubit) 2015-12-13 11:21:16 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-01-03 19:50:21 UTC Comment hidden (obsolete)
Comment 6 Aron Budea 2017-01-04 15:58:47 UTC
Still occurs in 5.3beta2 / Ubuntu 16.04.
Since local names were not available in OOo (step 3 in description), this is an implementation error.
Adding easyHack keyword, since this was proposed as an easy hack, but the proposal still has to be evaluated.

Currently the Manage Names dialog is available in Sheet -> Named Ranges and Expressions -> Manage...
Comment 7 Aron Budea 2017-01-04 16:03:06 UTC
One additional bit of information, the range can be assigned via the Add button in Manage Names dialog.
Comment 8 Buovjaga 2017-01-04 16:04:57 UTC
(In reply to marius.spix from comment #0)
> 4. Select the above assigned range in the corresponding sheet

..and this means you just select the range with your mouse or keyboard.
Comment 9 russell 2018-03-27 02:51:47 UTC Comment hidden (obsolete)
Comment 10 russell 2018-03-27 03:16:19 UTC Comment hidden (obsolete)
Comment 11 russell 2018-03-27 03:25:05 UTC
Created attachment 140900 [details]
Names with Local Scope do not appear Active Cell Reference (Name Box)

PS: Had a slight problem attaching the image. Hope it works. Sorry for any redundancy.
Comment 12 Roman Kuznetsov 2019-07-20 11:37:09 UTC
I don't see any code points => remove EasyHack keyword

and it's steill repro in

Версия: 6.3.0.1 (x64)
ID сборки: 41ac97386aba908b6db860cfb4cfe2da871886ae
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: GL; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: threaded
Comment 13 Commit Notification 2020-09-27 14:07:03 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d3a8fdf3cad0e71ff5e13bb229fed6e52206c6b9

Resolves: tdf#67007 display sheet-local range name in Name Box for selection

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Eike Rathke 2020-09-27 14:07:31 UTC
Pending review https://gerrit.libreoffice.org/c/core/+/103430 for 7-0
Comment 15 Xisco Faulí 2020-09-28 12:17:00 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 050e95e50d44a5cbb74bb5de481cb30551f83136
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Eike, thanks for fixing this issue!!
Comment 16 Commit Notification 2020-09-28 12:18:20 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/6d9652e2864a020b61f26a7b51ca908f1d9790a8

Resolves: tdf#67007 display sheet-local range name in Name Box for selection

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 b. 2020-10-04 16:40:16 UTC
Created attachment 166067 [details]
testsheet_with_two_named_ranges_test

hello @erAck, 

don't know for sure, but may be there's room for improvement, 

see attached sheet, two ranges named 'test', one scope 'global', one scope 'sheet1', 

if you select from the 'name box' you get offered both, but regardless which you click the selection changes to the local range, would it be better to make the global range 'adressable' - reachable? 

if you select the ranges manually 'test' appears in the name box, but without a hint about the scope, thus some simple minded users might check the magenta range as 'test', and be astonished why values keyed in there aren't evaluated by formuas referencing 'test', 

... this may look silly, but will happen once you think of handing sheets to other users ... 

once there are multiple ranges with identical names in a project they should always show their 'full name', with the scope, and should all be selectively adressable - by including the scope reference into the name or by clicking on the appr. entry ... 

or not? 

reg. 

b.
Comment 18 Eike Rathke 2020-10-05 10:52:47 UTC
If you want anything changed regarding the handling when clicking a name entry of the Name Box then please open a new RFE.