Bug 67011 - EDITING: Libreoffice calc hangs when drag&dropping cell(s) in KDE4
Summary: EDITING: Libreoffice calc hangs when drag&dropping cell(s) in KDE4
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.2 rc
Hardware: Other Linux (All)
: highest major
Assignee: Jan-Marek Glogowski
QA Contact:
URL:
Whiteboard: target:4.3.0 target:4.2.0.1
Keywords: regression
: 68281 70614 70897 71284 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-07-17 20:08 UTC by Ville Aakko
Modified: 2014-03-22 15:21 UTC (History)
21 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ville Aakko 2013-07-17 20:08:57 UTC
Hi!

In KDE4, when I drag&drop any range of cell, there's a total freeze of the UI as soon as the drag&drop is initiated (i.e. after celecting cell(s) to be dragged, hold mouse button and move mouse to initiate drag&drop - this is when the freeze happens). I can reproduce this on any spreadsheet, includin a new, empty one.

Moreover, the freeze includes the whole X.org UI, including desktop. There's no way to kill LibreOffice from the GUI. However, CTRL+ALT+F -keys still work so one can go to a VT and kill libreoffice from there, and the UI is released.

I can work around this freeze by setting "OOO_FORCE_DESKTOP=gnome", of course I loose all KDE integration by doing that.

This happens on Gentoo. Also there's a bug in Gentoo's bugzilla for libreoffice 3.4.1 with an identical issue, but that one is closed (as the issue was fixed). See <https://bugs.gentoo.org/show_bug.cgi?id=375277>.

I apologize if this is and duplicate, bug #48849 seems similar but is for 3.4.3 there's no mention of KDE and it's a crash as I'm experiencing a total freeze.
Comment 1 ign_christian 2013-07-18 05:15:50 UTC
HI Ville, I can't reproduce on LO 4.0.4.2 (PCLinuxOS with KDE 4.10.5, Qt 4.8.4). LO installed from PCLinuxOS packager, not from LO official page.
Comment 2 ign_christian 2013-07-18 05:20:32 UTC
This looks similar with Bug 40298. Perhaps you could try KDE 4.9 or 4.10. 
If that still fail please comment on that root bug.

*** This bug has been marked as a duplicate of bug 40298 ***
Comment 3 Ville Aakko 2013-07-18 14:38:56 UTC
See my comment in Bug 40298.
Comment 4 Lubos Lunak 2013-07-23 14:29:58 UTC
This doesn't look like a duplicate of bug #40298 to me.
Comment 5 Ville Aakko 2013-07-23 19:40:39 UTC
Hi,

Just FYI, I've repdroduced this on KDE 4.10.5 (and 4.10.4) and my qtcore version is 4.8.4-r5 in Gentoo. Sorry about missing version information for these (and the messup in the other bug).
Comment 6 keellambert 2013-08-12 11:32:01 UTC
This bug is still present in libreoffice-4.1.0.4-2.2.x86_64

not problems found with cut and paste for moving cells

system not frozen as 'sytem monitor' graphs can be seen updating,
sometimes analog clock can also be seen working,
all inputs from keyboard and mouse ignored

hangs survives longer than 5 minutes (end of patience before manual reboot)

Kernel: 3.10.5-1.g4e0ffc2-desktop x86_64
openSUSE 13.1 Milestone 4 (x86_64)
Desktop: KDE 4.10.97
qt3-3.3.8c-127.2.x86_64
qt4-qtscript-0.2.0-7.8.x86_64
Comment 7 keellambert 2013-08-13 06:45:32 UTC
JFI

libreoffice-calc
no problems found dragging and dropping cells with 
libreoffice4.1-4.1.0.4-4.x86_64
(Version: 4.1.0.4 Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28)

updated at the same to libqt4-4.8.5-2.1.x86_64
Comment 8 kaesezeh 2013-08-24 18:33:21 UTC
Same problem here with LibreOffice (Version: 4.1.0.4; Build ID: 410m0(Build:4)) on a Linuc Mint 15 64bit KDE machine. It freezes the whole system. (Once or twice I had a similar freeze when I inserted whole columns, but the drag/drop freeze is 100% reliable.)
Comment 9 kaesezeh 2013-08-28 17:07:56 UTC
My hunch is this is related to <https://bugs.freedesktop.org/show_bug.cgi?id=68281>
Comment 10 alexo 2013-09-02 10:39:36 UTC
Hi, I have the same problem here with LibreOffice (Version: 4.1.1.2) on an Arch Linux x86_64 system with KDE 4.11. When I try to drag and drop some cells, with or without content, the system get frozen and I can move mouse pointer but buttons are unresponsive. Also I confirm workaround using virutal consoles, a couples of switchings and the problem goes away. 

Kernel: 3.10.10-1-ARCH
Linux distro: Arch Linux (x86_64)
Desktop: KDE 4.11.00
Libreoffice: 4.1.1.2
Comment 11 Maxim Monastirsky 2013-09-10 17:48:52 UTC
*** Bug 68281 has been marked as a duplicate of this bug. ***
Comment 12 Maxim Monastirsky 2013-09-10 18:10:25 UTC
Reproducible here with LO 4.1.1.2 under Ubuntu 13.10 (64-bit).
Comment 13 Alefa 2013-09-11 14:30:56 UTC
Same problem here, LibreOffice 4.1.0.4 (from Debian backports) in Debian Wheezy (KDE 4.8.4). The UI also freezes when I try to drag and drop sheet tabs to change their order.
Comment 14 liudas 2013-09-16 21:31:42 UTC
Same here: 4.1.1.2 Arch Linux build-2 | KDE 4.11.1.

To unfreeze could be done I used Ctrl+Alt+F1 and then Ctrl+Alt+F7. Finally removed libreoffice-kde package (LO KDE desktop integration) and now can't reproduce freezing.
Comment 15 Murz 2013-09-27 06:48:45 UTC
Reproducible too with LO 4.1.1.2 under Ubuntu 13.10 AMD64 (Kubuntu with KDE 4.11).
Comment 16 Paul L 2013-10-06 00:27:39 UTC
This does not affect me. Kubuntu 13.04, KDE 4.11.2, kernel 3.8.0-32-generic (64-bit). Selecting a range and then click-dragging/dropping works just fine.
Comment 17 Paul L 2013-10-06 00:35:19 UTC
LibreOffice Calc Version 4.0.2.2 (Build ID: 400m0(Build:2))
Comment 18 Maxim Monastirsky 2013-10-06 05:32:02 UTC
(In reply to comment #16)
> This does not affect me. Kubuntu 13.04, KDE 4.11.2, kernel 3.8.0-32-generic
> (64-bit). Selecting a range and then click-dragging/dropping works just fine.

(In reply to comment #17)
> LibreOffice Calc Version 4.0.2.2 (Build ID: 400m0(Build:2))

Same observation as comment 1, so it's indeed 4.1 regression.
Comment 19 Maxim Monastirsky 2013-10-19 17:08:07 UTC
*** Bug 70614 has been marked as a duplicate of this bug. ***
Comment 20 C542 2013-10-21 12:47:31 UTC
This is also happening to me.
-Kubuntu 13.10, KDE 4.11.2, LibreOffice 4.1.2.3 410m0(Build:3), kernel 3.11.0-12-generic #19-Ubuntu.

I also confirm that removing libreoffice-kde-4.1.2~rc3-0ubuntu1 does fix the problem. I've also tried to switch off hardware acceleration and anti-aliasing with no success.
Comment 21 Robinson Tryon (qubit) 2013-10-23 17:24:32 UTC
Removing comma from whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
Comment 22 Maxim Monastirsky 2013-10-26 17:35:01 UTC
*** Bug 70897 has been marked as a duplicate of this bug. ***
Comment 23 andreas.sturmlechner 2013-10-27 17:45:58 UTC
Same trouble here. Drag and drop cells and sheets freezes kwin completely, switching to fbcon and back again is a workaround. Disabling hardware acceleration made no difference.

Linux 3.4.66-gentoo #1 SMP
Qt: 4.8.5
KDE Development Platform: 4.11.2
KWin: 4.11.2
LibreOffice 4.1.2.3 410m0(Build:3)
Comment 24 Marco Menardi 2013-11-03 22:02:55 UTC
Confirm on Debian GNU/Linux sid, KDE 4.10.5 and LiBo 4.1.3.2.
Computer completely frozen, also not responding to ssh login, had to REISUB, very bad.
I've some schools where I've Kubuntu 12.04 and recent LiBo and KDE (repositories with recent version) and happens there too (that's the reason I've tried on my pc too).
Comment 25 Roman 2013-11-06 08:14:04 UTC
*** Bug 71284 has been marked as a duplicate of this bug. ***
Comment 26 Joel Madero 2013-11-06 20:59:31 UTC
Requesting a bibisect on this one - if any of the people commenting care to have a stab at bibisecting - it'd be incredibly helpful. If not - I will try to get to it this weekend. 

https://wiki.documentfoundation.org/QA/HowToBibisect


Note: you'll have to use the daily bibisect package not the bibisect40 package and it takes some time to download + about 30 gigs of free space (package + unpacked package)
Comment 27 Marco Menardi 2013-11-10 16:09:30 UTC
Bibisect is useless since the bibisec code does not include the DE integration. In fact I've tried and was not able to reproduce the bug, that I can reproduce with the installed LiBo and -kde integration on the same host.
Comment 28 Sergey 2013-11-16 21:03:47 UTC
Confirmed both with 4.1.2.3 and 4.1.3.2 x86_64 - in case if compiled with --enable-kde flag. Otherwise is not reproducible
Comment 29 Joel Madero 2013-11-16 21:16:48 UTC
Does this bug happen if you install the package from libreoffice.org - ensure that you completely purge libreoffice before testing. If so it'd be nice to get some more tests with 4.1.0.1 rc and continue going backwards until you find where the bug is introduced. 

If not on that master build with kde integration enabled it'd be good get some kind of a log - honestly beyond my expertise so I'm going to add Michael to see if he can give some feedback. 

Michael - thoughts here?

Also updating the priority as I think this despite not preventing high quality work it's a very common feature that we hope would work without hangs. Furthermore, "highest" is appropriate because of how common it is + it being on the MAB list.

In general we would avoid this (because it breaks from workflow) but hopefully I've justified it enough above :)
Comment 30 C542 2013-11-16 21:25:37 UTC
Well, my report, comment #20 isn't valid anymore. The problem is now gone. From what I can tell:
KDE still 4.11.2 (despite there had been a few updates), Libreoffice is still 4.1.2.3 410m0(Build:3), kernel changed to 3.11.0-13-generic.

libreoffice-kde-4.1.2~rc3-0ubuntu1 package didn't change and is still the same.

So what's going on here? :-S
Comment 31 Joel Madero 2013-11-16 21:28:19 UTC
Forgot to include the link to prior releases: http://downloadarchive.documentfoundation.org/libreoffice/old/

It seems like at least some people are still confirming it.
Comment 32 Maxim Monastirsky 2013-11-17 05:53:21 UTC
@Joel Madero: Testing older releases is useless, since official builds don't include kde4 integration.
Comment 33 Joel Madero 2013-11-17 06:17:20 UTC
That's what I was afraid of. Okay - we'll await further instructions from Michael. Thanks!
Comment 34 Robinson Tryon (qubit) 2013-11-17 06:25:12 UTC
(In reply to comment #32)
> @Joel Madero: Testing older releases is useless, since official builds don't
> include kde4 integration.

What about older KDE builds? Can we dig up something from Kubuntu?
Comment 35 Joel Madero 2013-11-17 06:43:13 UTC
Not sure if this is the same package but -  maybe?
http://packages.ubuntu.com/precise/libreoffice-kde

Looks like you can get a few versions there
Comment 36 John Everest 2013-11-17 08:52:24 UTC
Release UI by opening a VT, no need to log in. Then immediately return to UI with "ctrl-alt-F7"
LO 4.1.2.3, KDE4.11.2, Kernel3.11.0-13

Quoted from first comment:-

"Moreover, the freeze includes the whole X.org UI, including desktop. There's no way to kill LibreOffice from the GUI. However, CTRL+ALT+F -keys still work so one can go to a VT and kill libreoffice from there, and the UI is released."
Comment 37 Maxim Monastirsky 2013-11-17 09:23:06 UTC
Reproducible with 4.1.0.0.beta2 from Fedora 19 DVD.
And still reproducible with a recent master build, updated some hours ago (Build ID: f7e6521efca5e5966a65e84848a1c35d71ba1a0b).
Comment 38 Sergey 2013-11-17 12:12:12 UTC
Can confirm that the bug is reproduced in actual sourcce from git core (libreoffice website) in case I use --enable-kde4. If I don't use --enable-kde4, everythin goes fine.
Comment 39 Michael Meeks 2013-11-18 09:25:39 UTC
There was a plausible patch for a similar bug to this somewhere that I saw recently, some KDE4 specific locking change I was CC'd on. I couldn't review that beyond thinking it looked sensible - not a great insight into how that works ...
Comment 40 Michael Meeks 2013-11-18 09:33:55 UTC
Ah - I saw it in gerrit:

   https://gerrit.libreoffice.org/6685

Jan - your patch looks plausible; I'd love to have it in 4.2 - but you realise that by touching the KDE backend you become the maintainer of it ? ;-) if you're willing to take that on - that's excellent by me ! =)
Comment 41 Maxim Monastirsky 2013-11-21 09:40:50 UTC
(In reply to comment #40)
> Ah - I saw it in gerrit:
> 
>    https://gerrit.libreoffice.org/6685
It's not fixed this bug. Still an issue with Build ID: 979f05eee3dafba60f6b93744183035e9cc8be81. The summary of this bug is misleading. It's not a hang, only a lock of the ui.
Comment 42 Michael Meeks 2013-11-21 10:07:52 UTC
Jan - any thoughts on this - it sounds bad; I had hoped your patch would help here :-)
Comment 43 Dirk 2013-11-27 22:46:47 UTC
I can confirm this bug, I think it started here after my recent upgrade to Kubuntu 13.10.
Kernel version 3.8.0-22-generic; KDE 4.11.2; LO version 4.1.2.3 Build 410m0(Build:3). 
Releasing the UI indeed works as described in comment 36 (John Everest).
Comment 44 Maxim Monastirsky 2013-11-28 06:31:25 UTC
There is already a patch for this bug at gerrit for about a week:
https://gerrit.libreoffice.org/#/c/6750/
Comment 45 Darío Hernández 2013-12-03 18:30:47 UTC
Hi all, I've discovered a temporary solution.

When KDE gets "hanged" (after drag and drop the cell(s)), just press the Escape key and on/off button (in that order), until KDE back to normality.

The problem should be (temporally) fixed until they release an official fix.

Hope this helps.
Comment 46 Commit Notification 2013-12-04 14:17:56 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=95f60222e75486336b6569afa8f34d60b51c94ad

fdo#67011: Run Display::Yield through KDEXLib::Yield.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 47 Stephan van den Akker 2013-12-08 20:17:13 UTC
Did a local cherry-pick to the libreoffice-4-2 branch. It works there too. No problems detected with a short test.

Please push to "libreoffice-4-2" too.
Comment 48 Commit Notification 2013-12-12 12:01:21 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8b4775458600dc2a2e8eb17e0bade35221c6b2ea&h=libreoffice-4-2

fdo#67011: Run Display::Yield through KDEXLib::Yield.


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 49 Scott Moore 2013-12-31 18:10:52 UTC
I'm having this same problem when trying to re-arrange worksheets. I have a spreadsheet with multiple worksheets. As soon as I grab the sheet by the tab at the bottom to move it, the whole session freezes, forcing a re-boot. Using Version: 4.1.3.2 Build ID: 410m0(Build:2) on Kubuntu 13.10.

It seems related. Should I file a new bug report?
Comment 50 andreas.sturmlechner 2013-12-31 18:15:04 UTC
No, you should bug your downstream to backport the above mentioned patch to 4.1 and ship a new libreoffice update (probably what they are doing anyway with the imminent bump to 4.1.4.2.
Comment 51 Maxim Monastirsky 2013-12-31 18:18:08 UTC
(In reply to comment #49)
> I'm having this same problem when trying to re-arrange worksheets.
Already reported in Bug 70897 (which is marked as a dup of this one). And yes - it's the same problem.
Comment 52 Alefa 2014-01-08 09:52:17 UTC
The problem is still present in LibreOffice 4.1.4.2 from Debian Wheezy Backports. So do we have to wait for 4.2 to get the fix?
Comment 53 Dan Ratje 2014-01-08 17:14:33 UTC
I am using 4.1.4.2-2.fc20 - This problem still exists for me as well
Comment 54 Dan Ratje 2014-01-08 17:18:49 UTC
(In reply to comment #53)
> I am using 4.1.4.2-2.fc20 - This problem still exists for me as well
Also, as stated earlier in the list - I can do a CTRL-ALT-F2 and sign in as the user and kill the processes which in turn unlocks the UI.
Comment 55 Maxim Monastirsky 2014-01-08 17:20:09 UTC
(In reply to comment #52)
> So do we have to wait for 4.2 to get the fix?
Yes.
Comment 56 andreas.sturmlechner 2014-01-08 18:04:13 UTC
(In reply to comment #50)
> No, you should bug your downstream to backport the above mentioned patch to
> 4.1 and ship a new libreoffice update (probably what they are doing anyway
> with the imminent bump to 4.1.4.2.

^ I can only repeat myself. If the downstream maintainers are unaware of your trouble, they can't do anything about it. The patch is easily backported to 4.1 branch, Gentoo has done it, Debian and Fedora can as well.
Comment 57 Joel Madero 2014-01-08 18:07:23 UTC
Please never update the top section unless asked to be a contributor - we have our policies/processes and when users change things it just confuses things. This bug is fixed, you'll see it in 4.2.
Comment 58 Commit Notification 2014-03-14 22:47:44 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=69e7f4491ec78384c46653d3cd8870c97cc9218a

Revert "fdo#67011: Run Display::Yield through KDEXLib::Yield."



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 59 Erdal Mutlu 2014-03-16 20:17:49 UTC
The exists in Arch linux kernel 3.13.6-1, KDE 4.12.3 and LibreOffice 4.1.5.3.
When I Ctrl+Alt+F1 and switch to text console and back to KDE the cells are moved and all applications start to function again.
Comment 60 andreas.sturmlechner 2014-03-16 20:19:20 UTC
(In reply to comment #59)
> The exists in Arch linux kernel 3.13.6-1, KDE 4.12.3 and LibreOffice 4.1.5.3.
> When I Ctrl+Alt+F1 and switch to text console and back to KDE the cells are
> moved and all applications start to function again.
Then either upgrade to >= 4.2 or give your downstream a heads up about this patch.
Comment 61 Marco Menardi 2014-03-19 21:13:43 UTC
(In reply to comment #58)
> Jan-Marek Glogowski committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=69e7f4491ec78384c46653d3cd8870c97cc9218a
> 
> Revert "fdo#67011: Run Display::Yield through KDEXLib::Yield."
> 
> 
> 
> The patch should be included in the daily builds available at
> http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> http://wiki.documentfoundation.org/Testing_Daily_Builds
> Affected users are encouraged to test the fix and report feedback.

I'm confused... did you revert the patch, so we have the bug again, alive and kicking, in master?
Comment 62 Jan-Marek Glogowski 2014-03-20 08:58:21 UTC
Ups - I forgot to add the fdo prefix to the real fix, which is:

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6c7374f071d998f726cd4a5b67baf54e357d096b&h=master

KDE4: prevent blocking in Display::Yield

Will reword for 4.2, so it will be included in bugzilla.
Comment 63 Commit Notification 2014-03-22 00:48:12 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "private/jmux/libreoffice-4-2+kde4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0d7b23340efceb25f5ce24ec2ba2e9549f61ad77&h=private/jmux/libreoffice-4-2+kde4

fdo#67011 KDE4: prevent blocking in Display::Yield


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 64 Commit Notification 2014-03-22 01:39:20 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "private/jmux/libreoffice-4-2+kde4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0f4ca8163650925d36c18fb898d81d1b942e9344&h=private/jmux/libreoffice-4-2+kde4

Revert "fdo#67011: Run Display::Yield through KDEXLib::Yield."


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 65 Commit Notification 2014-03-22 01:39:37 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "private/jmux/libreoffice-4-2+kde4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=631f43939c770613bf5d37cfccae06b0b1805c05&h=private/jmux/libreoffice-4-2+kde4

fdo#67011 KDE4: prevent blocking in Display::Yield


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 66 Commit Notification 2014-03-22 15:11:45 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6df01ea56717803f1ccf66bbbbb7a2815aa09fb5&h=libreoffice-4-2

Revert "fdo#67011: Run Display::Yield through KDEXLib::Yield."


It will be available in LibreOffice 4.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 67 Commit Notification 2014-03-22 15:15:16 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=448cd2be26527dc55b13d89c53c723ff62c32e95&h=libreoffice-4-2

fdo#67011 KDE4: prevent blocking in Display::Yield


It will be available in LibreOffice 4.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.