Download it now!
Bug 67039 - SVG filter (Draw) does not appear to handle area fill for line objects
Summary: SVG filter (Draw) does not appear to handle area fill for line objects
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SVG-Open
  Show dependency treegraph
 
Reported: 2013-07-18 12:40 UTC by Michael Chudobiak
Modified: 2018-06-18 13:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample SVG file (99.43 KB, image/svg+xml)
2013-07-18 12:40 UTC, Michael Chudobiak
Details
draw screenshot showing corruption (206.56 KB, image/png)
2013-07-18 12:41 UTC, Michael Chudobiak
Details
writer screenshot showing different corruption (159.31 KB, image/png)
2013-07-18 12:41 UTC, Michael Chudobiak
Details
inkscape renders the SVG correctly, for comparison (133.29 KB, image/png)
2013-07-18 12:45 UTC, Michael Chudobiak
Details
SVGs of objects causing rendering problems. (7.73 KB, application/zip)
2013-12-08 06:41 UTC, Owen Genat (retired)
Details
Screenshot - Insert>Picture on left, File>Open on right (241.23 KB, image/png)
2017-09-29 11:56 UTC, Michael Chudobiak
Details
pcb231A.svg in LO Draw 6.1 beta 2 (File->Open) (40.01 KB, image/png)
2018-06-18 13:14 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Chudobiak 2013-07-18 12:40:48 UTC
Created attachment 82591 [details]
Sample SVG file

A sample SVG file and 2 screenshots are attached to this file.

When opening the SVG file with draw, some extra lines appear. The draw screenshot highlights the extra lines.

When importing the SVG file into writer, some lines disappear. The writer screenshot highlights the missing lines.

The screenshots are from Fedora 19 Linux, with LO 4.1.0.1, but the same behaviour appears on the Windows 4.0.4.2 version.
Comment 1 Michael Chudobiak 2013-07-18 12:41:22 UTC
Created attachment 82592 [details]
draw screenshot showing corruption
Comment 2 Michael Chudobiak 2013-07-18 12:41:45 UTC
Created attachment 82593 [details]
writer screenshot showing different corruption
Comment 3 Michael Chudobiak 2013-07-18 12:45:20 UTC
Created attachment 82594 [details]
inkscape renders the SVG correctly, for comparison
Comment 4 ign_christian 2013-07-18 13:21:58 UTC
I can confirm same behavior on comment 1 if directly open that SVG with Draw.
 
But I can't reproduce behavior on comment 1 & comment 2 if that SVG inserted by Menu: Insert > Picture > From File... (correct result)
Seems like regression problem.

Tested on LO 3.6.6.2 (Ubuntu 12.04 32bit)

@Michael, perhaps you could search previously reported bug for possibly duplicate or similar problem? It will give much help for dev :)
Comment 5 Michael Chudobiak 2013-07-18 13:44:17 UTC
Additional info:

The open-with-draw extra-line problem also exists in 3.5.7.2 on Fedora 17.

The insert-with-writer missing-line problem does NOT exist in 3.5.7.2 on Fedora 17.

These bugs might be related:
bug 62284
bug 64075
bug 64076
bug 62461
Comment 6 Owen Genat (retired) 2013-12-08 06:41:33 UTC
Created attachment 90442 [details]
SVGs of objects causing rendering problems.

What I am seeing here is the same as that reported, although it requires some explanation and better test files (attached). I think given the testing here it would be a good idea to change the summary to reflect the fact that the main problem appears to be with the handling of area fill for lines. There are two distinct test cases reported in this bug:

- Insert > Picture... of a SVG "DC supply" (ring with line) graphic into Writer.
- File > Open... of a SVG "resistor" (zigzig line) graphic with Draw.

I have extracted these two small graphics from the SVG provided in comment #0 to simplify testing. The resultant SVGs have been created under Ubuntu 10.04 x86_64 using Inkscape v0.47 r22583 and Crunchbang 11 x86_64 using Inkscape v0.48.3.1 r9886 and are labelled as such. Both graphics were grouped objects with the individual components (lines) having a fill set for the area. The "no fill" variants have had this setting removed. I have then tested inserting the DC supply SVG into Writer and opening the resistor SVG with Draw under Ubuntu 10.04 x86_64 running:

- v3.3.0.4 OOO330m19 Build: 6
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

In all cases the no fill version of the resistor graphic displays as expected while the usual one exhibits the problem reported (line through zigzag). This would seem to indicate a problem with handling the area fill attribute for line items and seems to be a problem inherited from OOo. The DC supply graphic handling is more varied across versions of LO, although in all cases both the usual and no fill variant exhibit the same behaviour:

v3.3.0.4: severe rendering issue.
v3.4.6.2: severe rendering issue.
v3.5.7.2: rendered as expected (stick visible).
v3.6.7.2: rendered as expected (stick visible).
v4.0.6.2: rendered without stick.
v4.1.3.2: rendered without stick.

This would appear to indicate a regression in SVG handling, thus bug 62284 seems the likely candidate in this case.
Comment 7 Owen Genat (retired) 2013-12-08 06:48:45 UTC
As per comment #6, confirmed. Status set to NEW. Version set to Inherited From OOo. Platform set to All/All. Summary amended to "SVG filter (Draw) does not appear to handle area fill for line objects" for greater clarity.
Comment 8 Jorendc 2014-07-25 17:08:03 UTC
Insert > image > From file... -behavior is fully fixed. The small missing line shown in attachment 82593 [details] is drawn correctly.

File > Open behavior is still the same.
Comment 9 Xisco Faulí 2015-10-27 11:18:33 UTC
Problem is that polyline element doesn't handle fill="none;" attribute.
I take this one
Comment 10 Xisco Faulí 2017-09-29 08:52:16 UTC Comment hidden (obsolete)
Comment 11 Michael Chudobiak 2017-09-29 11:56:10 UTC
Created attachment 136621 [details]
Screenshot - Insert>Picture on left, File>Open on right

With libreoffice-base-5.3.6.1-5.fc26.x86_64 on Fedora 26, I still experience problems opening the original sample svg when using File>Open. It works OK if I use Insert>Picture. See the screenshot. The resistors on the right side have an extra line through them that should not be there.
Comment 12 Roman Kuznetsov 2018-06-18 13:14:29 UTC
Created attachment 142861 [details]
pcb231A.svg in LO Draw 6.1 beta 2 (File->Open)
Comment 13 Roman Kuznetsov 2018-06-18 13:44:24 UTC
In LibreOffice 6.1 beta 2 opening SVG with using of menu File->Open gives fine result


Status -> WFM