Bug 67044 - EDITING: search ignores keywords within comments
Summary: EDITING: search ignores keywords within comments
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2013-07-18 13:27 UTC by olddeath
Modified: 2017-05-31 06:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Allows to easily demonstrate the bug. (15.34 KB, application/vnd.oasis.opendocument.text)
2013-07-18 13:27 UTC, olddeath
Details

Note You need to log in before you can comment on or make changes to this bug.
Description olddeath 2013-07-18 13:27:17 UTC
Created attachment 82598 [details]
Allows to easily demonstrate the bug.

How to reproduce:
* Open the attached document.
* Search for "Zitates".
* Notice that he occurrence within the comment is never reached.
Comment 1 ign_christian 2013-07-18 13:35:54 UTC
Not reproducible on LO 3.6.6.2 (Ubuntu 12.04 32bit). 

If you meant white colored words, in my opinion white colored word won't occured but found while do searching.
Comment 2 olddeath 2013-07-19 17:05:15 UTC
OK, so search for "Quelle". There should be 2 occurrences in the document. One as white text, and one within the comment. However when using the search, you'll find only the first occurrence.

Can you confirm that?
Comment 3 ign_christian 2013-07-20 01:22:43 UTC
Ok I can confirm that with LO 4.0.4.2 (Win7 32bit)

But I don't know whether it's a bug, because we can do that using 'Find & Replace' dialog box as Joel mentioned in Bug 62518:
https://bugs.freedesktop.org/show_bug.cgi?id=62158#c1
Comment 4 ign_christian 2013-07-20 01:24:09 UTC
> Replace' dialog box as Joel mentioned in Bug 62518:
Ups..slipped when typing. I meant Bug 62158
Comment 5 retired 2013-07-21 11:06:57 UTC
Comment on attachment 82598 [details]
Allows to easily demonstrate the bug.

fixed mime type, as not recognized correctly :S
Comment 6 retired 2013-07-21 11:09:55 UTC
Confirmed with LO 4.1.0.3, OS X 10.8.4.

Imo a valid enhancement request. If I search a document, I want everything (and that includes comments) searched. Imo that would be appropriate default behavior. It is not thus setting to NEW.
Comment 7 QA Administrators 2015-04-01 14:40:28 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-04-22 11:08:40 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI
Comment 9 QA Administrators 2016-09-20 09:32:46 UTC Comment hidden (obsolete)
Comment 10 haim kilov 2017-01-05 23:17:26 UTC
Confirmed with LO 5.2.2.2.

I agree with Comment 6: "If I search a document, I want everything (and that includes comments) searched. Imo that would be appropriate default behavior."

This is especially appropriate in case of a text occurring only in a comment in an otherwise long document: the document is successfully found by Spotlight as containing the text, and then LO does not find the text itself!
Comment 11 Dieter 2017-05-31 06:20:16 UTC
I don't understand why this should be a bug, because writer gives you the possibility to search within comments (find & replace => more optins => comments). And I think it is important that you can choose searching within the comments or not. So my proposal is to close this bug as WORKSFORME.
Comment 12 Dieter 2017-05-31 06:30:52 UTC
It could be a useful to search only within comments. Bug 96474 is about this enhancement.
Comment 13 Buovjaga 2017-05-31 06:31:11 UTC
(In reply to Dieter Praas from comment #11)
> I don't understand why this should be a bug, because writer gives you the
> possibility to search within comments (find & replace => more optins =>
> comments). And I think it is important that you can choose searching within
> the comments or not. So my proposal is to close this bug as WORKSFORME.

Oh, you're right, man..