Download it now!
Bug 67419 - Viewport movements are slow with bigger documents
Summary: Viewport movements are slow with bigger documents
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
Depends on:
Blocks:
 
Reported: 2013-07-28 00:02 UTC by krokodil
Modified: 2018-12-11 17:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
attachment-22764-0.html (3.80 KB, text/html)
2013-08-02 13:09 UTC, krokodil
Details
attachment-22764-1.dat (1 bytes, multipart/alternative)
2013-08-02 13:09 UTC, krokodil
Details
DRAW_test.odg (951.08 KB, application/vnd.oasis.opendocument.graphics)
2013-08-02 13:09 UTC, krokodil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description krokodil 2013-07-28 00:02:15 UTC
DRAW
Vieport movement ( from left to right...) in LibreOffice_Draw is slow continually. It is better as previous versions, but not realtime. When draging viewport (shift) it is not continuos, but stepped.
I have long document (wide) + cca 5000 objects. 
( movement in Visio and ConceptDraw is with this document ok)

color dropper is missing (format paintbrush is not for everything)
:-))
Comment 1 Jorendc 2013-08-02 11:10:45 UTC
Hi,

Thanks for your report.
I'm not sure this is fixable for your document in 'particular', because I think the code base of LibreOffice is getting cleaner more and more. This result in less code/loops to run, which will result in a snappier LibreOffice.

To test if it is extremely unresponsive, is it possible to attach a test document were we can reproduce the behavior?

Kind regards,
Joren
Comment 2 krokodil 2013-08-02 13:09:51 UTC
Created attachment 83541 [details]
attachment-22764-0.html

Hi,
I sending you test file. It is graphical version of storyline ( action 
only ), but without text and layers in this version.
Movement is a little bit better without text...
Please, test it.
Why I am using Libre? It is more intuitive and easier as Word or Concept 
draw.
  I just need space( keyboard) + left mouse for moving ( pan, shift) - 
like Photoshop or  Concept draw ( big smile).

Nice testing...
Krokodil


Dňa 2. 8. 2013 13:10 bugzilla-daemon@freedesktop.org wrote / napísal(a):
> Jorendc <mailto:jorendc@libreoffice.org> changed bug 67419 
> <https://bugs.freedesktop.org/show_bug.cgi?id=67419>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEEDINFO
> CC 		jorendc@libreoffice.org
> Summary 	Draw 	Viewport movements are slow with bigger documents
> Ever confirmed 		1
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=67419#c1> 
> on bug 67419 <https://bugs.freedesktop.org/show_bug.cgi?id=67419> from 
> Jorendc <mailto:jorendc@libreoffice.org> *
> Hi,
>
> Thanks for your report.
> I'm not sure this is fixable for your document in 'particular', because I think
> the code base of LibreOffice is getting cleaner more and more. This result in
> less code/loops to run, which will result in a snappier LibreOffice.
>
> To test if it is extremely unresponsive, is it possible to attach a test
> document were we can reproduce the behavior?
>
> Kind regards,
> Joren
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 krokodil 2013-08-02 13:09:51 UTC
Created attachment 83542 [details]
attachment-22764-1.dat
Comment 4 krokodil 2013-08-02 13:09:51 UTC
Created attachment 83543 [details]
DRAW_test.odg
Comment 5 Jorendc 2013-12-28 12:38:22 UTC
Reproducible, tested using Windows 8.1 with LibreOffice Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Comment 6 QA Administrators 2015-04-19 03:22:54 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2015-06-18 15:47:04 UTC
I guess it is a bit stepped still.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 437210d58f32177ef1829d704f7f4d2f1bbfbfdd
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-18_07:21:56
Locale: fi-FI (fi_FI)
Comment 8 Robinson Tryon (qubit) 2015-12-09 18:07:53 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2017-01-03 19:41:54 UTC Comment hidden (obsolete)
Comment 10 Roman Kuznetsov 2018-12-11 17:01:28 UTC
movement of content in ODG file from attach is very fast 

Версия: 6.2.0.0.beta1
ID сборки: d1b41307be3f8c19fe6f1938cf056e7ff1eb1d18
Потоков ЦП: 4; ОС:Windows 6.1; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); UI-Language: ru-RU
Calc: threaded

I have here Core i3-3120m (max 2.5GHz, a notebook) with 4Gb of memory, Windows 7

status -> WFM