Download it now!
Bug 67582 - FILEOPEN: specific Word file, 80+ pages with ~70 (animated) images, opens slow/freezes; impossible to work with
Summary: FILEOPEN: specific Word file, 80+ pages with ~70 (animated) images, opens slo...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.1:OSX interoperability
Keywords: filter:doc, perf
Depends on:
Blocks: DOC-Images
  Show dependency treegraph
 
Reported: 2013-07-31 13:04 UTC by Slava
Modified: 2019-06-26 08:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Not open file (2.35 MB, application/msword)
2013-07-31 13:04 UTC, Slava
Details
screen shot of how it looks in 4.1.0.4 on Ubuntu (286.02 KB, image/png)
2013-07-31 13:40 UTC, Cor Nouws
Details
Windows 7 x64 8GB (2.35 MB, application/msword)
2013-07-31 13:53 UTC, Slava
Details
screen shot Windows 7 x64 8GB (93.85 KB, image/jpeg)
2013-07-31 14:04 UTC, Slava
Details
attachment-19923-0.html (1.83 KB, text/html)
2013-07-31 14:15 UTC, Slava
Details
attachment-19923-1.dat (1 bytes, multipart/alternative)
2013-07-31 14:15 UTC, Slava
Details
11.jpg (93.85 KB, image/jpeg)
2013-07-31 14:15 UTC, Slava
Details
document opens OK in LibreOffice daily 20160919 on Linux (336.21 KB, image/png)
2016-09-20 12:00 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Slava 2013-07-31 13:04:14 UTC
Created attachment 83362 [details]
Not open file
Comment 1 Cor Nouws 2013-07-31 13:38:05 UTC
Thanks for the report, Slava.

I change the summary a bit: it does open for me, but I can imagine that some computers will fail (due to lack of memory - though mine with Ubuntu only has 4GB).
Best,
Cor
Comment 2 Cor Nouws 2013-07-31 13:40:11 UTC
Created attachment 83365 [details]
screen shot of how it looks in 4.1.0.4 on Ubuntu

screen shot to help others
Comment 3 Slava 2013-07-31 13:53:50 UTC
Created attachment 83367 [details]
Windows 7 x64 8GB
Comment 4 Slava 2013-07-31 14:04:23 UTC
Created attachment 83368 [details]
screen shot Windows 7 x64 8GB
Comment 5 Slava 2013-07-31 14:15:26 UTC
Created attachment 83369 [details]
attachment-19923-0.html

Среда, 31 июля 2013, 13:40 UTC от bugzilla-daemon@freedesktop.org:
>Comment # 2 on  bug 67582 from < a href="sentmsg?mailto=mailto%3acno%26%2364%3bnouenoff.nl" title="Cor Nouws  " target="_blank"> Cor Nouws
>Created attachment 83365 [details]
screen shot of how it looks in 4.1.0.4 on Ubuntu

screen shot to help others
>----------------------------------------------------------------------
>You are receiving this mail because:
>*  You reported the bug.
Comment 6 Slava 2013-07-31 14:15:27 UTC
Created attachment 83370 [details]
attachment-19923-1.dat
Comment 7 Slava 2013-07-31 14:15:27 UTC
Created attachment 83371 [details]
11.jpg
Comment 8 Matthias Basler 2014-01-03 22:05:34 UTC
Guessing from the title, this might be another duplicate of issue 63433?
Comment 9 retired 2014-01-04 10:14:52 UTC
Confirmed:4.2.0.1:OSX

While this document is pretty chaotic and covers a ton of edge cases it displays ok in Word but looks very broken when opened with LO.
Comment 10 Joel Madero 2015-05-02 15:44:20 UTC Comment hidden (obsolete)
Comment 11 Slava 2015-05-05 07:48:56 UTC
 Not open file. LibreOffice 4.4.2, 4.4.3.1, 4.4.3.2
Comment 12 Cor Nouws 2015-05-06 10:03:45 UTC
Thanks for confirming, Slava.

Please do not change field version and so.
Comment 13 QA Administrators 2016-09-20 09:37:58 UTC Comment hidden (obsolete)
Comment 14 Slava 2016-09-20 11:21:45 UTC
LibreOffice 5.1.5 5.2.1 x86 not open file.
LibreOffice 5.2.1 x64 open file, but hangs. RAM 3800 Гб 
Windows 7 x64
Comment 15 Cor Nouws 2016-09-20 12:00:10 UTC
Created attachment 127461 [details]
document opens OK in LibreOffice daily 20160919 on Linux
Comment 16 Cor Nouws 2016-09-20 12:04:23 UTC
Opening in 5.2.1.2 on Windows 7 64 bits... indeed open but then nothing can be done, every action hangs
I did set Tools > Options > Memory LibreOffice to 400 MB and number of objects to 100.

set to Windows only
Comment 17 Thomas Lendo 2017-10-02 07:46:12 UTC
Performance issue still reproducible with
Version: 6.0.0.0.alpha0+ (x64)
Build-ID: d918a8086af56d1869e465baae64d960e56066d1
CPU-Threads: 8; Betriebssystem: Windows 6.19; UI-Render: Standard; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2017-09-08_22:40:30
Gebietsschema: de-DE (de_DE); Calc: group

Adding to meta "DOC-Images" bug 112701 because there are no other objects in that file which can cause the problem as far as I can see. Performance problems with images are known in LibO, see other regressions and perf bugs e.g. in meta "Images" bug 108437 or meta "Scrolling" bug 108075.
Comment 18 Thomas Lendo 2017-10-02 07:47:02 UTC
On Win10, the attached file needs 3200 MB of RAM!
Comment 19 QA Administrators 2018-10-03 02:54:17 UTC Comment hidden (obsolete)
Comment 20 Slava 2018-10-03 06:28:32 UTC
LibreOffice 6.1.2.1 x64 open the file. RAM 3900 Гб
Comment 21 Noel Grandin 2019-06-25 08:03:43 UTC
On current trunk (i.e. 6.3) this seems to be working fine, opens in less than 10s for me (on Linux)
Comment 22 Xisco Faulí 2019-06-26 08:10:01 UTC
it opens in less than 20 seconds in

Version: 6.4.0.0.alpha0+ (x64)
Build ID: fe855eda54faf6196ad9dea12d8dc090b6d6c1da
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

Setting status to RESOLVED WORKSFORME since we don't know which commit fixed this issue...