Bug Hunting Session
Bug 67602 - Unable to open .eps files: "Graphics filter not found"
Summary: Unable to open .eps files: "Graphics filter not found"
Status: RESOLVED DUPLICATE of bug 68210
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-08-01 04:48 UTC by Björgvin Ragnarsson
Modified: 2013-09-04 15:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample eps (2.86 KB, application/postscript)
2013-08-01 17:38 UTC, Joel Madero
Details
Resulting Draw File (7.93 KB, application/vnd.oasis.opendocument.graphics)
2013-08-01 17:38 UTC, Joel Madero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björgvin Ragnarsson 2013-08-01 04:48:17 UTC
How to reproduce:

Take any .eps file and open it. A dialog displays "Graphics filter not found" and the file is not opened.

This is a regression since 4.0. Reproducible on Linux but not Windows XP.

(It's good to be aware that there are also other unrelated EPS issues: #64161, #67465)
Comment 1 Joel Madero 2013-08-01 17:37:58 UTC
Marking as WFM 

Bodhi Linux x64
Version 4.1.0.4 release

Attached you'll find a EPS and the resulting draw file that I created after opening it.

Seems like you are missing some dependencies there - how did you install LibreOffice? What distro? Did you purge whatever version you had prior? 

If running Ubuntu we recommend sticking with the official ppa - if you installed from TDF (libreoffice.org) let us know so we are aware but purge LibreOffice completely and install from the official ppa.
Comment 2 Joel Madero 2013-08-01 17:38:15 UTC
Created attachment 83463 [details]
sample eps
Comment 3 Joel Madero 2013-08-01 17:38:34 UTC
Created attachment 83464 [details]
Resulting Draw File
Comment 4 Björgvin Ragnarsson 2013-08-02 02:23:16 UTC
I downloaded the LibreOffice x86 .deb release for comparison and the bug is not there.

It's most likely a bug in the Ubuntu package 1:4.1.0-0ubuntu1~precise1~ppa1 (x86). I'll report this issue to the Ubuntu packaging team.
Comment 5 Joel Madero 2013-08-02 02:35:16 UTC
Ill add our Canonical person just so he is aware.

Bjoern - looks like ubuntu specific
Comment 6 Björgvin Ragnarsson 2013-08-08 15:20:19 UTC
I'm reopening this for Bjoern or someone else to confirm the issue.
Comment 7 Joel Madero 2013-08-08 15:25:56 UTC
UNCONFIRMED is correct status - changing
Comment 8 Robert Großkopf 2013-08-12 06:09:45 UTC
Not only a Ubuntu-packinging-problem. The same bug appears in packages of OpenSUSE.
https://bugzilla.novell.com/show_bug.cgi?id=834374
Isn't a problem of LO.
Comment 9 Carl Michal 2013-08-13 16:46:25 UTC
This also a problem in Gentoo

Attempts to EPS import and export both give the "Graphics filter not found" error.

Bug report here:
https://bugs.gentoo.org/show_bug.cgi?id=478648

Is there some advice that can be given to packagers on what needs to be done differently in 4.1 for the eps import/export filters to work?
Comment 10 Björn Michaelsen 2013-09-01 14:44:33 UTC
confirmed by multiple downstream bugs
Comment 11 Robert Großkopf 2013-09-01 15:58:50 UTC
(In reply to comment #10)
> confirmed by multiple downstream bugs

Could be I don't understand right, but ...

Nobody has ever confirmed this bug appears in the original packages from LO. All confirmations come from other packages: Ubuntu, SuSE ...

When I open LO 4.1.1.1 directly from LO I could import *.eps-files. When I try the same with 4.1.1.2 from SUSE I couldn't import *.eps-files.
Comment 12 Carl Michal 2013-09-01 23:18:16 UTC
I believe Robert is correct. The official builds don't show the problem, but downstream builds since 4.04 do.

Is there something different required in the build environment to allow the eps import/export filters to be found?
Comment 13 Robert Großkopf 2013-09-02 14:25:21 UTC
I have just opened a document with connected *.tif-files. The same procedure. LO, installed from OpenSUSE-packages, doesn't work. It doesent show any *.tif-image and when I try to insert a new *tif-image the dialog "Graphics filter not found" appears.
The same version, installed from LO directly, works. There is a file libgraphicfilterlo.so. When I look at LO 4.1.1.2 from OpenSUSE it is 95,3 kb. When I look at LO 4.1.1.1 from LO directly, it's 141,4 kb.
Comment 14 Björn Michaelsen 2013-09-03 10:23:35 UTC
Likely same root cause as fdo#68210: mergedlibs broke between 4.0 and 4.1.
Comment 15 Carl Michal 2013-09-03 20:59:33 UTC
I can confirm that on gentoo, when --enable-mergedlibs is removed from the configure command, the eps import/export problem goes away.
Comment 16 Björn Michaelsen 2013-09-04 15:34:58 UTC
Not strictly speaking a dupe, but caused by the same root cause as fdo#68210

*** This bug has been marked as a duplicate of bug 68210 ***