Bug 67616 - FORMCONTROLS: Checkbox not working in Writer without assigned label text
Summary: FORMCONTROLS: Checkbox not working in Writer without assigned label text
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.3 rc
Hardware: All All
: lowest normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Form-Controls
  Show dependency treegraph
 
Reported: 2013-08-01 09:44 UTC by Florian Ebnet
Modified: 2019-01-22 08:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Simple Check Box (8.68 KB, application/vnd.oasis.opendocument.text)
2013-08-01 16:58 UTC, Joel Madero
Details
Sample of an affected document (12.60 KB, application/vnd.oasis.opendocument.text)
2013-08-01 19:31 UTC, Florian Ebnet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Ebnet 2013-08-01 09:44:21 UTC
Problem description: 

Steps to reproduce:
1. Create checkbox. Do not assign a Label.
2. Leave design mode.
3. Click checkbox.

Current behavior:
No state change.

Expected behavior:
State change.

Additional oddity: After exporting the same document as PDF form and opening it in Acrobat the checkbox works as expected even without a label.

Should this be the intended behaviour then the form controls documentation needs to reflect this!
              
Operating System: Windows 7
Version: 4.1.0.3 rc
Comment 1 Joel Madero 2013-08-01 16:58:29 UTC
This one works for me:

Bodhi Linux
LibreOffice version 4.0.4

Attached: simple document with checkbox with no label/name - you can check it


Marking as WFM - if you can't click the checkbox on the attached document please set to UNCONFIRMED. If you have a different attachment that you can provide that shows that we cannot click the check box please attach and mark as UNCONFIRMED.

Thanks!
Comment 2 Joel Madero 2013-08-01 16:58:52 UTC
Created attachment 83458 [details]
Simple Check Box
Comment 3 Florian Ebnet 2013-08-01 19:25:35 UTC
Weird, now I cannot reproduce the issue even by removing the labels in the affected document. Your test case works perfectly fine as well. For whatever reason there must have been a glitch in the affected file that went away by adding the labels once. Adding and editing additional checkboxes has not triggered the issue again.

It was there, and not just for me but for another user on the same document, but we both cannot reproduce it. I am going to leave the bug on WFM; If I ever come across that glitch again I will attach the affected file.
Comment 4 Florian Ebnet 2013-08-01 19:30:57 UTC
My colleague managed to find a backup of the affected file; I will attach a redacted version with just the affected checkboxes.
Comment 5 Florian Ebnet 2013-08-01 19:31:42 UTC
Created attachment 83476 [details]
Sample of an affected document
Comment 6 Joel Madero 2013-08-01 19:38:23 UTC
I think it's something to do with the table inside of the document not with the labeling - it would be really nice to get reproducible steps for a fresh document but I can confirm the behavior here so...


New (confirmed)
Normal - could theoretically prevent professional work
Lowest - as of now we have one test case and no way to reproduce from scratch - with Florian saying he is also unable to create from scratch I'm leaving this as lowest. If we can get steps that reproduce the problem from a blank state then we can up this to low or medium.


Thanks Florian for test case.
Comment 7 QA Administrators 2015-04-01 14:41:03 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-04-22 18:43:12 UTC
(In reply to Florian Ebnet from comment #5)
> Created attachment 83476 [details]
> Sample of an affected document

Yep, can't affect state.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI
Comment 9 QA Administrators 2016-09-20 09:33:38 UTC Comment hidden (obsolete)
Comment 10 Roman Kuznetsov 2019-01-22 08:07:29 UTC
don't repro in

Version: 6.2.0.1
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

Status->WFM