Bug 67627 - Clicking on the toolbox icons of the sidebar should both open and close Decks
Summary: Clicking on the toolbox icons of the sidebar should both open and close Decks
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: high enhancement
Assignee: Thomas Arnhold
QA Contact:
URL:
Whiteboard: target:4.4.0
Keywords: difficultyBeginner, easyHack, skillCpp
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2013-08-01 15:21 UTC by Stefan Knorr (astron)
Modified: 2016-10-24 14:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Manipulated screenshot, to hopefully make things clearer. (25.54 KB, image/png)
2013-08-01 15:21 UTC, Stefan Knorr (astron)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2013-08-01 15:21:23 UTC
Created attachment 83445 [details]
Manipulated screenshot, to hopefully make things clearer.

I assume you are using 4.1 or higher and have enabled the experimental sidebar, if not, in LibreOffice go to Tools > Options > LibreOffice/Advanced > Enable Experimental Sidebar. You are then prompted to restart, do it.


Just to clear the terminology, in my view, the new experimental sidebar
consists of two parts (see screenshot if it's still unclear):
  1. a panel selector (the far-right thing)
  2. a panel area (the thing that houses Properties, Navigator, Styles
    panel themselves)

(see screenshot if it's still unclear)

Now, clicking on one of the buttons in the panel selector will let you go
that panel, or in case no panel is open (because you closed it with the X
button at the top of the panel area before), it will open.
However, clicking the same button again will not close the panel. This is
a bit user-hostile, since for one, the button in the panel is a bigger, more
colourful target, and for the other, it always helps to have both expected
ways of doing something available.

Using LibreOffice 4.1.0.4 on Linux x86-64.
Comment 1 Joel Madero 2013-08-01 16:14:30 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.1
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
High

Keywords - 

Whiteboard Status - proposedeasyhack

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Joel Madero 2014-02-27 22:55:07 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 3 Thomas Arnhold 2014-08-24 00:50:36 UTC
Changed the wording of the header. Explanation: The Toolbox consists of the main Sidebar icons. If you click on such an icon a Deck opens, which itself contains panels (like Character and Page for the Properties Deck).
Comment 4 Commit Notification 2014-08-24 03:28:53 UTC
Thomas Arnhold committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=04e96b6d6eb55b9ff2a6ec9c4ce52260e33df121

fdo#67627 Clicking on icons of the sidebar should both open and close Decks



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Samuel Mehrbrodt (CIB) 2014-10-17 08:18:43 UTC
I had to revert this because it had an unwanted side effect (bug 84351).
This needs to be redone so that it only closes the deck, when clicked on the tabbar, not when called from somewhere else.
Comment 6 Kevin 2014-10-29 14:05:37 UTC
Hello,

I'm hoping to have this reimplemented. Libreoffice 4.3.3 on Linux Mint 17 'Qiana' - clicking on the icons in the "1" area as in the picture does not close the toolbar, as was stated by Stefan. This would be a nice enhancement for power users.

Thank you!
Comment 7 Commit Notification 2014-11-05 22:17:18 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d59b9b4af36148e4d8df8f3e3492116d378642e2

fdo#67627 fdo#85791 Allow to show/hide sidebar decks with the same command

It will be available in 4.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Mike §chinagl 2014-12-20 22:57:46 UTC
This bug fix comes with LibreOffice 4.4 (release notes https://wiki.documentfoundation.org/ReleaseNotes/4.4) 

Tabs icons now also work as a toggle to open/close sidebar decks.
Comment 9 Robinson Tryon (qubit) 2015-12-15 23:35:50 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyBeginner SkillCpp )
[NinjaEdit]