Bug 67629 - FILEOPEN Particular .xlsx hangs Spreadsheet & pegs a core
Summary: FILEOPEN Particular .xlsx hangs Spreadsheet & pegs a core
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords: filter:xlsx, perf
Depends on:
Blocks: XLSX CPU-AT-100%
  Show dependency treegraph
 
Reported: 2013-08-01 16:13 UTC by Ben
Modified: 2019-04-26 20:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
File demonstrates issue (98.40 KB, application/zip)
2013-08-01 16:18 UTC, Ben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben 2013-08-01 16:13:37 UTC
The attached file reliably hangs Spreadsheet (and has the same behaviour on Apple's Numbers, and appears to display the same behaviour in GDocs, but opens fine in MS Excel). 

The file was originally generated in this version (4.0.1.2) of LibreOffice. It contains less than 50 lines, but is over 3M in size. I suspect that this may be more of a generation issue than a parsing one.

The system shows 1 core pegged at 100% whilst it attempts to open the file.

By the way, the user experience of trying to report a bug on this website as a new user is utterly appalling.
Comment 1 Ben 2013-08-01 16:18:10 UTC
Created attachment 83451 [details]
File demonstrates issue

Please unzip the attached - BZ refuses to accept attachments over a paltry 3M & I had to zip it. 

By the way, the originally message about "I couldn't attach your file, please do so manually" is so easy to miss, that I almost closed this tab.

Really, guys, do something about the UX here - you'll get better bug reports...
Comment 2 Thomas van der Meulen 2013-08-01 17:55:18 UTC
Thank you for your bug report, I can reproduce this bug running LibreOffice Version: 4.1.0.4
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28 on Mac osx 10.8.4. 

It also opens slow on Apple Numbers.
Comment 3 Thomas van der Meulen 2013-08-01 18:00:22 UTC
BTW.. wenn I open it with Apple Numbers it looks like there are a lot of the same lines with "=SOM(B10:B21)" more than 65.553 lines says Numbers.. so maybe this a why it also loads slowly
Comment 4 QA Administrators 2015-04-19 03:19:49 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-06-15 06:56:25 UTC
Yep, hangs.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 01a189abcd9a4ca472a74b3b2c000c9338fc2c91
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-14_07:46:28
Locale: fi-FI (fi_FI)

LibreOffice 3.5.0rc3 
Käännöksen ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 6 QA Administrators 2016-09-20 10:00:16 UTC Comment hidden (obsolete)
Comment 7 raal 2018-06-12 17:37:05 UTC
LO 6.2 -  load 100% of cpu, bug still present.
Comment 8 Xisco Faulí 2019-04-24 12:32:31 UTC
it takes

real	37m5,736s
user	37m14,491s
sys	0m2,482s

in

Version: 6.3.0.0.alpha0+
Build ID: 90e3b47b52f26420425a7417d2f51b6a386282d9
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Noel, another one that might be interesting to you...
Comment 9 Roman Kuznetsov 2019-04-24 18:16:50 UTC
https://gerrit.libreoffice.org/#/c/71251/
Comment 10 Commit Notification 2019-04-25 06:10:03 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e1ebb5cb58edc325bb30bb5eb992665fb861960f%5E%21

tdf67629 FILEOPEN Particular .xlsx hangs Spreadsheet

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2019-04-25 10:13:26 UTC
wow!!! it takes

real	0m14,815s
user	0m21,387s
sys	0m1,605s

in

Version: 6.3.0.0.alpha0+
Build ID: fad98c8641342a77241124dd98e0cb781daef4ad
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

AMAZING!!

@Noel, thanks a lot for fixing this!!
Comment 12 Commit Notification 2019-04-26 20:07:03 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/9dac5b11bc9d8b9709611846d6ded07cecacc94c%5E%21

tdf67629 FILEOPEN Particular .xlsx hangs Spreadsheet

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.