Bug 67689 - Writer won't export international characters correctly using Frutiger-Roman type font
Summary: Writer won't export international characters correctly using Frutiger-Roman t...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2013-08-02 23:39 UTC by Eduardo Alvim
Modified: 2019-01-05 12:06 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF and ODT files (40.66 KB, application/x-zip-compressed)
2013-08-02 23:39 UTC, Eduardo Alvim
Details
Frutiger Font Type (242.18 KB, application/x-zip-compressed)
2013-08-04 13:30 UTC, Eduardo Alvim
Details
PDFs and XPS made by exporting and printing of the testcase from Comment #0 (165.72 KB, application/x-zip-compressed)
2013-08-04 20:03 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo Alvim 2013-08-02 23:39:55 UTC
Created attachment 83557 [details]
PDF and ODT files

When using accentuated characters in Writer, with Frutiger-Roman type font, for example those used by Brazilian-Portuguese (é, ç, ã, à, ô) PDF exports include bogus characters. See attached ODT and PDF files.
Comment 1 Thomas van der Meulen 2013-08-03 06:44:22 UTC
Thank you for your bug report, I cannot reproduce this bug running LibreOffice Version: 4.1.0.4
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28 on Mac osx 10.8.4. 

maybe it is a Windows only bug ...
Comment 2 Mike Kaganski 2013-08-04 00:21:28 UTC
Font details are needed to be able to reproduce this bug.

If the font is free, then please provide a link to it (or attach here, if appropriate).
Comment 3 Eduardo Alvim 2013-08-04 13:30:50 UTC
Created attachment 83612 [details]
Frutiger Font Type

I'm attaching the Frutiger Font type here ONLY FOR TESTING PURPOSES. Delete it from your system once finished.
Comment 4 Mike Kaganski 2013-08-04 20:01:33 UTC
Reproducible with all versions starting from 3.3.0.4 to 4.1.0.4; also reproducible with AOO 4.0.

Version 3.3.0.4 produces a PDF that emits an error on opening saying that Reader cannot load the embedded font properly. Other versions create PDFs that don't emit the message. However, all look identical.

If printed to a virtual printer (like PDFill, or MS XPS Writer), the resulting file is OK.
Comment 5 Mike Kaganski 2013-08-04 20:03:47 UTC
Created attachment 83626 [details]
PDFs and XPS made by exporting and printing of the testcase from Comment #0
Comment 6 QA Administrators 2015-04-01 14:42:23 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2015-04-24 16:23:22 UTC
Still reproduced.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI
Comment 8 Eduardo Alvim 2015-06-26 12:46:10 UTC
Still reproduced.

Windows 8.1 Pro 64-bit
Versão: 4.4.3.2
ID de compilação: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Local: pt_BR
Comment 9 QA Administrators 2016-09-20 10:11:09 UTC Comment hidden (obsolete)
Comment 10 Roman Kuznetsov 2019-01-05 11:32:00 UTC
This font is Type-1. IMHO LO dropped support of those fonts family.

Mike, am I right or not?
Comment 11 Buovjaga 2019-01-05 12:06:43 UTC
(In reply to Roman Kuznetsov from comment #10)
> This font is Type-1. IMHO LO dropped support of those fonts family.
> 
> Mike, am I right or not?

You are right. Let's close.