Bug Hunting Session
Bug 67742 - [FORMATTING] Autocorrection prevents horizontal line/rule after inserting three dash "---" and pressing enter.
Summary: [FORMATTING] Autocorrection prevents horizontal line/rule after inserting thr...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: high normal
Assignee: Laurent BP
URL:
Whiteboard: target:4.2.0 target:4.1.4
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-04 12:48 UTC by Papamatti
Modified: 2013-11-25 11:26 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Papamatti 2013-08-04 12:48:41 UTC
Normally after inserting three dashes "---" and pressing enter they will repleaced by a horizontal line/rule. (This works until LibreOffice 4.0)

In LibreOffice 4.1 the autocorrection replaces the two of the three dashes with a long dash and a short dash remains. Writer cannot see the three dashes anymore and does not replace it with a horizontal line.

If i disable autocorrection or delete the rule to replace "--" with a long dash the function to insert a horizontal line with three dashes works well.
Comment 1 Jorendc 2013-08-04 12:59:42 UTC
Thanks Papamatti :)!

Confirmed, tested using Windows 8 with LibreOffice Version: 4.2.0.0.alpha0+
Build ID: 2382b8e8ec0ea65dc2a9ad1c401abe3be35a1487 TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-08-02_23:15:16
Comment 2 曾孝薇 2013-09-18 19:25:43 UTC
Inserting three equal signs (===) cannot replaced by double horizontal line either
Comment 3 Mateusz 2013-11-04 20:45:37 UTC
When I last tested LO 4.2 DEV, horizontal line worked correctly. Please check the newest master build and inform developers here about solution in new branch.
Comment 4 Laurent BP 2013-11-18 11:13:05 UTC
Test with Version: 4.2.0.0.alpha1+
Build ID: 935f1f61cbe112b1cf1ab95bae9dfcb42b4fdb5e

I can reproduce with ---
I do NOT reproduce with ===
Comment 5 Laurent BP 2013-11-18 14:24:36 UTC
(In reply to comment #2)
> Inserting three equal signs (===) cannot replaced by double horizontal line
> either

Actually, with ===, border exists but is almost invisible. I opened a new bug as it is different from this one: bug 71740

This bug (with ---) is due to the fact that since LibO 4.1, '-' is recognized as word separator in AutoCorrection. So, the 3rd '-' launches AutoCorrection of "--" in "–".
Comment 6 Commit Notification 2013-11-20 10:52:48 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7a32f528fe4746e721e7f1a45f2039b75b08fdfc

fdo#67742 Avoid autocorr of "--" before "-"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Mateusz 2013-11-20 11:24:16 UTC
Please, push commitment to 4.1.4 branch as well.
Comment 8 retired 2013-11-20 16:55:49 UTC
Verified. Thanks a lot, Laurent!
Comment 9 tommy27 2013-11-24 05:30:00 UTC
(In reply to comment #7)
> Please, push commitment to 4.1.4 branch as well.

+1 nice fix. please cherry-pick to 4.1.4
Comment 10 Commit Notification 2013-11-25 11:26:10 UTC
Laurent Balland-Poirier committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0299cfaca263b1cc635980fdd8497346d5cb8513&h=libreoffice-4-1

fdo#67742 Avoid autocorr of "--" before "-"


It will be available in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.