Download it now!
Bug 67905 - Enhancement: Add ability to turn off preview in print dialog
Summary: Enhancement: Add ability to turn off preview in print dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
: 83920 (view as bug list)
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2013-08-08 14:36 UTC by crxssi
Modified: 2019-01-14 23:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File Print Dialog Preview on/off mockup (68.80 KB, image/png)
2013-08-08 14:36 UTC, crxssi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description crxssi 2013-08-08 14:36:38 UTC
Created attachment 83838 [details]
File Print Dialog Preview on/off mockup

The page "preview" area in the newer LO print dialog is nice for most users, most of the time.

However, there are times when the delay required to render that preview is annoying.  It is especially annoying on slow systems, on thin clients, on complex/big documents, and on users remotely running LO.  And the negativity is compounded since the preview is re-rendered with most UI selection/changes (printer change, Properties, Page Layout, etc).

There should be a "Preview" on/off checkbox below the page number indicator- and the setting remembered across sessions.  We already have such an option in the file manager dialog when using Insert->Picture->From File.

I have attached a "before and after" mockup graphic attachment.
Comment 1 Joel Madero 2013-08-09 00:05:14 UTC
@Mike - please leave a short comment when confirming bugs - easier to tell who confirmed it :) Thanks for confirming this one
Comment 2 Milos Sramek 2014-03-20 09:57:50 UTC
Hi,

I vote for this enhancement. We run LO on a Windows server with about 30 users and the print dialog is unacceptably slow. This is mostly annoying if the print range is being changed - the preview is unnecessarily rerendered after each digit being typed into the box, even though the preview page does not change. The users complain a lot about that.

The Preview" on/off checkbox could be a solution, but, maybe, it would be enough to rerender only if necessary and not after each change. For example, the "number of copies" control does not enforce rerendering.
--
Milos
Comment 3 haewa GmbH 2015-01-15 09:42:50 UTC
Our company has the same trouble with the preview in the print dialog.
We use LibreOffice in a Citrix XenApp environment(build on top of Terminal Servers) and experience a lot of trouble, especially with the Citrix Universal Print driver.
Through the print dialogue preview consumes a lot of cpu power while getting the printer information via network, the print operation might take a lot of time.


The print dialoge is also a problem on older fat clients with weak CPUs and takes up to 1 Minute until users can print a vew simple pages.

In my oppinion a solution to permanently deactivate the print dialog preview is better than render only once, because even the initial rendering slows down the performance
Comment 4 haewa GmbH 2015-01-26 14:40:01 UTC
*** Bug 83920 has been marked as a duplicate of this bug. ***
Comment 5 Christoph 2015-08-17 22:07:10 UTC
Proposal for solving this issue in general.

Assumption: Also other regularly updated previews are troublesome - besides print preview (e.g. insert diagram, insert picture from file). However, previews itself are considered to be helpful and should be available on demand.

Option:
* Add expert option "Render previews automatically" (LibO wide setting)
* Expert option: Since common issue if LibO is set up for remote use / on thin clients - otherwise it might further clutter the UI.

Behavior:
* If option is "true" (default setting), then behave as today (and render previews, see technical note below).
* If option is "false", then ...
** Show/reserve space for preview, show info like "Click for preview"
** If user clicks on space, then previews are being rendered/shown (only for this dialog session).

Note: Technically, previews should only be updated if "something" changed from the user's point-of-view (e.g if the print range is changed, it is not required to redraw the currently displayed page preview, if the previewed page is identical).

Detailed spec / description on demand.
Comment 6 crxssi 2015-08-17 22:52:25 UTC
(In reply to Christoph from comment #5)
> Proposal for solving this issue in general.

I like your proposal.
Comment 7 Xisco Faulí 2018-08-29 09:45:29 UTC
Dear Daniel Silva,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 8 Commit Notification 2018-11-29 16:02:24 UTC
Daniel committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2c23a96f7b6888c0e05fdc2aba57f03cd797b647%5E%21

tdf#67905 adds an option to disable print preview in print dialog

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Daniel Silva 2018-11-30 16:46:15 UTC
Dear Xisco,

This bug was also solved in my feature branch and we havefinally merged it master. Sorry for any inconvenience I may have caused.