Download it now!
Bug 67913 - Formatting of text within a drawing in Visio format is not placed vertically correctly
Summary: Formatting of text within a drawing in Visio format is not placed vertically ...
Status: RESOLVED WONTFIX
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libvisio (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-08 18:04 UTC by m_josenhans
Modified: 2017-10-30 11:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Vertically incorrect alignment of text with Visio diagram. (65.60 KB, application/x-zip-compressed)
2013-08-08 18:04 UTC, m_josenhans
Details
screenshot - VisioViewer (14.31 KB, image/png)
2015-12-31 13:03 UTC, David Tardon
Details
screenshot - LibreOffice (14.22 KB, image/png)
2015-12-31 13:03 UTC, David Tardon
Details
sample diagram (142.00 KB, application/vnd.visio)
2015-12-31 13:04 UTC, David Tardon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m_josenhans 2013-08-08 18:04:28 UTC
Created attachment 83859 [details]
Vertically incorrect alignment of text with Visio diagram.

A Viso drawing with a vertically incorrect allignment in LibreOffice 4.0.3.3.

This error apprears on Windows and Linux.
Comment 1 m_josenhans 2013-08-08 18:14:10 UTC
The above attachment is a zip file. This bug is closely related to bug #67914.
Comment 2 Mike Kaganski 2013-08-09 01:41:50 UTC
Reproducible with 4.1.0.4 under Win7x64.

The text in the attachment 83859 [details] is in single text frame, empty lines between labels make the alignment.

Looks like the frame is positioned by its center (correctly), but paragraph spacing is choosen incorrectly (it should be ~112% instead of 125%).
Comment 3 Julien Nabet 2013-08-24 06:38:34 UTC
On pc Debian x86-64 with master sources updated yesterday, I reproduced the problem.
Comment 4 QA Administrators 2015-04-01 14:40:31 UTC Comment hidden (obsolete)
Comment 5 Mike Kaganski 2015-04-02 09:03:13 UTC
Still REPRODUCIBLE with Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: ru_RU
Comment 6 David Tardon 2015-12-31 13:03:19 UTC
Created attachment 121659 [details]
screenshot - VisioViewer
Comment 7 David Tardon 2015-12-31 13:03:39 UTC
Created attachment 121660 [details]
screenshot - LibreOffice
Comment 8 David Tardon 2015-12-31 13:04:12 UTC
Created attachment 121661 [details]
sample diagram
Comment 9 Fridrich Strba 2016-01-15 09:58:13 UTC
OK, the only solution there is to play manually with the line spacing. I see in Visio line spacing of 125% and I set the same in Draw. It grows then little by little out of place. I played manually with the spacing and set it to something like 115% and the result is suddenly much better. I cannot fix this because I have no idea how Visio computes the rendering exactly. This are subtle implementation problems that a document importer cannot handle :(