Bug Hunting Session
Bug 67935 - EDITING: Report-Builder: "Print repeated value - No" doesn't work in the first group
Summary: EDITING: Report-Builder: "Print repeated value - No" doesn't work in the firs...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:4.3.0 target:4.2.6
Keywords:
Depends on:
Blocks: Database-Reports-Builder
  Show dependency treegraph
 
Reported: 2013-08-09 06:10 UTC by Robert Großkopf
Modified: 2017-07-23 21:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Database with report - print repeated values: no (40.50 KB, application/vnd.oasis.opendocument.base)
2013-08-09 06:10 UTC, Robert Großkopf
Details
Desciption and pictures of the bug (66.49 KB, application/pdf)
2013-08-09 06:11 UTC, Robert Großkopf
Details
File not usable (53.07 KB, application/pdf)
2013-08-09 10:02 UTC, Jochen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2013-08-09 06:10:16 UTC
Created attachment 83873 [details]
Database with report - print repeated values: no

When editing a report you could chose for a field for database-content or for labels the property "Print repeated values" - "no".
This didn't work in all versions of LO up to LO 4.0.0.1. All values have been printed - if not repeated or repeated. The first version I have tested were it works is LO 4.0.2.2.

When you open the report of the attached database you could see four groups in the report. 
The repeated values are printed in the first group. That's wrong.
The repeated values aren't printed in all other groups. That's right.

In the second attachment you could see, how it should work. There is an attached report, which shows the right behavior in the first group also. But this couldn't be reached by "Print repeated value - No". And this couldn't be saved in the report. It's another bug.
Comment 1 Robert Großkopf 2013-08-09 06:11:07 UTC
Created attachment 83874 [details]
Desciption and pictures of the bug
Comment 2 Jochen 2013-08-09 10:02:46 UTC
Created attachment 83887 [details]
File not usable

File not usable (attach). I can´t reproduce.
Comment 3 Robert Großkopf 2013-08-09 13:02:23 UTC
(In reply to comment #2)
> Created attachment 83887 [details]
> File not usable
> 
> File not usable (attach). I can´t reproduce.

Hello Jochen,

you can't open a database-file on the server, because you cannot write in the directory of the server.
Please download the file and open it. Then all actions are possible and nothing is greyed out.
Comment 4 Jochen 2013-08-09 13:14:34 UTC
After download file also not usable.
Comment 5 Robert Großkopf 2013-08-09 13:32:07 UTC
(In reply to comment #4)
> After download file also not usable.

Hello Jochen,

one hint: Don't use LO 4.0.4 for opening a report. It will shutdown LO immediately.
Comment 6 Jochen 2013-08-09 13:38:21 UTC
Indeed - I´m using LO 4.0.4 for testing. I will use another version.
Comment 7 Jochen 2013-12-26 23:14:20 UTC
I can confirm the bug - using LO 4.1.3
Comment 8 Commit Notification 2014-05-27 10:48:53 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa48af57531851a16204381854f1ee19ebb63a6a

fdo#67935 "print on group change" acted as "print in first group instance"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-05-28 15:32:06 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=15499eae7edf9227996618d8a6d68cc9dac2c086&h=libreoffice-4-3

fdo#67935 "print on group change" acted as "print in first group instance"


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2014-05-28 15:33:36 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=23874c1f61898f9cab7e23169ca36596b2e6c982&h=libreoffice-4-2

fdo#67935 "print on group change" acted as "print in first group instance"


It will be available in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.