Bug 68210 - Cannot import or read imported tiff images in --enable-mergelibs build
Summary: Cannot import or read imported tiff images in --enable-mergelibs build
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Björn Michaelsen
URL:
Whiteboard: target:4.2.0 target:4.1.2
Keywords: regression
: 67602 67868 69902 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-17 06:56 UTC by thanasis57
Modified: 2013-12-09 16:04 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Tiff file that could not be imported (84.94 KB, image/tiff)
2013-08-17 11:09 UTC, thanasis57
Details

Note You need to log in before you can comment on or make changes to this bug.
Description thanasis57 2013-08-17 06:56:15 UTC
Using Libreoffice Writer 4.1 (directly from ppa:libreoffice/ppa) on Ubuntu 12.04 64bit.
I tried opening an existing .odt text file with tiff images imported as links. The imported images would not show. Instead only an empty and flickering frame showed up.
Also, I could not import new tiff files, either embedded in the document, or as links. When I tried (Insert --> Picture --> From file) I would get a "Filter not found" message.

However, other image formats (I tried png and jpg) could be correctly imported.

I downgraded to version 4.0 from ppa:libreoffice/libreoffice-4-0 and now it all works just fine [Version 4.0.4.2 (Build ID: 400m0(Build:2)].

sudo apt-get remove libreoffice*
sudo apt-get autoremove
sudo add-apt repository sudo add-apt-repository ppa:libreoffice/libreoffice-4-0
sudo apt-get updatesudo
apt-get install libreoffice
Comment 1 retired 2013-08-17 10:33:56 UTC
Could you please attach an example tiff file which you can't import?
Comment 2 thanasis57 2013-08-17 11:09:20 UTC
Created attachment 84169 [details]
Tiff file that could not be imported
Comment 3 tommy27 2013-08-20 12:03:13 UTC
Tiff import of your test file (Insert --> Picture --> From file) works fine on 4.1.0.4 using Win7 64bit.

is there any other Linux user who can test?
Comment 4 Thomas van der Meulen 2013-08-23 08:23:09 UTC
Thank you for your bug report, I CAN'T reproduce this bug running Version: 4.1.1.2
Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903 on Mac osx 10.8.4. 

but
version: 4.1.0.4 
Build ID: 410m0(Build:4) on Linux Mint 15
So it is a Linux only bug & a regression because you said it was working in version 4.0.x. (with I didn't test)
Comment 5 Michael Stahl (CIB) 2013-08-26 14:44:56 UTC
works for me on self built 4.1.0.4 and 4.0.4.2 and master versions

Bjoern, seems reporter is using Ubuntu PPA - perhaps a packaging bug?
Comment 6 Björn Michaelsen 2013-09-02 19:50:18 UTC
A quick check with various versions shows:
- 4.1 on saucy: "import filter not found"
- 4.0 on raring: works
- 4.1 on raring: "import filter not found"
Comment 7 Björn Michaelsen 2013-09-03 10:22:44 UTC
Debian is not hit by this in 4.0 and 4.1. Digging further, this seems to be an upstream regression with enable-mergedlibs, which Debian is not using, but Ubuntu does in both 4.0 and 4.1.
Suspicious commits:

38e95dc334047dfb9a7ae959deda4e4d2f39b3bf
eacf12eeb174e35a301570726bf74434a4dd4b94

by Peter Foley, thus CC'ing as I dont know his IRC nick.

Also: https://bugs.freedesktop.org/show_bug.cgi?id=67602 likely has the same root cause.
Comment 8 Commit Notification 2013-09-04 14:52:13 UTC
Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dc86610d16a561ff1a0455d5fef157431f9271e3

fdo#68210: Make tiff import work again with merged-libs



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-09-04 15:02:48 UTC
Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3a021c00d9b27e6bcafbfaf8bf7b36cdd40768e2

fdo#68210 related: make other filters work again too



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Björn Michaelsen 2013-09-04 15:34:58 UTC
*** Bug 67602 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2013-09-05 12:42:41 UTC
Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d4d60f0abadf048ae203914f5b4e8b828ff76f16&h=libreoffice-4-1

fdo#68210: Make tiff import work again with merged-libs


It will be available in LibreOffice 4.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2013-09-11 10:53:56 UTC
Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=88a97db7e630a70e68afcc80277174b9dd5ec159&h=libreoffice-4-1-2

fdo#68210: Make tiff import work again with merged-libs


It will be available already in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 ign_christian 2013-09-28 09:35:41 UTC
*** Bug 69902 has been marked as a duplicate of this bug. ***
Comment 14 Jean-Baptiste Faure 2013-10-24 21:08:58 UTC
Hi,

This bug has still the NEW status: are these patches only partial, preventing to mark this bug as fixed?

Best regards. JBF
Comment 15 tommy27 2013-10-24 22:04:13 UTC
it is a Linux specific bug. any Linux user can still confirm this?
Comment 16 Björn Michaelsen 2013-10-25 12:55:17 UTC
Indeed this is now fixed.
Comment 17 Stefan Gruber 2013-11-14 21:39:42 UTC
In Libreoffice 4.1.3.2 it doesn't seem to be fixed.
Just tested with opensuse-factory-build on opensuse 12.3.
Same with the original version downloaded from the LO-website.

Can we expect a general solution, because this is a real blocker for 
business needs?
Comment 18 Michael Stahl (CIB) 2013-11-14 22:34:44 UTC
(In reply to comment #17)
> In Libreoffice 4.1.3.2 it doesn't seem to be fixed.
> Just tested with opensuse-factory-build on opensuse 12.3.
> Same with the original version downloaded from the LO-website.

i don't know about suse builds but the upstream builds from
libreoffice.org definitely do not use --enable-mergelibs
so you should file a separate bug if that doesn't work for you.
Comment 19 Stefan Gruber 2013-11-15 22:26:02 UTC
I'm sorry, it was obviously my fault, because I didn't test it with the example above.
This works with both - opensuse and upstream version.

My own testimage contained kind of compression, that is incompatible with LO.
Might be a task for improvement,but not a bug...
Comment 20 thanasis57 2013-11-20 16:35:16 UTC
After upgrading to 4.1 (again from ppa:libreoffice/ppa) I can confirm that the problem has been corrected.
Comment 21 Michael Stahl (CIB) 2013-12-09 16:04:39 UTC
*** Bug 67868 has been marked as a duplicate of this bug. ***