Download it now!
Bug 68249 - Writer does not draw a chart with "data series in rows" pasted from Calc correctly
Summary: Writer does not draw a chart with "data series in rows" pasted from Calc corr...
Status: RESOLVED DUPLICATE of bug 71075
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-08-18 22:45 UTC by John Kuang
Modified: 2013-11-06 03:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
messed up chart, saved with 4.1 (12.76 KB, application/vnd.oasis.opendocument.text)
2013-08-18 22:45 UTC, John Kuang
Details
chart saved with 4.0, opens fine in 4.0, but not in 4.1 (13.57 KB, application/vnd.oasis.opendocument.text)
2013-08-18 22:45 UTC, John Kuang
Details
ODS file with the chart data in series (14.31 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-08-18 22:46 UTC, John Kuang
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Kuang 2013-08-18 22:45:10 UTC
Created attachment 84212 [details]
messed up chart, saved with 4.1

In Writer 4.1, charts with "data series in rows" pasted from Calc gets messed up. It gets messed up slightly different when the ODT file was saved using 4.0 vs 4.1.

This is a regression, as it does not happen with 4.0. Also, it does not occur when the chart has "data series in columns".

Also, if you save the ODT with the messed up chart in 4.1, and then open it using 4.0, it is also messed up, so it is both a chart reading and writing issue.

Test files are attached for you to view in 4.0 vs 4.1. Both ODT files contain the same pasted chart from the ODS file, but was created in different versions of LibO.
Comment 1 John Kuang 2013-08-18 22:45:54 UTC
Created attachment 84213 [details]
chart saved with 4.0, opens fine in 4.0, but not in 4.1
Comment 2 John Kuang 2013-08-18 22:46:44 UTC
Created attachment 84214 [details]
ODS file with the chart data in series
Comment 3 Jean-Baptiste Faure 2013-09-15 15:51:36 UTC
Thank you for the bug report.

I reproduce the problem with LibreOffice 4.1.3.0.0+ and the master under Ubuntu 13.04 x86-64.

Best regards. JBF
Comment 4 Kevin Suo 2013-11-06 02:27:49 UTC
This seems to be the same issue as shown in Bug 71075 (chart mangling on paste), which was marked as fixed. So maybe this should be marked duplicated?
Comment 5 John Kuang 2013-11-06 02:57:16 UTC
I just checked this bug in libreoffice-4-1~2013-11-04_14.18.57_LibreOfficeDev_4.1.4.0.0_Win_x86.msi and it's no longer there! :)
Comment 6 Kevin Suo 2013-11-06 03:13:05 UTC
(In reply to comment #5)
> I just checked this bug in
> libreoffice-4-1~2013-11-04_14.18.57_LibreOfficeDev_4.1.4.0.0_Win_x86.msi and
> it's no longer there! :)

Yes it should be, as there was a "reverted patch" as discussed in bug 71075.

I think the correct status for this bug should be "RESOLVED DUPLICATED OF 71075".

*** This bug has been marked as a duplicate of bug 71075 ***