Bug Hunting Session
Bug 68259 - Import MS Publisher file
Summary: Import MS Publisher file
Status: RESOLVED INVALID
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libmspub (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 61579 68589
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 07:52 UTC by ComputerHotline
Modified: 2017-11-12 21:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
brochure.pub (189.50 KB, application/x-mspublisher)
2013-08-19 07:52 UTC, ComputerHotline
Details
bulletin (236.50 KB, application/x-mspublisher)
2013-08-19 07:54 UTC, ComputerHotline
Details
compo-rapide (81.50 KB, application/x-mspublisher)
2013-08-19 07:54 UTC, ComputerHotline
Details
en-tete (43.50 KB, application/x-mspublisher)
2013-08-19 07:55 UTC, ComputerHotline
Details
Some features partially supported by LibreOffice (77.00 KB, application/x-mspublisher)
2013-08-24 18:32 UTC, ComputerHotline
Details
Some features partially supported by LibreOffice (screenshots of Composition1.pub)) (767.21 KB, image/jpeg)
2013-08-24 18:34 UTC, ComputerHotline
Details
Toolbars of MSPUB2003 : design (162.28 KB, image/jpeg)
2013-08-24 18:34 UTC, ComputerHotline
Details
All wordarts of MSPUB2003 (188.93 KB, image/jpeg)
2013-08-24 18:35 UTC, ComputerHotline
Details
PDFs showing rendering in Draw and Publisher 2007 of first four PUB file attachments. (1.65 MB, application/zip)
2013-12-07 11:41 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ComputerHotline 2013-08-19 07:52:41 UTC
Created attachment 84229 [details]
brochure.pub

Hello.
When I open this attached files in LibreOffice, there are some errors of layout (text align).
Comment 1 ComputerHotline 2013-08-19 07:54:02 UTC
Created attachment 84230 [details]
bulletin
Comment 2 ComputerHotline 2013-08-19 07:54:25 UTC
Created attachment 84231 [details]
compo-rapide
Comment 3 ComputerHotline 2013-08-19 07:55:09 UTC
Created attachment 84232 [details]
en-tete
Comment 4 retired 2013-08-19 08:33:07 UTC
Hi there,

which file has which problem? Could you post a screenshot showing the layout issue? Maybe MS Office and LO side by side. That would help a lot getting this bug verified and thus taking the first step to get this fixed.
Comment 5 ComputerHotline 2013-08-19 17:59:31 UTC
brochure.pub : page 2 : the text go out of the page.
bulletin.pub : all pages : the text go out of the page.
compo-rapide.pub : the font is not respected.
en-tete.pub : no problem.
Comment 6 ComputerHotline 2013-08-21 11:05:16 UTC
Some MS Pub filter error.
In this template :
http://office.microsoft.com/fr-fr/templates/redir/TC010082249.aspx
the text go out of the page.

Some MS Pub templates are available here to test the LibreOffice Import filter :
http://office.microsoft.com/en-us/templates/publisher-templates-FX102828212.aspx
http://office.microsoft.com/fr-fr/templates/modeles-publisher-FX102832613.aspx
Comment 7 ComputerHotline 2013-08-24 18:32:52 UTC
Created attachment 84568 [details]
Some features partially supported by LibreOffice

Some features partially supported by LibreOffice
Comment 8 ComputerHotline 2013-08-24 18:34:05 UTC
Created attachment 84569 [details]
Some features partially supported by LibreOffice (screenshots of Composition1.pub))
Comment 9 ComputerHotline 2013-08-24 18:34:59 UTC
Created attachment 84570 [details]
Toolbars of MSPUB2003 : design

To integrate in Libreoffice Draw
Comment 10 ComputerHotline 2013-08-24 18:35:31 UTC
Created attachment 84571 [details]
All wordarts of MSPUB2003
Comment 11 ComputerHotline 2013-08-24 18:47:26 UTC
* "Some features partially supported by LibreOffice" (Composition1.pub) contains some feature partially supported by LibreOffice.
* "Some features partially supported by LibreOffice (screenshots of Composition1.pub))" contains screenshots of all pages of "Some features partially supported by LibreOffice" file.
* "Toolbars of MSPUB2003 : design" contains screenshots of all design toolbars.
* "All wordarts of MSPUB2003" contains screenshots of all WordArt used in MSPUB2003. All WordArt are used in "Some features partially supported by LibreOffice" file.
Comment 12 Owen Genat (retired) 2013-12-07 11:41:52 UTC
Created attachment 90401 [details]
PDFs showing rendering in Draw and Publisher 2007 of first four PUB file attachments.

Some of the problems detailed in this bug appear to be the same or similar to those reported in: 

- bug 61579: indentation, bullets, clip-art placement.
- bug 67299, repeated text (depends on next bug).
- bug 68589, add support for linking of text frames.

The first two are currently being worked on by developers. It may be best if this bug is restricted to a few select issues and the summary amended to be clearer about this, as there have been several attachments to this bug already and yet no PDF indicating what the original versions look like under Publisher. I have attached PDFs of the first four attachments. These illustrate what I am seeing here in Draw under Ubuntu 10.04 x86_64 running:

- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

... as well as MS Publisher 2007 (12.0.6676.5000) SP3 MSO (12.0.6683.5000) running under MS Windows 7 (6.1.7601). Hopefully this will help clarify the nature of the problems, which I see as:

A. brochure.pub:
a. minor text alignment, kerning on p.1.
b. text wrapping around graphics on p.2 (probably covered by 61579).
c. repeated text on p.2 (likely 67299/68589).

B. bulletin.pub:
a. missing bullets on p.1 (61579).
b. font sizing on p.4.
c. others issues as for (A).

C. compo-rapide.pub:
a. minor text alignment / kerning.

D. Composition1.pub:
a. most examples of WordArt from MS Publisher 2003 do not render correctly.

In summary, (Bb) and (Da) would seem to be the main problems reported here that are not reported elsewhere.
Comment 13 Owen Genat (retired) 2013-12-07 11:52:29 UTC
Confirmed as per comment #12. Status set to NEW. Platform set to All/All. Since some of the issues reported here are the same as those in bug 61579 and bug 68589, I have added both bugs to the Depends on field.
Comment 14 David Tardon 2014-12-30 08:54:36 UTC
Could you please create a separate bug for each problem? Cumulative bugs like this do not really encourage anyone to work on them.