Download it now!
Bug 68281 - EDITING: Dragging cells causes input lockup on Linux Mint KDE x64
Summary: EDITING: Dragging cells causes input lockup on Linux Mint KDE x64
Status: RESOLVED DUPLICATE of bug 67011
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-19 14:11 UTC by Ryan K
Modified: 2013-09-10 17:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan K 2013-08-19 14:11:58 UTC
Problem description: Attempting to move a range of cells by dragging causes all mouse input to become unresponsive (within LiBo and the rest of the system).

Steps to reproduce:
1. Open calc to a blank spreadsheet
2. Highlight two or more cells (populated or blank)
3. Drag the cells down a few rows
4. Observe that keyboard and mouse input becomes unresponsive

NOTE: it is possible to escape this bug by switching to a virtual console and then back to X by pressing CTRL+ALT+F1,2,3, etc. Sometimes one such switch is sufficient to unfreeze the input; other times it takes two switches.

Current behavior: dragging cells freezes input and requires virtual terminal switch to correct

Expected behavior: dragging cells does not freeze input

SYSTEM: Linux Mint 15 KDE x64 (Ubuntu 13.04 base, KDE Plasma 4.10, Libreoffice 4.1.0.4)
              
Operating System: Linux (Other)
Version: 4.1.0.4 release
Comment 1 CrayzeeWulf 2013-08-19 18:09:21 UTC
The same bug is also present in LibreOffice Calc Version 4.1.0.4 on Fedora 19 (Build ID: 4.1.0.4-6.fc19).
Comment 2 kaesezeh 2013-08-28 17:07:35 UTC
Replicated here on the same kind of system: Linux Mint 15 KDE x64 (Ubuntu 13.04 base, KDE Plasma 4.10, Libreoffice 4.1.0.4). My hunch is this is related to <https://bugs.freedesktop.org/show_bug.cgi?id=67011>
Comment 3 Ryan K 2013-09-03 17:48:37 UTC
Update: the same lockup behavior occurs when trying to drag and drop a worksheet to change the order.
Comment 4 Maxim Monastirsky 2013-09-10 17:48:52 UTC

*** This bug has been marked as a duplicate of bug 67011 ***