Bug Hunting Session
Bug 68406 - [Autofilter] "All" checkbox shows also empty cells, which can lead to various misunderstandings
Summary: [Autofilter] "All" checkbox shows also empty cells, which can lead to various...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-21 22:18 UTC by Mirosław Zalewski
Modified: 2015-09-21 00:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example sheet with autofilter and empty cells in row (9.63 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-08-21 22:18 UTC, Mirosław Zalewski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mirosław Zalewski 2013-08-21 22:18:59 UTC
Created attachment 84416 [details]
Example sheet with autofilter and empty cells in row

(Derived from Bug 57431)

Checking "All" checkbox will show also empty cells. This makes it's behavior inconsistent and can lead to various misunderstandings of Autofilter nature.

Steps to reproduce:
1. Open attached spreadsheet
2. Open Autofilter popup on column B, select "little brother of 1" and "big brother of 3". Click OK.
3. Open Autofilter popup on column B again, select "pseudonym of 5".

Actual result:
All rows are shows - also these containing empty cells.

Expected result:
Show only rows containing three selected values. Hide rows with empty cells in column B.

Expected result is derived from assumption that "All" checkbox really means "check all boxes above", not "show entire column".

Probably there should be one more button in popup that actually does show entire column. It could be labeled "Show all rows" or "Remove filter rule" to avoid confusion with "All" checkbox.

This bug is related to 57431 and 45681. Please see <https://bugs.freedesktop.org/show_bug.cgi?id=57431#c8> for my understanding of relations between them. Feel free to disagree and provide arguments for other meaning of Autofilter and "All" checkbox.

Reproduced on LO 4.0.4 on Debian testing, amd64.
Comment 1 Michel Rudelle 2013-08-22 08:26:56 UTC
Reproduced under Vista-32b:
Version 4.0.5.2 (Build ID: 5464147a081647a250913f19c0715bca595af2f)
Version: 4.1.0.4 Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28

(In reply to comment #0)
> Probably there should be one more button in popup that actually does show
> entire column. It could be labeled "Show all rows" or "Remove filter rule"
> to avoid confusion with "All" checkbox.
I agree, the use of two buttons could be a very good solution, easy to understand for users.
Comment 2 Rob 2014-10-20 12:42:46 UTC
I tested this on Mac OS X Lion 10.7.5 (11G63)
using: LO Version: 4.3.1.2
Build ID: 958349dc3b25111dbca392fbc281a05559ef6848

The reported problem regarding the inconsistency in the menu tickboxes is resolved. The 'Empty tickbox' is available now, and it works as expected.

All means indeed ALL, in that all tickboxes are marked, including the 'Empty' tickbox. This effectively means that All is cancelling any selection.

In my environment this seems to be resolved.
Comment 3 Rob 2014-10-20 13:20:04 UTC
(In reply to Rob from comment #2)
> I tested this on Mac OS X Lion 10.7.5 (11G63)
> using: LO Version: 4.3.1.2
> Build ID: 958349dc3b25111dbca392fbc281a05559ef6848
> 
> The reported problem regarding the inconsistency in the menu tickboxes is
> resolved. The 'Empty tickbox' is available now, and it works as expected.
> 
> All means indeed ALL, in that all tickboxes are marked, including the
> 'Empty' tickbox. This effectively means that All is cancelling any selection.
> 
> In my environment this seems to be resolved.

Sorry, it apears I have fields just containing one space. That showed in the list of tickboxes. After deleting the space, the tickbox disapeared also, and my initial euphoria quickly vanished....
Comment 4 Rob 2014-10-20 13:39:51 UTC
I don't agree.
As far as I see it, the All tickbox should effectively cancel any selection (All is really ALL). It should also auto mark all individual tickboxes.

What should happen is that an extra tickbox for 'empty' should be added.
Also, the 'Empty' and 'Not Empty' menu entries could be deleted, or should auto update the tickboxes.

If the "empty" tickbox is added the tickboxes can reflect the actual situation.

In LO "aaa" and "aaa  " are distinct values with respect to the autoselect functionality. Simularely " " and "  " are different.
In Excel "aaa" and "aaa  " result in 1 tickbox, same for "", " " and "    ".

So, in Excel the values are trimmed. In fact the values are both left and right trimmed, resulting in any surrounding spaces to be ignored ("aaa" is then the same as "  aaa").

See also bug 81577
Comment 5 alister.hood 2014-11-10 22:08:47 UTC
> Probably there should be one more button in popup that actually does show entire column. It could be labeled "Show all rows" or "Remove filter rule" to avoid confusion with "All" checkbox.

No, this is not a good way to solve the problem, because it wouldn't address all the related issues.

> What should happen is that an extra tickbox for 'empty' should be added.
Also, the 'Empty' and 'Not Empty' menu entries could be deleted, or should auto update the tickboxes.

Yes, this is how it should be solved.
Comment 6 alister.hood 2014-11-10 22:10:28 UTC
Sorry, the line starting "Also" should be a quote too.
Comment 7 Kevin Suo 2015-09-21 00:46:40 UTC
This issue does not exist any more in my testing with:
Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: zh-CN (zh_CN)
Win 10 x86

A new checkbox "(Empty)" was added in the new version, so when you check both "big brother of 3", "little brother of 1", and "pseudonym of 5" but do not check "(Empty)", the empty values will not show up.

Mark as RESOLVED WORKSFORME as we are not sure which commit fixed this (Maybe the fix to Bug 65505?)