Bug Hunting Session
Bug 68459 - EDITING: frames are jumping and impossible to position correctly with arrow keys
Summary: EDITING: frames are jumping and impossible to position correctly with arrow keys
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Writer-View-Jumps
  Show dependency treegraph
 
Reported: 2013-08-23 01:34 UTC by mango wodzak
Modified: 2019-09-18 20:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
one .odt file with sample text and instructions to see the bug. (28.99 KB, application/vnd.oasis.opendocument.text)
2013-08-23 01:34 UTC, mango wodzak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mango wodzak 2013-08-23 01:34:03 UTC
Created attachment 84483 [details]
one .odt file with sample text and instructions to see the bug.

Problem description: Using frames in a large document together with footnotes, and they cannot be always positioned where one wants.

Steps to reproduce:
1. create small frames with notes at right side of page.
2. document has footnotes with references at bottom of each page
3. click on side of frame, so it is selected. 
4. Use up arrow key and down arrow keys

Current behavior:

As you click up arrow, the frame moves up steadily until the first paragraph on page, when it suddenly jumps to the previous page and lans in the "footer" area of that page. Try to press down arrow again, and it doesn't budge at all. If the frame is too small, and the frame totally below the footnote line, and the cursor focused onto the main text area, one can no longer move the frame at all. (I have to "control+enter" after the previous paragraph, in order to force it back to the follow on page).

Expected behavior:

I expect the up arrow to move the frame up to any place on the page until I reach the top, and then for it to jump to the previous page. I also expect the down arrow to move it back to the page it came from.

     Ther is another connected bug, when a frame is deleted from within the footnote area, I am automatically taken back to the very first page of the document.
Operating System: Windows 7
Version: 4.1.0.4 release
Comment 1 Jean-Baptiste Faure 2013-09-22 08:12:43 UTC
To move a frame from a page to another, it is less expensive to use the mouse or the cut-and-paste instead of hitting several times on the arrow keys.

That said, after several experiences, I think that the ability to move a frame using up and down arrow keys seems to have not been designed to work outside the current page.

I tend to close this bug report as NotABug. Any advice?

Best regards. JBF
Comment 2 mango wodzak 2013-09-22 19:16:51 UTC
I'm really not sure what you mean by "less expensive". If I use the cut and paste, the frame does not get placed exactly where I tell it to get pasted. It's quite difficult, for example to place a frame directly between 2 paragraphs "without" using the arrow keys.

In any case, the behaviour is erratic, and if the arrow key moves it up to the previous page (which it does!), surely it would just make logical sense that it would move it back down again, (which it doesn't). Also the fact that the frame can get stuck in the footer area is quite annoying and surely merits being listed as a bug rather than an extremely badly thought through feature.

Also, there is currently no way to place a frame within a paragraph that started on the previous page.

Try featuring such frames in your own writing, I think you will soon realise that the degree of control is minimal and that this needs addressing.
Comment 3 QA Administrators 2014-05-17 00:34:09 UTC
Dear Bug Submitter,

Please read the entire message before proceeding.

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 4 Jean-Baptiste Faure 2014-05-19 19:24:24 UTC
Added whiteboard NeedAdvice because of my comment #1 and set the status back to unconfirmed.

Best regards. JBF
Comment 5 tommy27 2014-10-06 08:49:01 UTC
I confirm "arrow keys" issue on Win7x64 using LibO 4.3.2.2

I set status to NEW and let's see what other people from the QA team thinks about this: a BUG or NOTABUG ?
Comment 6 mango wodzak 2014-10-06 20:41:27 UTC
Thanks for reopening this Tommy..

This "bug" is still present and demonstrable in the latest version of LO, via the attachment I uploaded here earlier.. It is quite frustrating if one uses frames a lot (which I do)..
Comment 7 tommy27 2014-10-06 21:23:58 UTC
@mango
do not change version field to latest version you see the bug. it should indicate firts version the issue apperared. after more tests I can tell this bug is inherited from OOo (affects OOo 3.3.0, LibO 3.3.3 and AOO 4.1.0)
Comment 8 mango wodzak 2014-10-06 21:33:17 UTC
(In reply to tommy27 from comment #7)
> @mango
> do not change version field to latest version you see the bug. it should
> indicate firts version the issue apperared. after more tests I can tell this
> bug is inherited from OOo (affects OOo 3.3.0, LibO 3.3.3 and AOO 4.1.0)

ok.. sorry about that..
Comment 9 QA Administrators 2015-10-14 19:57:23 UTC Comment hidden (obsolete)
Comment 10 mango wodzak 2015-10-15 01:21:03 UTC
This bug definitely continues with version 5.0.1.2, as far as I can see there has been no change, and it's still as irritating as ever. It works exactly the same way in the lastest Open Office version too. I'm using windows 10.
cheers,
mango.
Comment 11 Robinson Tryon (qubit) 2015-12-10 10:15:45 UTC Comment hidden (obsolete)
Comment 12 mango wodzak 2016-01-20 01:58:49 UTC
Does anyone know if this bug will be fixed in the up-and-coming version 5.1?
Comment 13 mango wodzak 2016-02-10 19:38:41 UTC
very disappointed to see that this bug is still not fixed in version 5.1…
Comment 14 Xisco Faulí 2016-09-19 15:29:40 UTC Comment hidden (obsolete)
Comment 15 mango wodzak 2016-10-10 19:42:11 UTC
Is there any chance that this bug will be fixed in the up-and-coming version 5.3? It's been over three years since I reported this bug, which has been present since the very beginning of LibreOffice.. it really would be great to know that this bug is not being completely ignored, as it is still something which I find restricts my usage of this otherwise fantastic office suite.
Comment 16 mango wodzak 2017-02-01 19:57:37 UTC
I'm very sad to see that this bug is still not fixed in version 5.3… Surely it is more important to fix bugs in a program before adding new features? This issue has been around since the dawn of libreoffice/openoffice and is still present, and still very annoying. It has been well over three years since I first reported it too.. It would be much appreciated if some kind soul could at least acknowledge that this bug is being worked on, or low prioritized on a long list of bugs that need fixing?
Comment 17 Thomas Lendo 2017-03-05 23:57:44 UTC
I confirm the impossibility to move the frame in the described manner with arrow keys.

I also discovered that you can't move the frame with the mouse to a position within the paragraph that started at the page before. It's only possible to anchor it to the next paragraph. Maybe that behavior for arrow keys and mouse has the same cause.

Version: 5.3.0.3
Build ID: 1:5.3.0~rc3-0ubuntu1~trusty1.1
CPU Threads: 2; OS Version: Linux 3.13; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: de-AT (de_DE.UTF-8); Calc: group

Jumping when deleting a frame is also covered by Bug 101932. That bug is newer as this one but to respect the "one report per bug" rule I would suggest to handle the jumping issue there.

mango: I think it's unlikely that this bug will be fixed in the near future unless you will personally find a developer who is willing to work on it. There are a thousand times more issues than developers and the priority is not high - see https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Priority#Priority_Levels
Comment 18 QA Administrators 2018-05-21 02:35:44 UTC Comment hidden (obsolete)
Comment 19 mango wodzak 2018-06-02 02:29:32 UTC
This issue is still present within libreoffice writer..

Version: 6.0.4.2 (x64)
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: en-AU (en_AU); Calc: group

I believe I've already marked someplace that the issue has been around since the beginning of libreoffice, and is still present with openoffce too..
Comment 20 QA Administrators 2019-06-03 02:49:26 UTC Comment hidden (obsolete)
Comment 21 mango wodzak 2019-06-03 05:47:52 UTC
Yes.. bug is still annoyingly present in 6.2.4.2 ..
Comment 22 mango wodzak 2019-09-18 20:01:22 UTC
Bug is still present in v6.3 .. only now one can no longer double click on a frame edge to open the properties dialogue, and aligning a frame using the align buttons causes separation of text from the frame.. Frames seem to work differently in 6.3, someone is tweaking things there, but doesn't look like they've improved things at all..