Bug Hunting Session
Bug 68487 - ooofilt_x64.dll causes permanent high CPU load via SearchFilterHost.exe
Summary: ooofilt_x64.dll causes permanent high CPU load via SearchFilterHost.exe
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: (target:4.1.4)
Keywords:
: 68490 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-23 21:14 UTC by Volko Neitmann
Modified: 2014-01-28 21:41 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volko Neitmann 2013-08-23 21:14:15 UTC

    
Comment 1 Volko Neitmann 2013-08-23 21:25:50 UTC
Hi,

after installing LibreOffice v4.1.0 or v4.0.5 on two different Windows 7 (x64) machines on both systems ooofilt_x64.dll causes permanent high CPU load via SearchFilterHost.exe and the indexing service does not finish indexing.
Unselecting all OpenDocument file types in indexing service preferences fixes the problem.
As the bug is not resent in all versions before 4.0.5 reverting back to LibreOffice v4.0.4 also solves the problem.

Regards,
Volko
Comment 2 Marek Zdunek 2013-08-26 15:50:45 UTC
I can confirm this error
SearchFilterHost.exe running on three cores about 50% CPU usage all time
In C:\Program Files (x86)\LibreOffice 4\program\shlxthdl I changed files ooofilt.dll and ooofilt_x64.dll to those from version 3.6.4.3 then problem disappeared
Comment 3 Maxim Monastirsky 2013-08-26 18:02:49 UTC
*** Bug 68490 has been marked as a duplicate of this bug. ***
Comment 4 Maxim Monastirsky 2013-08-26 18:08:17 UTC
Confirmed by comment 2 & Bug 68490.
Also Bug 55854 might be related, although it's reported against 3.6.2.2.
Comment 5 Maxim Monastirsky 2013-08-26 18:12:23 UTC
According to Bug 56035 there are some changes related to indexing in 4.1.1. Would be great if someone could test it, and report here. thanks.
Comment 6 John Schuetz 2013-08-28 15:44:07 UTC
I installed the 4.1.1.2 (release candidate) to see if this was fixed.  Unfortunately, Microsoft Windows Search Filter runs long and at high cpu.  I had uninstalled LibreOffice, rebuilt the search index, and it took less than an hour.  I then installed LibreOffice 4.1.1.2, and while indexing was finding OpenDocument files, it was taking upwards of 10 hours, and indexing was still running.  I then uninstalled the Windows Explorer extensions from LibreOffice and rebuilt the index--this took a little over a half-hour for 8955 files.

Unfortunately, Windows Search indexing makes no information about what specific files it's working on apparent, so I can't really tell what's going on.  If you'd like help in debug, I'd be happy to help.
Comment 7 Ludo 2013-08-29 13:38:52 UTC
Hi.

I had the same problem while creating a text document (LibreOffice 4.1.0.4 + Win7 x64) on drive C:, in the folder "My Documents". The document included a 32-bit PNG image (509kb) stored on drive E: which is not indexed by Windows Search Filter Host. It took about 1 minute to save the ODT file. Then I changed the picture in the ODT to the same in 8 bits (same folder on E:, not indexed). The saving was instantaneous, even if the ODT was stored in a place checked by Windows Search Filter Host (e.g. "My Documents").

I also tried to save the document with the 32 bits PNG image in a folder which is _not_ indexed by Windows and it saved it instantly !

Might it be due to the .~lock file ? Does WSFH tries to open the file in read+write mode while the .~lock file is present, causing a latency ?
I preferred to stop Windows' file indexation for the moment. Good luck for solving this case.
Comment 8 maspelic 2013-09-01 09:34:54 UTC
Bug confirmed with 4.1.1.2 version on two Win8 machines. Full core CPU usage starts when windows search host tries to index open document file.
Comment 9 Grisemine 2013-09-06 05:31:59 UTC
Same here, constant 40% CPU load, had to remove explorer extensions.
Comment 10 Frank 2013-09-08 03:57:16 UTC
Can confirm this for 4.1.0 and 4.1.1 (and 4.0.5) also on 32-bit Windows 7. Using Process Explorer I saw SearchFilterHost.exe using high CPU (>= 1 core of my X4) when searching certain odt or odp files. In addition, Windows Search tries to index these files several times and obviously always fails. All these files have pictures embedded - that's the only thing I could find they have in common.
Comment 11 Frank 2013-10-01 10:19:23 UTC
Problematic behaviour is still there in version 4.1.2.2. The only way to circumvent the bug (other than disabling the indexer) is replacing the files in <installdir>\program\shlxthdl with the versions from AOO 4.0.0 (or some version of LO prior to 3.6) - or installing MS Filterpack 2.0 and let their filters index OpenDocument files.

Note: it seems that my odt and odp files causing high cpu with ooofilt from LO 4.1.x are silently skipped by AOOO 4.0.0 ooofilt (without throwing an error in Windows' eventlog), only MS' filters index them correctly.
Comment 12 josiasmat 2013-11-30 00:32:54 UTC
I can confirm this bug for LibreOffice 4.1.3.2, on 64-bits Windows 8.1. It loads one of the CPU cores 100%, thus reducing battery life of my notebook. I think importance should be changed to high.
Comment 13 Maxim Monastirsky 2013-12-01 12:12:20 UTC
I think it's a duplicate of Bug 56035
Please test with 4.1.4 RC1 (or 4.2.0 beta1):
http://www.libreoffice.org/download/pre-releases/
Comment 14 Maxim Monastirsky 2013-12-01 12:34:53 UTC
(In reply to comment #13)
>(or 4.2.0 beta1)
Note that for 4.2.0 beta1, you should install from the command line with:
msiexec /i <downloaded file>.msi WRITE_REGISTRY=1
Otherwise the test is irrelevant. (Beware: It will overwrite file associations of currently installed version.)
Comment 15 aa-lobz 2014-01-27 14:23:17 UTC
This bug is fixed for me (Windows 7 Professional 64-bit) with LibreOffice version 4.1.4.2.
Comment 16 Frank 2014-01-28 11:25:53 UTC
Had this problem on 32-bit Windows 7, and for me, too, this seems to be solved in 4.1.4.2 (didn't try 4.2 yet).
Thanks!
Comment 17 Volko Neitmann 2014-01-28 21:25:39 UTC
Confirm that this bug is fixed for me (Windows 7 Professional 64-bit) with LibreOffice version 4.1.4.2 as well.
Thanks for fixing the bug.
Comment 18 John Schuetz 2014-01-28 21:41:08 UTC
I also find that this is now working in LibreOffice 4.1.4.2 running on Windows 8.1.  Thank you for fixing this!