Download it now!
Bug 68539 - Sorting of Columns in Tablegrid not possible by drag&drop
Summary: Sorting of Columns in Tablegrid not possible by drag&drop
Status: RESOLVED DUPLICATE of bug 54021
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-25 17:34 UTC by Ulf
Modified: 2013-11-21 20:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LibO3.4.3 (8.06 KB, image/jpeg)
2013-08-25 17:34 UTC, Ulf
Details
New version (23.54 KB, image/jpeg)
2013-08-25 17:35 UTC, Ulf
Details
ExampleDB (11.27 KB, application/vnd.sun.xml.base)
2013-08-25 17:35 UTC, Ulf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulf 2013-08-25 17:34:28 UTC
Created attachment 84608 [details]
LibO3.4.3

You can change the order of columns in a tablegrid by leftklick on the header and go to the coloum where you want to have the column. You can see an arrow let the Mousebutton free.
See picture „...before“ was taken with LibO 3.4.3 on WinXP

This is not possible anymore. Now you get a copy of the column. See picture „...after“, was taken with LibO 4.1.1 on WinXP

Open Database
open form Master to edit
Try to get Coloum 3 to get the first column
Comment 1 Ulf 2013-08-25 17:35:09 UTC
Created attachment 84609 [details]
New version
Comment 2 Ulf 2013-08-25 17:35:55 UTC
Created attachment 84610 [details]
ExampleDB
Comment 3 Robert Großkopf 2013-08-27 20:03:04 UTC
I thought this bug had been reported - but didn't find it anywhere.
I have tested the following versions under rpm-Linux-64bit when opening a form for editing, not for input of data: 
LO 3.3.4 - Columns could be moved in both ways
LO 3.5.7.2 - Columns could only move to the left, not to the right. The header of the columns is only refreshed with a klick on the header.
LO 3.6.7.2 - Columns couldn't be moved any more. Shows as if they were copied, but they aren't.
I have to see which is the first version, which shows a defect there.
Comment 4 Robert Großkopf 2013-08-27 20:07:15 UTC
I have found the bug I have reported earlier. Will see, if I can change the title, so it could be found better.

*** This bug has been marked as a duplicate of bug 54021 ***