Bug 68586 - Second Writer window is missing its decorations
Summary: Second Writer window is missing its decorations
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-08-26 21:37 UTC by Todd
Modified: 2014-12-13 08:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Decoration bar tucked under Xfce Panel 1 (task bar) (40.50 KB, image/png)
2013-10-02 21:11 UTC, Todd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2013-08-26 21:37:24 UTC
Hi All,

LibreOffice_4.1.0_Linux_x86-64_rpm.tar.gz

Since upgrading to 4.1.0, when I open two Writers documents, the second document I open is missing its window decorations.  (Workaround: use "File", "Close".)

Very curious.  When I open a third document, its window decorations show.  It is just the second one that is a pill.

-T
Comment 1 tommy27 2013-08-28 12:31:34 UTC
when you say decorations do you mean icons?
could you please attach a screenshot here of such window?

for the record: I do not see the described issue on 4.1.0.4 under Win7 64bit
Comment 2 Todd 2013-08-28 17:06:26 UTC
(In reply to comment #1)
> when you say decorations do you mean icons?

Decorations are what appears on the very top of the window.  Typically, on the far right, you have an underscore, boxes, and an "x".

> could you please attach a screenshot here of such window?

Yes, but today, I can not reproduce it.

> 
> for the record: I do not see the described issue on 4.1.0.4 under Win7 64bit

Go ahead and close.  If it comes back, I will screen shot it.  (Must have been a bad boot -- very unusual with Linux.)
Comment 3 tommy27 2013-08-28 17:59:21 UTC
Ok. I set status to NEEDINFO. 
If in a week it doesn't come back, change status to RESOLVED WORKSFORME
Comment 4 Todd 2013-09-21 02:28:07 UTC
It has been driving me nuts the last two days.  The second windows has no decorations, but the first and the third do.
Comment 5 Todd 2013-09-27 23:33:29 UTC
Scientific Linux 6.4, 64 bit
Xfce 4.8.1-4.el6.x86_64, Appearance Style: BlueCurves-BerriesAndCream (the default)

This is driving me cray again today.  The second window has no decorations.  And since it has no top, it can not be moved, minimized, or sized.  AHHHH!

I came up with a work around:

1) open the first document that you want to view.

2) open a random second document that you do not want to view.  This will have no decorations.

3) open a third document that you want to view.  This will have its decorations back.

4) go to the second document, File --> Close.  Now you will have two documents with decorations.  

Please fix this!

Many thanks,
-T
Comment 6 Todd 2013-09-27 23:40:30 UTC
Figured it out.  

The top bar is actually there.  It is just tucked under the Panel 1 (Task Bar) at
the top of the screen.  To fix it, 

--> Task Bar (panel 1)
  --> click once on the document without the decorations
    --> right click on the name of the document
       --> left click on "Move"
         --> move the document down enough such that the top is no longer
             tucked under the task bar.  Close the document and reopen it.  Its
             new setting will be remembered

So, the bug here is that the window should never be allowed to scoot itself under the task bar when opened.  (The user can do it later, but, when he reopens the document, it should be repositioned such the top of the window shows.
Comment 7 Todd 2013-10-02 21:11:53 UTC
Created attachment 87005 [details]
Decoration bar tucked under Xfce Panel 1 (task bar)

It is at it again.  This time on version 4.1.1.2 and Xfce 4.8.0-1
Comment 8 Todd 2013-10-04 20:36:40 UTC
Now running 4.1.2.3.  Problem is not persisting.  Did you guys fix this in 4.1.2.3?
Comment 9 tommy27 2013-10-05 06:34:27 UTC
@Todd
maybe it's a side effect of another fix.
since you don't see the bug anymore I mark this as RESOLVED WORKFORME.
feel free to reopen if it comes back.
Comment 10 Todd 2013-10-08 04:35:57 UTC
It is at it again
Comment 11 tommy27 2013-10-10 12:38:23 UTC
do you mean that you see it again in 4.1.2.3 as well?
Comment 12 Todd 2013-10-10 17:38:02 UTC
(In reply to comment #11)
> do you mean that you see it again in 4.1.2.3 as well?

Yes.  If you look at the attachment I added to comment 7, you can see where the top of the window tucks itself under the task bar (panel one in Xfce jargon).  As it doesn't happen all the time, I think it depends on else I have open.  But, when it happens, it is always the second and fourth LO windows I try to open.
Comment 13 Joel Madero 2014-11-06 17:58:15 UTC
This needs to be independently confirmed by QA - moving to UNCONFIRMED. Thanks
Comment 14 tommy27 2014-12-13 08:10:51 UTC
@Todd
please give an update of the bug status with a recent LibO versio.
the 4.3.4.1 release is available right now.

revert status to UNCONFIRMED if the bug is still present or RESOLVED WORKSFORME if it's gone
Comment 15 Todd 2014-12-13 08:50:34 UTC
Hi Tommy,

I have since had this happen with other programs as well.  This is an Xfce 4.8 issue and since I am using Enterprise Linux 6.6, I am stuck with all the bugs in Xfce 4.8 and can not upgrade to the latest version.

Thank you for your graciousness with this not-our-bug.

Many thanks,
-T