Download it now!
Bug 68678 - EDITING: Query-editor doesn't change values in listfields (Field, Table, Sort, Function) when the changed field is selected while saving the query.
Summary: EDITING: Query-editor doesn't change values in listfields (Field, Table, Sort...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
: 82110 82322 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-28 18:04 UTC by Terrence Enger
Modified: 2015-12-15 11:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
example embedded HSQLDB (3.10 KB, application/vnd.sun.xml.base)
2013-08-28 18:04 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2013-08-28 18:04:16 UTC
Created attachment 84806 [details]
example embedded HSQLDB

To reproduce ...

(1) Download and open attached file a.odb.  Program displays window
    a.odb; the Database pane has Forms selected.

(2) In the Database pane, click Tables.  The program displays Tables
    pane in the lower right, showing table Table1 and view View1.

(3) Right-click View1 and from the pop-up menu select Edit.  Program
    displays window "a.odb : View1"; the view has just Field en from
    Table Table1, Sort is ascending, and Visible is checked.

(4) Click in the grid position for field en, atrribute Soft.  Program
    displays a dropdown listbox with ascending selected.

(5) In the listbox, click descending.  Program shows descending in the
    listbox, and the Save icon in the toolbar is enabled.

(6) Click the Save icon in the toolbar.

    Program action expected: The listbox continues to show descending.

    Program action actual: The listbox shows ascending.  

(7) Close window "a.odb - View1".  Program returns focus to window
    a.odb.

(8) Double-click View1.

    Program action expected:  data rows two, three, one, four, five.

    Program action actual :   data rows five, four, one, three, two.


Note for comparison, that ...

(*) a change through "Edit in SQL View..." is remembered.

(*) Something unknown (sigh!) which I once did makes the GUI editor
    remember a changed sort criterion.  I know I am not dreaming this
    because that is how I got Sort ascending into the view in the
    first place.

(*) LibreOffice 3.3.4, as distributed with ubuntu-natty (11.04)
    remembers and uses the sort criterion.

(*) bibisect 40 oldest (65fd30f... source-hash-d6cde02...), upon entry to the GUI view editor does not show the sort criterion at all, and the drop-down list when you open it starts out showing "(not sorted)".  Nevertheless, the Table Data View honours the sort criterion.

My LibreOffice is commit 731b2af, pulled around 2013-08-19 14:40 UTC,
configured with

    --enable-option-checking=fatal
    --enable-dbgutil
    --enable-crashdump
    --without-system-postgresql
    --without-myspell-dicts
    --with-extra-buildid
    --without-doxygen
    --with-external-tar=/home/terry/lo_hacking/git/src

built and executing on ubuntu-natty (11.04) 32-bit

    $ uname -a
    Linux cougar-natty 2.6.38-16-generic #67-Ubuntu SMP Thu Sep 6 18:00:43 UTC 2012 i686 athlon i386 GNU/Linux

    $ gcc --version
    gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
    Copyright (C) 2010 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

    $ java -version
    java version "1.6.0_24"
    OpenJDK Runtime Environment (IcedTea6 1.11.5) (6b24-1.11.5-0ubuntu1~11.04.1)
    OpenJDK Client VM (build 20.0-b12, mixed mode, sharing)


bibisect tells me ...

    577edb57067b1c21b4503559b957869956f961ff is the first bad commit
    ...
        source-hash-f1a96446fab8f65e77a1cb0996e43c6523fe2873
        ...

and `git bisect log` says ...

    # bad: [4118d739dbd71e16057ea926ef3ef696025d3b67] source-hash-5bd6a5110bb812f82a81e73422a7b14851f84441
    # good: [3e7462bd65e692bf0592d5b080b7716341b62a47] source-hash-1eddfce9894fd05315173744f495619189093dc7
    git bisect start 'latest' 'oldest'
    # bad: [086c82fbd0a50dbf5dd28e8bcc7a6d702cea124e] source-hash-c74f2edfce221960fe546e88f2b3222d69d53598
    git bisect bad 086c82fbd0a50dbf5dd28e8bcc7a6d702cea124e
    # good: [3367a5f4f0d1768c35ed32ac1956abf5c3ab4e0d] source-hash-cc9cd7af3beb13eede23c6c60506c6e8c329e29d
    git bisect good 3367a5f4f0d1768c35ed32ac1956abf5c3ab4e0d
    # bad: [8609688fe6682504b3e6bc675e209db988d3acc1] source-hash-de69091d34d8102c0b56194d603ed9e66699d34c
    git bisect bad 8609688fe6682504b3e6bc675e209db988d3acc1
    # bad: [a0da7886ec5c1ecfc0b5a1e9a85a18459a764761] source-hash-a82f7b20539e60f1cf599afcceaf865bef297a66
    git bisect bad a0da7886ec5c1ecfc0b5a1e9a85a18459a764761
    # good: [872ce1bed9806a36f0bec7eb1a1d09ceff38bdd6] source-hash-3d46b39491af97ba360fb92182501e6b399f4f56
    git bisect good 872ce1bed9806a36f0bec7eb1a1d09ceff38bdd6
    # good: [dcfdde186fb88e112150b6c8612a3e755b9235d0] source-hash-cb8fcf5a169f030827b1150c50b6ed284717e485
    git bisect good dcfdde186fb88e112150b6c8612a3e755b9235d0
    # bad: [577edb57067b1c21b4503559b957869956f961ff] source-hash-f1a96446fab8f65e77a1cb0996e43c6523fe2873
    git bisect bad 577edb57067b1c21b4503559b957869956f961ff
    # good: [4720c3e9a7274e0b107b6ae347cebd1a79cef7aa] source-hash-568b3bdb9b20bd2de68dc2760b69594a9b52ba43
    git bisect good 4720c3e9a7274e0b107b6ae347cebd1a79cef7aa
Comment 1 Terrence Enger 2013-09-12 19:46:24 UTC
I have also seen the same behaviour with the group-by function.
Comment 2 Robert Großkopf 2013-10-24 17:35:56 UTC
It seems to be a problem of all listfields in the query-editor. When you want so save something, which has been changed, you have to click anywhere in the query-editor. You must deselect the listfield. 
Try to change the field - doesn't work.
Try to change the table - doesn't work.
Same problem with "sort" and "function".

I have tested this with other LO-versions. Works in LO 4.0.*, first appears in LO 4.1.0.0 beta1
Comment 3 Doug 2014-08-13 01:24:36 UTC
*** Bug 82322 has been marked as a duplicate of this bug. ***
Comment 4 Robert Großkopf 2014-08-14 05:18:00 UTC
*** Bug 82110 has been marked as a duplicate of this bug. ***
Comment 5 Alex Thurgood 2015-01-03 17:38:33 UTC
Adding self to CC if not already on
Comment 6 Terrence Enger 2015-08-08 19:59:05 UTC
The problem is gone in daily dbgutil bibisect repository version
2015-08=08 ...

    Version: 5.1.0.0.alpha1+
    Build ID: d026cad64c72eacf7bff9bbd7e3bb5b1a56f8479
    Locale: en-CA (en_CA.UTF-8)

I am setting bug status RESOLVED WORKSFORME.
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:03:28 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]