Download it now!
Bug 68764 - table borders appear different when printed
Summary: table borders appear different when printed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.4.6 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2013-08-30 17:15 UTC by Link500X
Modified: 2019-01-05 11:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
file used in example pictures (8.02 KB, application/vnd.oasis.opendocument.text)
2013-09-01 07:06 UTC, Link500X
Details
How it appears in Writer (4.00 KB, image/gif)
2013-09-01 07:07 UTC, Link500X
Details
How it appears in PDF or printed format (4.79 KB, image/gif)
2013-09-01 07:07 UTC, Link500X
Details
PDF from LO 6.1 (16.58 KB, application/pdf)
2019-01-05 11:38 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Link500X 2013-08-30 17:15:27 UTC
Table boders in Writer appear very different when printed or converted to PDF.  Tested on Windows 7 (x64), Windows 8 (x64), and Gentoo (compiled for x64).

Steps to reproduce:
1) create a table
2) change the border style (tested with dotted and dashed, 0.5pt and 1pt)
3) print or save to pdf

The dashed border looks much better when printed, however the dotted border looks more like a semi-transparent line.  I'm unable to determine if the happens in Calc because most of the borders don't show up when printed in Calc.
Comment 1 Link500X 2013-08-30 17:59:27 UTC
I forgot to mention, all tested systems have AMD processors (FX-8150, A8, and A4) and graphics (HD7970, A8, A4).
Comment 2 tommy27 2013-08-31 19:58:53 UTC
please attach a test file in which you reproduce the bug.
Comment 3 Link500X 2013-09-01 07:06:09 UTC
Created attachment 84991 [details]
file used in example pictures
Comment 4 Link500X 2013-09-01 07:07:06 UTC
Created attachment 84992 [details]
How it appears in Writer
Comment 5 Link500X 2013-09-01 07:07:57 UTC
Created attachment 84993 [details]
How it appears in PDF or printed format
Comment 6 Link500X 2013-09-01 07:10:21 UTC
Note about attached pictures:  zoomed to 150% because dotted lines were invisible in Writer's page preview at 100%
Comment 7 tommy27 2013-09-01 10:06:53 UTC
tested under Win7 Pro 64bit

3.3.3 --> .odt input and .pdf output look the same

3.4.6 / 3.5.7 / 3.6.7 / 4.0.4 / 4.1.1 --> .odt input and .pdf output look different

I confirm your bug also in 4.2.0.0.alpha0+
Build ID: 94730f359023a3e90fd6d5239a12a150f41f4dd2
TinderBox: Win-x86@39, Branch:master, Time: 2013-08-31_03:30:47

I set status to NEW and add Writer expert to CC list.
Comment 8 tommy27 2014-10-25 20:36:02 UTC
still reproducible with LibO 4.3.2.2
Comment 9 QA Administrators 2015-12-20 16:08:17 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2017-01-03 19:46:54 UTC Comment hidden (obsolete)
Comment 11 Roman Kuznetsov 2019-01-05 11:37:51 UTC
PDF from 

Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

looks like as in Writer

Status->WFM
Comment 12 Roman Kuznetsov 2019-01-05 11:38:50 UTC
Created attachment 148060 [details]
PDF from LO 6.1