Bug Hunting Session
Bug 68784 - cell comment pop-up window doesn't disappears completely when mouse moves away
Summary: cell comment pop-up window doesn't disappears completely when mouse moves away
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Calc-Comments
  Show dependency treegraph
 
Reported: 2013-08-31 09:01 UTC by deshayes
Modified: 2019-04-17 14:00 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
attachment-9770-0.html (4.65 KB, text/html)
2013-09-14 10:01 UTC, deshayes
Details
attachment-9770-1.dat (1 bytes, multipart/alternative)
2013-09-14 10:01 UTC, deshayes
Details
test.ods (21.59 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-09-14 10:01 UTC, deshayes
Details
bug screenshot (25.79 KB, image/png)
2013-09-14 11:55 UTC, tommy27
Details
scrennshot (352.62 KB, image/jpeg)
2018-05-19 13:44 UTC, deshayes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deshayes 2013-08-31 09:01:31 UTC
when the mouse pointer passes over a cell containing a comment track of the upper part of the comment is displayed in the table! you must click to remove these residues. very unpleasant
Comment 1 tommy27 2013-09-13 03:10:26 UTC
please provide a test file and a screenshot of what you consider a bug.

P.S. edited summary notes.
Comment 2 deshayes 2013-09-14 10:01:58 UTC
Created attachment 85820 [details]
attachment-9770-0.html

                 Hello,
please find attached a file with which I am having problems posting. 
Your comment my bug is not really accurate: in fact only *_résiduts_* 
comments are displayed *_AFTER_* the mouse is passed over the cells 
containing a comment.
Thank you for your help.
Francois
(I tried to print as pdf spreadsheet with residues comments but when it 
displays the pdf résiduts not appear?)








Le 13/09/2013 05:10, bugzilla-daemon@freedesktop.org a écrit :
> tommy27 <mailto:barta@quipo.it> changed bug 68784 
> <https://bugs.freedesktop.org/show_bug.cgi?id=68784>
> What 	Removed 	Added
> CC 		barta@quipo.it
> Summary 	livre office calc version 4.0.5.2 	comment displayed in the 
> table when mouse pointer passes over
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=68784#c1> 
> on bug 68784 <https://bugs.freedesktop.org/show_bug.cgi?id=68784> from 
> tommy27 <mailto:barta@quipo.it> *
> please provide a test file and a screenshot of what you consider a bug.
>
> P.S. edited summary notes.
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You are on the CC list for the bug.
>   * You reported the bug.
>
Comment 3 deshayes 2013-09-14 10:01:58 UTC
Created attachment 85821 [details]
attachment-9770-1.dat
Comment 4 deshayes 2013-09-14 10:01:58 UTC
Created attachment 85822 [details]
test.ods
Comment 5 tommy27 2013-09-14 10:29:50 UTC
(In reply to comment #2)
>  Hello,
> please find attached a file with which I am having problems posting. 

I tested the file with 4.0.5.2 and 4.1.1.2 under Win7 64 but I do not see issue with it. mouse passes over cells with comments, comments show up then disappear when moving to another cell. this is how the feature is intended to work.

> Your comment my bug is not really accurate: in fact only *_résiduts_* 
> comments are displayed *_AFTER_* the mouse is passed over the cells 
> containing a comment. Thank you for your help.
> Francois

please translate *_résiduts_* in English since I do not understand French
maybe do you mean that the comment pop-up doesn't go away unless you click on it?

> (I tried to print as pdf spreadsheet with residues comments but when it 
> displays the pdf résiduts not appear?)
> 

try posting a screenshot with any screencapture software.
I don understand exactly which problem you are describing.
Comment 6 deshayes 2013-09-14 11:25:49 UTC
                     Hello

résiduts means that after the cursor moves to the cell containing a 
comment yellow thick line remains on the columns
C D and sometimes E. If I left click near these lines, they disappear 
one by one.
francois.







Le 14/09/2013 12:29, bugzilla-daemon@freedesktop.org a écrit :
>
> *Comment # 5 <https://bugs.freedesktop.org/show_bug.cgi?id=68784#c5> 
> on bug 68784 <https://bugs.freedesktop.org/show_bug.cgi?id=68784> from 
> tommy27 <mailto:barta@quipo.it> *
> (In reply tocomment #2  <show_bug.cgi?id=68784#c2>)
> >  Hello,
> > please find attached a file with which I am having problems posting.
>
> I tested the file with 4.0.5.2 and 4.1.1.2 under Win7 64 but I do not see issue
> with it. mouse passes over cells with comments, comments show up then disappear
> when moving to another cell. this is how the feature is intended to work.
>
> > Your comment my bug is not really accurate: in fact only *_résiduts_*
> > comments are displayed *_AFTER_* the mouse is passed over the cells
> > containing a comment. Thank you for your help.
> > Francois
>
> please translate *_résiduts_* in English since I do not understand French
> maybe do you mean that the comment pop-up doesn't go away unless you click on
> it?
>
> > (I tried to print as pdf spreadsheet with residues comments but when it
> > displays the pdf résiduts not appear?)
> >
>
> try posting a screenshot with any screencapture software.
> I don understand exactly which problem you are describing.
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You are on the CC list for the bug.
>   * You reported the bug.
>
Comment 7 tommy27 2013-09-14 11:55:22 UTC
Created attachment 85824 [details]
bug screenshot

Ok, now I understand and I reproduce the bug. 
as you may see in the attached screenshot when comment pop-up disappears, a small part of its upper border still remain visbile.
Comment 8 tommy27 2013-09-14 11:58:47 UTC
set status to NEW and edited summary.
Comment 9 QA Administrators 2015-04-01 14:41:58 UTC Comment hidden (obsolete)
Comment 10 deshayes 2015-04-01 16:05:03 UTC
2015/04/01

   Hello,

   Now :  Version: libre office  4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale : fr_FR

hardware : x86-64 (AMD64)
software : Windows 8.1 professionnel 

And...... Dommange is that this problem is still present

Thank you for your help.
Francois
Comment 11 tommy27 2016-04-16 07:24:45 UTC Comment hidden (obsolete)
Comment 12 deshayes 2016-04-16 09:06:05 UTC
hello,

the bug is still present

current version : 5.0.5.2
hardware : x64 (amd64)   
software : windows 10 professionnel 

Thank you for your help.
Francois
Comment 13 tommy27 2016-04-16 09:13:41 UTC
affects LibO 5.2.0.0.alpha0+ too
Build ID: d6bf3bcd8b51012d55a2ec962800a8549e2b85e1
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-04-15_06:46:09
Locale: it-IT (it_IT)

the bugs happens regardless if OpenGL is on/off
Comment 14 Tom Williams 2016-12-24 21:44:14 UTC
My dad runs LibreOffice 5.2.2.2 on Windows 10 and is experiencing this issue as well.  When he hovers the mouse over a cell with a comment, the comment will appear.  When he moves the mouse outside of the cell, the comment remains displayed.  If he happens to hover over more than one cell with a comment, the comments of all the cells appear and he can't make them disappear (outside of closing the spreadsheet).
Comment 15 Tom Williams 2016-12-24 21:45:26 UTC
I almost forgot. My dad's runing LibreOffice Calc 5.2.2.2 on Windows 10.
Comment 16 tommy27 2016-12-27 08:19:48 UTC
bug still present under Win8.1 x64 using LibO 5.4.0.0.alpha0+
Build ID: 9cfb2f2f03b5ec086487fd483298466db0b09010
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-20_23:58:02
Locale: it-IT (it_IT); Calc: group
Comment 17 tommy27 2016-12-27 08:22:04 UTC
bug not present in LibO 3.6.7.2 hence it's a 4.0.x regression
needs bibisecting
Comment 18 Tom Williams 2017-05-02 16:38:35 UTC
On Saturday, April 29, 2017, I upgraded my dad's Windows 10 system to the 64-bit version of LibreOffice 5.3.2.  The comments didn't linger as I previously reported with the 32-bit version of LibreOffice 5.2.2 that was installed on his system.
Comment 19 tommy27 2017-05-02 16:58:16 UTC
I confirm is still reproducible under Win7 x64 using the 32-bit version of LibO 5.3.2.2
Comment 20 QA Administrators 2018-05-03 02:41:56 UTC Comment hidden (obsolete)
Comment 21 deshayes 2018-05-03 08:24:40 UTC
    Hello,

  Now Version: 5.4.6.2 (x64)
Build ID: 4014ce260a04f1026ba855d3b8d91541c224eab8
Windows 10 1803
 
with this version the bug is still present but less visible.
a very small part of upper border still remain visbile.
thanks you for your help.
Cordially
François
Comment 22 Buovjaga 2018-05-18 19:00:57 UTC
I'm not seeing the problem anymore. Could you test with a master build?
If it still happens, you could attach a new screenshot.

https://dev-builds.libreoffice.org/daily/master/Win-x86_64@42/current/

Version: 6.1.0.0.alpha1+ (x64)
Build ID: 8c07193cec5e09d50b20bc5b107da02a7d8f05a5
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-05-17_23:03:56
Locale: fi-FI (fi_FI); Calc: group
Comment 23 deshayes 2018-05-19 13:43:50 UTC
Hello,
i have installed master build 6.1.
i have captured a screenshot.
a very small part of upper border still remain visbile.
thanks you for your help.
Cordially
François
Comment 24 deshayes 2018-05-19 13:44:25 UTC
Created attachment 142207 [details]
scrennshot

Hello,
i have installed master build 6.1.
i have captured a screenshot.
a very small part of upper border still remain visbile.
thanks you for your help.
Cordially
François
Comment 25 Buovjaga 2018-06-30 15:55:33 UTC
I do reproduce this with latest master on Linux (gtk3).

Note: the comment trace is a multigenerational issue. Already in the oldest commit of Linux 43all repo (3.5.0), the comments leave a very faint horizontal line that you almost do not notice. At some point, the boxes also leave a vertical trace. Then, surprisingly, there was a moment in 4.1.0.0alpha0+ commits where no traces were left at all (this is before the problem in this report appeared).

I bibisected marking "bad" the builds which showed the black horizontal line. The range given was https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=fff4d120866a0be3cd8185f2c67bb9f59b1a6a3f...fd84daf696a368c2c7561b5253b32a63ecdeca4a

I do not notice anything immediately suspicious in the range.
Comment 26 Roman Kuznetsov 2019-04-16 14:59:26 UTC
don't repro in

Version: 6.3.0.0.alpha0+
Build ID: 3083fe569f96bf0289da1e9d0ef7da15ab22e2f6
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-04-16_01:39:55
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

Status WFM
Comment 27 Luke 2019-04-16 17:10:11 UTC
Was last reproduced in master on Linux (gtk3). Cannot confirmed "fixed" with Windows.
Comment 28 Buovjaga 2019-04-16 17:44:05 UTC
I'm not seeing the residues anymore. On the other hand, new interesting issues have come up. I will report them after further testing with newest builds.

1. On Linux, most of the comments display only partly or not at all
2. On both Win & Linux, View - Comments causes a crash

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 9030ffb1a1b282eb2c6d1773930b0de0d42df447
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 13 April 2019
Comment 29 Buovjaga 2019-04-17 09:51:25 UTC
(In reply to Buovjaga from comment #28)
> I'm not seeing the residues anymore. On the other hand, new interesting
> issues have come up. I will report them after further testing with newest
> builds.
> 
> 1. On Linux, most of the comments display only partly or not at all

This is bug 120797

> 2. On both Win & Linux, View - Comments causes a crash

Reported as bug 124778
Comment 30 Tom Williams 2019-04-17 14:00:18 UTC
Comments are behaving correctly for me in Calc 6.1.5.2 on Ubuntu 18.10 and in Calc 6.2.2.2 on Windows 7 (32-bit).