Bug Hunting Session
Bug 68797 - FILEOPEN lost position of lines anchored to cell
Summary: FILEOPEN lost position of lines anchored to cell
Status: RESOLVED DUPLICATE of bug 67712
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 69136 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-08-31 18:54 UTC by g4b0
Modified: 2015-01-22 16:44 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Most simple showcase (8.27 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-28 13:00 UTC, Bernhard Schiffner
Details
Most simple showcase (8.32 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-28 13:00 UTC, Bernhard Schiffner
Details
Most simple showcase (8.32 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-28 13:01 UTC, Bernhard Schiffner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description g4b0 2013-08-31 18:54:59 UTC
Draw a line on a spreadsheet, anchor it to a cell.
Close and reopen.
The line has lost its position, is now located on the bottom left of the document, anchored to the top left cell of the spreadsheet.
Save, close and reopen again, the line has disappeared.

Same issue with freehand lines and poly lines.
Comment 1 m.a.riosv 2013-08-31 21:32:15 UTC
Hi g4b0, thanks for reporting.

Reproducible.
Win7x64Ultima
Version: 4.1.1.0.0+ Build ID: c1f0f890f5065f88164add33707228f8c6d5755
Comment 2 sophie 2013-09-10 06:31:29 UTC
*** Bug 69136 has been marked as a duplicate of this bug. ***
Comment 3 Julien Nguyen 2013-09-14 16:37:49 UTC
Reproductible using LibreOffice 4.1.1.2, ArchLinux x86-64.
Comment 4 Gerco-Kees 2013-10-01 11:19:29 UTC
Same problem as:
https://bugs.freedesktop.org/show_bug.cgi?id=67712

??
Might be a duplicate...
Comment 5 Bernhard Schiffner 2014-01-28 12:57:44 UTC
Yes, its _very_ reproducible with newer|recent versions of libreoffice.

I attach two minimal files showing the problem.
- lines_1.ods : lines anchored to page,
- lines_21.ods: same as line_1.ods, but lines are anchored to cell, stored
- lines_22.ods: reopened lines_21.ods, seeing lines moved, stored as lines_22.ods without any change.

Hints for bug hunters:
I use
xmllint --format content.xml > content_f.xml
to have something  compareable by diff.

lines_21.ods->content_f.xml differs from line_22.ods->content_f.xml (line-no 50)

This means to me that while parsing the input something is not read / forgotten to apply to the internal representation.

Because this bug renders every (even old) document touched useless I think this bug should be considered a very grave one.

Hopefully it will be an easy fix :-) with the help given above.

Thanks!

Bernhard
Comment 6 Bernhard Schiffner 2014-01-28 13:00:05 UTC
Created attachment 92922 [details]
Most simple showcase

1 of 3 files
Comment 7 Bernhard Schiffner 2014-01-28 13:00:52 UTC
Created attachment 92923 [details]
Most simple showcase

file 2 of 3
Comment 8 Bernhard Schiffner 2014-01-28 13:01:31 UTC
Created attachment 92924 [details]
Most simple showcase

file 3 of 3
Comment 9 Gerco-Kees 2014-01-28 13:03:33 UTC

*** This bug has been marked as a duplicate of bug 67712 ***