Bug 68889 - FORMATTING: Font "Gill Sans MT Pro" always bold
Summary: FORMATTING: Font "Gill Sans MT Pro" always bold
Status: RESOLVED DUPLICATE of bug 69254
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Mac OS X (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:6.1.0 target:6.0.2
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-09-03 15:05 UTC by jvtechnik
Modified: 2018-02-23 18:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Version 4.0.5.2 (65.78 KB, image/png)
2013-09-03 15:05 UTC, jvtechnik
Details
Version: 4.1.1.2 (65.58 KB, image/png)
2013-09-03 15:06 UTC, jvtechnik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jvtechnik 2013-09-03 15:05:20 UTC
Created attachment 85119 [details]
Version 4.0.5.2

Problem description: 
In Version: 4.1.1.2 Build ID: 7e4286b58adc75a14f6d83f53a03b6c11fa2903 the font "Gill Sans MT Pro" is always bold. Other fonts seem to work.



Steps to reproduce:
1. I installed Version: 4.1.1.2 -> Gill Sans MT Pro always Bold
2. I installer Version 4.0.5.2 (Build ID: 5464147a081647a250913f19c0715bca595af2f) --> Gill Sans MT Pro works fine


Operating System: Mac OS X
Version: 4.1.1.2 rc
Last worked in: 4.0.5.2 rc
Comment 1 jvtechnik 2013-09-03 15:06:04 UTC
Created attachment 85120 [details]
Version: 4.1.1.2
Comment 2 Maxim Monastirsky 2013-09-12 11:35:17 UTC

*** This bug has been marked as a duplicate of bug 67744 ***
Comment 3 jvtechnik 2014-01-14 11:24:08 UTC
Tested with LibreOffice 4.1.4 -> Problem still exists
Comment 4 jvtechnik 2014-05-23 13:59:17 UTC
Still exist under versions:

LibreOfficeDev_4.3.0.0.beta1_MacOS_x86-64.dmg    22-May-2014 06:48
LibreOfficeDev_4.3.0.0.beta1_MacOS_x86.dmg   22-May-2014 06:48
Comment 5 Alex Thurgood 2014-06-06 22:42:48 UTC

*** This bug has been marked as a duplicate of bug 69254 ***
Comment 6 Thomas Linard 2018-01-05 09:58:10 UTC

*** This bug has been marked as a duplicate of bug 35538 ***
Comment 7 Thomas Linard 2018-01-23 13:58:24 UTC

*** This bug has been marked as a duplicate of bug 69254 ***
Comment 8 Tor Lillqvist 2018-02-22 19:08:47 UTC
The way bug #67744 was fixed, buy explicitly correcting the weight reported by the system for 'Courier Std: Medium' to zero ("medium"), means that it won't help for any other fonts. So this should probably be un-duplicated.
Comment 9 Commit Notification 2018-02-22 20:58:48 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f7733528e88a6619f82b54b59e92a9bca72c0a89

tdf#68889: Fix the weight reported by the system for the problematic font

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-02-23 18:35:49 UTC
Tor Lillqvist committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e092effee32cfbade59fb68adddc9db96d3c3c88&h=libreoffice-6-0

tdf#67744, tdf#68889: Fix weight reported by the system for these fonts

It will be available in 6.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.