Bug 68894 - Other: CMIS: GOOGLEDRIVE: LiberOffice crashes on startup.
Summary: Other: CMIS: GOOGLEDRIVE: LiberOffice crashes on startup.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other macOS (All)
: high major
Assignee: Cao Cuong Ngo
URL:
Whiteboard: BSA target:4.2.0
Keywords:
: 69735 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-03 16:08 UTC by Thomas van der Meulen
Modified: 2014-07-08 14:41 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Apple Crash report (51.98 KB, text/plain)
2013-09-03 16:11 UTC, Thomas van der Meulen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas van der Meulen 2013-09-03 16:08:29 UTC
Problem description: wen I add Google Drive and opened and closed a file/libreoffice and try to open it the next time LibreOffice crashes

Steps to reproduce:
1. add/connect to Google Drive
2. Open a file
3. close LibreOffice 
4.  Try to open LibreOffice again 
5. LibreOffice loading screen comes and after that is crashes....

Current behavior:
LibreOffice crashes

Expected behavior:
It opens normally
     
Work around: Delete the userprofile and then LibreOffice will work again but the connection to Google Drive is lost and wen you do step 1-5 again it will crash again...          
Operating System: Mac OS X
Version: 4.2.0.0.alpha0+ Master
Comment 1 Thomas van der Meulen 2013-09-03 16:10:59 UTC
Version: 4.2.0.0.alpha0+
Build ID: c2a9699e90abb40cbe1772cbd581435568468265

Downloaded it today.
Comment 2 Thomas van der Meulen 2013-09-03 16:11:21 UTC
Created attachment 85125 [details]
Apple Crash report
Comment 3 Cao Cuong Ngo 2013-09-03 16:58:53 UTC
Any idea Cedric? 
I think it may be related to the CheckOut windows problem we mentioned when leaving the application.
Comment 4 Commit Notification 2013-09-26 14:21:30 UTC
Cao Cuong Ngo committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=86218bda0d74fc5bfc877b5c12d594d527207b11

Fix fdo#68894 Cmis crashes on start up.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Cao Cuong Ngo 2013-09-26 14:23:21 UTC
Hi Thomas,

Please check if it still crashes on MacOS.

Thanks,
Cuong.
Comment 6 Thomas van der Meulen 2013-09-29 08:23:25 UTC
Hi, I would like to test this but I don't know how to build libreOffice on mac.. and the master from dev-builds.libreoffice.org are outdated. ....
Comment 7 Joel Madero 2014-03-08 23:56:20 UTC
*** Bug 69735 has been marked as a duplicate of this bug. ***
Comment 8 Joel Madero 2014-03-08 23:56:59 UTC
Can we close this as resolved? I believe this wasn't just a OSX issue and the solution seems to have resolved another possible google drive problem.
Comment 9 Vaughn Reid III 2014-03-09 18:27:35 UTC
This issue does appear to be resolved for me let's go ahead and mark it as
fixed.
On Mar 8, 2014 6:56 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  Joel Madero <jmadero.dev@gmail.com> changed bug 68894<https://bugs.freedesktop.org/show_bug.cgi?id=68894>
>  What Removed Added  CC   jmadero.dev@gmail.com
>
>  *Comment # 8 <https://bugs.freedesktop.org/show_bug.cgi?id=68894#c8> on
> bug 68894 <https://bugs.freedesktop.org/show_bug.cgi?id=68894> from Joel
> Madero <jmadero.dev@gmail.com> *
>
> Can we close this as resolved? I believe this wasn't just a OSX issue and the
> solution seems to have resolved another possible google drive problem.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>
>