Download it now!
Bug 68948 - Other: Problem with graphs in Writer when data series in rows
Summary: Other: Problem with graphs in Writer when data series in rows
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2013-09-04 18:07 UTC by Gorka Navarrete
Modified: 2015-12-15 10:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer file with the problematic graphs (47.66 KB, application/vnd.oasis.opendocument.text)
2013-09-04 18:07 UTC, Gorka Navarrete
Details
ODS file with a 2x2 table (15.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-03 16:43 UTC, Gorka Navarrete
Details
The graph issue encapsulated (21.46 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2013-12-15 15:27 UTC, Roy Coleman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gorka Navarrete 2013-09-04 18:07:48 UTC
Created attachment 85205 [details]
Writer file with the problematic graphs

Problem description: If I copy from Calc to Writer a graph whose data series are in rows (Data ranges), it automatically adds a new row of data and hence, the graph changes, creating and extra (empty) space.

That does not happen when data series are in columns.

Steps to reproduce:
1. Create 2x2 graph
2. In Data range, select: data series in rows
3. Copy graph
4. Paste in writer

Current behavior: The Calc graph copied changes having an extra blank space. If you double click the graph, then right click and select chart data table you will see an extra (empty) row. This does not happen when the data series are in columns.

Also, if you delete the extra row the graph looks as it should. But, if you save the document and reopen it, the extra line is there again.

Expected behavior: The graph is copied as it is and no extra rows are added.
              
Operating System: Ubuntu
Version: 4.1.0.4 release
Comment 1 ign_christian 2013-10-03 03:25:39 UTC
Hi Gorka, is that problem still reproducible on LO 4.1.1.2 or 4.1.2.3 ? Otherwise please attach your spreadsheet file so we can test.

Have you experienced that works properly in version before 4.1.0.4 ?
Comment 2 Gorka Navarrete 2013-10-03 16:43:25 UTC
Created attachment 87049 [details]
ODS file with a 2x2 table

If you copy the graph in the ods file to a odt document, the described problem occurs.
Comment 3 Gorka Navarrete 2013-10-03 16:46:30 UTC
The problem is reproducible in 4.1.2.2, the default LO in Ubuntu 13.10.

Not sure about when the problem started though. 

Thanks!
Comment 4 ign_christian 2013-10-04 08:53:25 UTC
I'm sorry I don't clearly understand your description. I thought I understand but I don't. 

I just tried to copy chart from your ODS (which already has data series in rows) to Writer, same result...didn't see anything wrong. Might be I misunderstood.. please give step by step procedure to reproduce problem so anyone could easily triage the problem.

Tested on LO 4.0.6.1 (Win7 32bit)
Comment 5 Gorka Navarrete 2013-10-11 12:12:14 UTC
Hi ign_christian,

It may be a Linux only problem?

The steps to reproduce are as follows:

1. Open calc, introduce any four numbers in 4 difference cells as follows:

6	5
3	4

2. Select the four cells containing numbers and create a graph.

3. In 2. Data Range, select "Data series in rows". Finish.

4. Select the graph, copy and paste in a Writer document.

You will see an extra space to the right of the graph that should not be there.

Let me know if you manage to reproduce it.

Thanks.
Comment 6 ign_christian 2013-10-11 13:13:08 UTC
Hi Gorka, thanks for the clear steps :)
Let me modify a bit to make it clearer:
> 3. In 2. Data Range, select "Data series in rows". Finish.
4.a. Click anywhere outside the graph
> 4.b. Select the graph, copy and paste in a Writer document.
(paste in new text document in Writer)

> You will see an extra space to the right of the graph that should not be
> there.
Still can't reproduce on LO 4.0.6.1 (Win 7 32bit). My suscpicion is bug within LO 4.1.x.

Changing status back to UNCONFIRMED to let someone confirm that
Comment 7 Dominique Boutry 2013-10-20 16:07:48 UTC
Reproduced with LibO 4.1.2.3 on Win7
Comment 8 dylanbrtlett 2013-10-28 21:16:12 UTC
Cannot reproduce with attached files but i can confirm I am receiving identical symptoms.
Comment 9 bombaj-79 2013-11-04 18:23:46 UTC
Yes. I've got the same problem using 4.1.2 and 4.1.3.

I created graph in Calc... Copied to Writer and in my opinion data are shown wrong (but if opened in 3.4.x everyting is allright) - series in colums are swithed with series in rows - that's why are empy rows or colums, but some data are lost...
Comment 10 bombaj-79 2013-11-04 18:28:22 UTC
oh... i'm using win 7 with 4.1.3, win 8.1 with 4.1.2 (graph showm incorrectly) and old computer wit win xp and some old verion 3.x (graph shown correctly)
Comment 11 Owen Genat (retired) 2013-11-23 09:25:18 UTC
This would seem a clear regression. Under Ubuntu 10.04 running these versions:

- v3.3.0.4 OOO330m19 Build: 6
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

... opening the attachment to comment #2 in Calc and pasting into the corresponding version of Writer, only v4.1.3.2 copies the chart incorrectly. I will leave it for QA to set the Whiteboard and Keywords accordingly.
Comment 12 Jean-Baptiste Faure 2013-11-23 18:17:29 UTC
Not reproducible for me with version 4.1.4.0.0+ under Linux / Ubuntu 64 bits.

Best regards. JBF
Comment 13 Roy Coleman 2013-12-15 15:27:49 UTC
Created attachment 90802 [details]
The graph issue encapsulated

..this may assist hopefully
Comment 14 Roy Coleman 2013-12-15 15:34:40 UTC
Only the graph based on column data exports correctly to Writer. ( LO 4.1.3.2 Vista 64)
Comment 15 QA Administrators 2015-04-19 03:23:03 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 16 Jean-Baptiste Faure 2015-04-20 04:49:52 UTC
Works as expected in LibreOffice 4.4.4.0.0+ built at home under Ubuntu 14.10 x86-64.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF
Comment 17 Robinson Tryon (qubit) 2015-12-15 10:53:46 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]