Download it now!
Bug 69030 - Multiple instances of the Unity launcher icon for the same LO-App (e.g. writer) instead of grouping
Summary: Multiple instances of the Unity launcher icon for the same LO-App (e.g. write...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-06 12:14 UTC by Martin Wildam
Modified: 2015-04-12 08:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Unity Launcher bar with multiple instances of Writer (37.23 KB, image/png)
2013-09-06 12:14 UTC, Martin Wildam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Wildam 2013-09-06 12:14:27 UTC
Created attachment 85325 [details]
Unity Launcher bar with multiple instances of Writer

When I start LibreOffice (no matter which of the sub-apps Writer, Calc etc) by double-clicking a .od*-File, I get one icon instance in the Unity launcher for each opened document. But in that case those should be grouped together instead of showing a second time the same icon (see screenshot). It further doesn't matter if LibreOffice Writer/... was already pinned/locked to the launcher before. If it was already pinned/locked to the launcher before then anyway a new instance of the icon is displayed.

I have two different computers with the same effect so I don't think of a misconfiguration of my local computer.

I also noticed that same Ubuntu-Version (12.04) on an older 32-bit laptop with older LibreOffice (having v3.5.7.2 there) works flawlessly. I cannot tell for sure when the issue started to occur, but I am pretty sure that with LO 4.0 I did not have the issue. The older laptop is 32-bit - can this make a difference here? I don't think so.

Some bug reports in Ubuntu tell about bamf package being the culprit, but I don't really think so because the older laptop has the same bamf version installed. See
https://bugs.launchpad.net/ubuntu/+source/bamf/+bug/1076018
https://bugs.launchpad.net/bamf/+bug/1077518
https://bugs.launchpad.net/bamf/+bug/1026426

I made further tests while writing this and noticed that when double-clicking *.docx documents for example the grouping works as it then groups all those icons together where a *.docx document is opened. Strangely all *.odt document windows remain as ungrouped separate instance.

I wonder what the difference is in window handling depending on the mimetype or file extension.
Comment 1 Martin Wildam 2013-09-06 12:25:25 UTC
Not to mix up with
https://bugs.freedesktop.org/show_bug.cgi?id=46116
as of course LibreOffice Writer and Calc etc should not group alltogether.
Comment 2 Jean-Baptiste Faure 2013-09-14 06:22:14 UTC
I reproduce the problem with LO 4.1.2.1, LO 4.1.3.0.0+ (build at home in release mode) and master.
No grouping for ODF files, grouping works for docx files.
There is something changed with 4.1 because it works as expected for me with LO 4.0.5 (generic Linux version).

Best regards. JBF
Comment 3 Marco Trevisan (Treviño) 2013-10-10 16:24:52 UTC
The bug itself is only partially in LO... The new version includes the StartupWMClass strings to the .desktop file, and that's fine to improve matching but this leads to problems in unity since LO updates the window class values very slowly (after that it sets the new window title) and this confuses old BAMF versions.

A workaround for precise users using LO 4.1 is just removing this key from the .desktop files by using:

  sudo sed '/StartupWMClass=.*/d' -i /usr/share/applications/libreoffice-*.desktop

More at https://bugs.launchpad.net/bamf/+bug/1238122
Comment 4 Jean-Baptiste Faure 2013-10-12 09:40:48 UTC
Thank you Marco for the workaround, but I have the same problem with the generic Linux version on Ubuntu 13.04 and this workaround does not work in this case.

Best regards. JBF
Comment 5 QA Administrators 2015-04-01 14:41:25 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 6 Jean-Baptiste Faure 2015-04-12 08:53:36 UTC
Not reproducible with my own builds of LibreOffice 4.4.x under Ubuntu 14.10.

Closing as WorksForMe.

Best regards. JBF