Bug 69033 - Formatting issues in DOCX to PDF export
Summary: Formatting issues in DOCX to PDF export
Status: RESOLVED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-06 12:56 UTC by bugzilla
Modified: 2015-07-20 05:11 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
original docx which was converted to PDF (90.38 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-09-06 12:56 UTC, bugzilla
Details
PDF with shifted lines (73.34 KB, application/pdf)
2013-09-06 12:57 UTC, bugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2013-09-06 12:56:26 UTC
Created attachment 85350 [details]
original docx which was  converted to PDF

Problem description: A MS Word docx file was converted into a PDF by LibreOffice 4.1. Some formatting issues occured like texts cut or moved to the next line.

Steps to reproduce:
1. Use LibreOffice 4.1 to create a PDF from the attached testdocument.docx. The output we created is attached as well.
2. Compare docx and PDF.


Current behavior:
- In the head of the letter on the right side, the last line is cut.
- The date is moved to the next line and aligned left, but it should be placed one line further up and aligned right. Looks like one tabulator hop too much.
- Below the tables are lines with the total amount. In the docx, this lines are bordered by a double line but in the PDF it's black bars.
- The PDF has 4 pages instead of 3 because some lines shifted.

Expected behavior: The PDF should look like the docx.

              
Operating System: Windows 7
Version: 4.1.0.4 release
Comment 1 bugzilla 2013-09-06 12:57:07 UTC
Created attachment 85351 [details]
PDF with shifted lines
Comment 2 tommy27 2013-09-29 01:53:17 UTC
(In reply to comment #0)

tested with 4.1.0.4 and 4.1.1.2 under Win7 64bit
> 
> Current behavior:
> - In the head of the letter on the right side, the last line is cut.

please provide a screenshot with arrows on the line are you talking about.
in my PC last line looks already cut in the original .docx file as well, but I need to be sure we are talking of the same line.

> - The date is moved to the next line and aligned left, but it should be
> placed one line further up and aligned right. Looks like one tabulator hop
> too much.

again, post screenshot. if you are talking of "29. september 2013, it looks already aligned left in the original .docx file and has same position in the .pdf output.

> - Below the tables are lines with the total amount. In the docx, this lines
> are bordered by a double line but in the PDF it's black bars.

confirmed. double line in .docx and thick single line in .pdf

> - The PDF has 4 pages instead of 3 because some lines shifted.

In my PC the .docx has already 4 pages as the .pdf export.

>               
> Operating System: Windows 7
> Version: 4.1.0.4 release

did you try upgrading to 4.1.1.2 and see what happens?
Comment 3 bugzilla 2013-10-01 14:49:16 UTC
Thank you very much for your investigation and your remarks. We updated to 4.1.1.2, with the same result as before. But we found out that the behaviour - except of the double / single line problem - already occurs after the docx has been opened by LibreOffice.

I will create new issues, attach screenshots, and add the links in See Also.
Comment 4 bugzilla 2013-10-02 11:01:44 UTC
Bug 69033, 70007, 70032 and 70033 are all based on one and the same test document.
Comment 5 tommy27 2013-10-03 09:38:00 UTC
I set status to RESOLVED MOVED since the original bug report mixed 3 issues that now have been filed separately in Bug 70007, Bug 70032 and Bug 70033