Bug 69043 - INSTALLATION: On MS-Windows 7, upgrade using 'LibreOffice_4.1.1_Win_x86.msi' systematically complains that it needs to update files which are opened by 'Microsoft Windows Search Filter Host'
Summary: INSTALLATION: On MS-Windows 7, upgrade using 'LibreOffice_4.1.1_Win_x86.msi' ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.2.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 94282 (view as bug list)
Depends on:
Blocks: Installer-Windows
  Show dependency treegraph
 
Reported: 2013-09-06 16:03 UTC by Etienne URBAH
Modified: 2021-03-05 04:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Etienne URBAH 2013-09-06 16:03:51 UTC
On MS-Windows 7, 'LibreOffice_4.1.1_Win_x86.msi' systematically complains that it needs to update files which are opened by 'Microsoft Windows Search Filter Host'.

On 2 different computers, I requested to ignore this issue :
- On a powerful computer running MS-Windows 7 PRO, 'LibreOffice_4.1.1_Win_x86.msi' installed LibreOffice version 4.1.1.2, which seem to work correctly.
- On a slow computer running MS-Windows 7 HOME, 'LibreOffice_4.1.1_Win_x86.msi' displayed an error code (I apologize, but I do NOT remember its value).
Comment 1 Etienne URBAH 2013-09-09 13:03:04 UTC
On the slow computer running MS-Windows 7 HOME :

-  The failed installation of LibreOffice 4.1.1 seems to have cleanly uninstalled LibreOffice 4.1.0

-  When I tried again to run 'LibreOffice_4.1.1_Win_x86.msi', it installed LibreOffice version 4.1.1.2, which seems to work correctly.

So the problem seems to appear only when trying to upgrade LibreOffice.
Comment 2 Oliver 2013-10-16 07:10:53 UTC
I have got the same problem on a windows 7 laptop : only with the newest version 4.1.2.3 the installation process complains that the
"Microsoft Windows Search Filter Host" uses a file that needs to be update
this is probably the "searchProtocolHost.exe" programm

stopping this programm in the task manager and re-trying installation gives a new error : giving only a process ID, but which points to SmcService, which is a Symantec management Client. 
I actually have upgraded since the last LibreOffice installation my antivirus to 
Symnatec Endpoint protection V 12.1.3001.165

And I guess that this is what is causing the problem.
I tried several times to stop the "searchProtocolHost.exe" and retry installation, and after several trials it worked and installation continued. 

Cheers

Oliver
Comment 3 pierre-yves samyn 2013-10-27 11:45:53 UTC
Hello

Reproduced (fr-user) with 4.0.6.2
Error : "microsoft windows search filter host (process id 4116)"

The user found this workaround : 
- disable "Windows Search" via "Control Panel \ Programs \ Programs and Features"
- install LibreOffice
- reinstall "Windows Search"

Regards
Pierre-Yves
Comment 4 Harald Koester 2013-11-27 12:53:44 UTC
I got the same message according search filter host process. I ignored this message (Click on "Ignore") and continued the installation and LibreOffice was installed - at least in my case - correctly.

As far as I know, the search filter host process is a background process that is used to update the index for Windows Search. It may take hours (or even longer) until the index is updated, but it should not effect the system performance significantly. It seemed to me that an installation or deinstallation of LibreOffice triggers the update of the index.
Comment 5 Maxim Monastirsky 2013-11-28 06:41:25 UTC
(In reply to comment #4)
> It seemed to me that an installation or
> deinstallation of LibreOffice triggers the update of the index.
More likely it's related to Bug 56035, which was fixed towards 4.1.4. So hopefully you won't see this bug when upgrading *from* 4.1.4.
Comment 6 Etienne URBAH 2013-12-23 14:23:28 UTC
On upgrade to version 4.1.4.2, this bug did NOT show up.
Comment 7 Frederic Da Vitoria 2014-05-11 15:02:23 UTC
Issue reappeared when upgrading from 4.1.5.3 to 4.1.6
Comment 8 Frederic Da Vitoria 2014-05-11 16:32:58 UTC
Sorry, I forgot to mention: I'm running Windows 7 64 bits.
Comment 9 Robert Impey 2014-09-09 22:33:55 UTC
I got the same error in Windows 8.1 Pro 64 with the installation file: LibreOffice_4.2.6-secfix_Win_x86.msi. 

However, this seems to be intermittent as after a restart it failed then succeeded after hitting retry in the error dialog box.
Comment 10 QA Administrators 2015-10-14 19:57:08 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2016-11-08 11:18:15 UTC Comment hidden (obsolete)
Comment 12 Harald Koester 2017-02-10 19:45:36 UTC
In order to find out if this bug is still a problem, I searched for duplicates in Bugzilla. The latest one is bug 94282. According that bug report the latest version where this bug occured is 4.4.5.2. I did not find any complaints respective later versions. So it seemed that this bug has been solved meanwhile. 

Hence I tend to close this bug with RESOLVED WORKSFORME. 
Other suggestions?
Comment 13 skierpage 2017-02-28 22:47:05 UTC
This happened when I installed 5.2.3.3 on a Windows 10 laptop, so it is not fixed.

The installer warned me that (approximately) The application Microsoft Windows Search Filter Host was using one of the files and invited me to close it.

That's a system service. I used Task Manager > Processes, clicked (v)More details to show additional processes, found Microsoft Windows Search Index, and right-clicked on it to end task. ([sic], that's what I have in my notes, install reported Search Filter Host but for some reason I killed Search Index.) 

I am not using any antivirus beyond Windows Defender, the default in Windows 10.

To reproduce you would probably have to copy a lot of random files into your Documents folder before starting LibreOffice install; or in the control panel Indexing Options > Advanced, click [Rebuild] and then start the LibreOffice install. Even then that might not be sufficient to trigger the conflict if particular operations in the installer and Microsoft Windows Search service have to overlap. You might have to do something else in Task Manager such as run as System Administrator to see the Microsoft Windows Search service(s).

Thanks for all y'all do for LibreOffice!
Comment 14 QA Administrators 2018-03-01 03:41:34 UTC Comment hidden (obsolete)
Comment 15 Harald Koester 2018-03-02 10:55:36 UTC
*** Bug 94282 has been marked as a duplicate of this bug. ***
Comment 16 QA Administrators 2019-03-04 03:53:24 UTC Comment hidden (obsolete)
Comment 17 Mike Kaganski 2019-03-05 19:03:33 UTC
If I understand it correctly, the problem discussed here is specific to the warning issued by installer that some files required to be updated are in use by Microsoft Windows Search Filter Host.

This is not a bug. Since LibreOffice provides an Explorer extension (a DLL) capable of providing data to the Windows Search, it's normal that at times the Windows Search indexing service is active, the shell extension is used. When it's used, it naturally can't be updated without a restart. And this is not a bug or error. This is not something that might or should be changed. The warning tells that reboot would be required if user doesn't shut down the process, and suggests rebooting if used does not stop the service.

The installation errors mentioned in comment 1 might be an unrelated, or specific to some old version of installer (I doubt the latter, actually).

Despite use of Windows Restart Manager was included in LibreOffice Windows installer, the Restart Manager can only automatically restart processes owned by currently logged on user, so it cannot restart services.

I propose to close it NOTABUG.
Comment 18 QA Administrators 2021-03-05 04:18:56 UTC
Dear Etienne URBAH,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug