Download it now!
Bug 69094 - HTML documentation: link to inherited member should go to inherited interface
Summary: HTML documentation: link to inherited member should go to inherited interface
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: sdk (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: UNO
  Show dependency treegraph
 
Reported: 2013-09-08 11:56 UTC by Lionel Elie Mamane
Modified: 2019-09-24 07:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2013-09-08 11:56:57 UTC
Take e.g. http://api.libreoffice.org/docs/idl/ref/interfacecom_1_1sun_1_1star_1_1frame_1_1XTerminateListener2.html

Under "Public Member Functions inherited from XTerminateListener", there is e.g.
queryTermination
The "queryTermination" word is a link to
http://api.libreoffice.org/docs/idl/ref/interfacecom_1_1sun_1_1star_1_1frame_1_1XTerminateListener.html#a70b244d6dc5a5f95b9a315292de29d54

That's good and correct. However, the "more" word is a link to
http://api.libreoffice.org/docs/idl/ref/interfacecom_1_1sun_1_1star_1_1frame_1_1XTerminateListener2.html#a70b244d6dc5a5f95b9a315292de29d54
That's incorrect. It should be the same as the previous one; the "more" information is at XTerminateListener.html (where the member function is defined), not XTerminateListener2.html (where it is "merely" inherited).
Comment 1 QA Administrators 2015-07-18 17:44:40 UTC Comment hidden (obsolete)
Comment 2 Buovjaga 2015-10-23 17:18:35 UTC
Confirmed.
Comment 3 QA Administrators 2016-11-08 11:35:31 UTC Comment hidden (obsolete)
Comment 4 Thomas Lendo 2018-09-22 02:40:06 UTC
Still reproducible.
Comment 5 QA Administrators 2019-09-23 02:54:16 UTC Comment hidden (obsolete)
Comment 6 Thomas Lendo 2019-09-24 07:38:36 UTC
Can't reproduce anymore. Closing as WFM.