Bug 69280 - UI: Comments toggle button should be on the left side of the ruler when locale set to RTL language
Summary: UI: Comments toggle button should be on the left side of the ruler when local...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Linux (All)
: medium minor
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:4.2.0
Keywords:
Depends on:
Blocks: rtl-meta
  Show dependency treegraph
 
Reported: 2013-09-12 17:00 UTC by Maxim Monastirsky
Modified: 2013-09-20 18:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (Fedora 19) (57.46 KB, image/png)
2013-09-12 17:00 UTC, Maxim Monastirsky
Details
screenshot with RTL paragraph (Fedora 19) (59.92 KB, image/png)
2013-09-15 16:10 UTC, Maxim Monastirsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Monastirsky 2013-09-12 17:00:56 UTC
Created attachment 85729 [details]
screenshot (Fedora 19)

Steps to reproduce:
1) Set locale to some RTL language (like Arabic or Hebrew) (through Tools->Options...->Language settings->Languages->locale setting)
2) Open Writer and add comment (Insert->Comment)
3) As you can see the comment appears on the left side of the page, while the toggle button (which was added due to bug 38246) appears on the right side of the ruler, not above the comments.

Tested with LO 4.1.1.2 under both Ubuntu 13.10 & Fedora 19.
Comment 1 Maxim Monastirsky 2013-09-15 16:10:45 UTC
Created attachment 85871 [details]
screenshot with RTL paragraph (Fedora 19)

Also please note that when paragraph's direction is RTL, you don't see the tab
icon on the top ruler (probably because comments toggle button covering it, or pushing it too much to right). So it's missing functionality, not just cosmetic issue.
Comment 2 Lior Kaplan 2013-09-15 21:08:21 UTC
Bug confirmed (4.1.1.2 on Debian 64bit). The tab icon is available if you zoom out a little (meaning it's there, but covered as you thought).
Comment 3 Commit Notification 2013-09-18 10:47:22 UTC
Abdulaziz A Alayed committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d86a72b64f208fe55f302d9fd8a7f578a4275bb8

fdo#69280 fixing comments toggle button position when local



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Lior Kaplan 2013-09-20 18:43:37 UTC
Fix verified on a build from master.