Bug 69290 - LibreOffice opens .tsv and .csv files in writer not calc
Summary: LibreOffice opens .tsv and .csv files in writer not calc
Status: CLOSED DUPLICATE of bug 68903
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-12 19:56 UTC by Leon French
Modified: 2013-11-21 13:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leon French 2013-09-12 19:56:10 UTC
Opening .tsv and .csv files with LibreOffice opens the file in writer instead of calc. The behaviour I expected is to open in calc (the previous LibreOffice version I had, opened in calc). 

This is not easy to fix in Mac as I can't just change open with to "Calc", only LibreOffice executable is available to open with. 

If I open the file from Calc directly it works fine but I'd like to be able to open files from the Mac File browser/Finder.
Comment 1 Alex Thurgood 2013-09-13 09:38:59 UTC
This works for me in 4.1.1.2 on OSX.

If I right mouse button click on a CSV file and choose LibreOffice 4.1, a CSV file opens correctly in Calc via the csv import wizard.

Alex
Comment 2 Alex Thurgood 2013-09-13 09:43:22 UTC
In 4.0.5.2 on OSX, if I do the same thing, i.e. right mouse button click on a CSV file and choose Open with LO 4.0.5.2, then I just get the start screen.

If I drag and drop the file onto a running instance of LO 4.0.5.2, I get the Calc CSV import wizard, and the file opens in Calc.
Comment 3 Leon French 2013-09-13 14:08:02 UTC
Thanks for looking into it.

I upgraded my version to 4.1.1.2 and .csv files open in calc - sorry I didn't check this sooner. However, tab separated files (.tsv) still open in writer. Could the same procedure for csv files be applied to tsv?
Comment 4 Alex Thurgood 2013-09-13 15:54:07 UTC
@Leon : did tsv files ever open directly in Calc in previous versions ? If they didn't, then this can only be an enhancement request, which quite possibly is an already known issue (I haven't checked, but it sounds familiar).

Alex
Comment 5 Alex Thurgood 2013-09-13 15:58:02 UTC

*** This bug has been marked as a duplicate of bug 61557 ***
Comment 6 Leon French 2013-09-13 16:19:24 UTC
Yes, I'm pretty sure .tsv files did open in calc in my previous version ( I can't remember the details).

Thanks for finding the similar bug - I added a comment to that one.
Comment 7 Maxim Monastirsky 2013-09-14 19:50:07 UTC
It's better to mark it as a duplicate of Bug 68903. And as you can see from this bug it worked with 4.0, so it's not related to bug 61557 at all, because the latter was reported against 3.6.

*** This bug has been marked as a duplicate of bug 68903 ***